locked
Forms Not Being Displayed in Win7 x64 RRS feed

  • Question

  • Corporate just upgraded my laptop to Win 7 Pro x64. Now that I have VFP9 SP2 installed, forms are not visable when running. These are the same forms and apps built in Win 7 Pro x32. I have set compatability to XP SP3 and run as admin to no avail. Anyone have suggestions?
    Thursday, September 22, 2011 3:35 PM

Answers

  • Top level form never were able to be modal, in no windows version. If you set a form to be top level the modal setting simply is ignored. As you experience a problem since changing the OS the question what really changed. Have you tried the nely compiled ex on XP? you can install a virtual machine to do such tests. Modal and Top Level is not compatible to each other by regulation of windows itself, always has been that way. Maybe your project just misses a READ EVENTS eg at the end of your start program.

    Bye, Olaf.

    Sunday, September 25, 2011 12:49 PM

All replies

  • Do you mean you don't see the forms in run-time? Do you see them OK in design time? If yes, see which are non-default properties - some non-default property may be responsible.

    Also, delete foxuser file if it's there.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    • Edited by Naomi N Thursday, September 22, 2011 4:17 PM
    Thursday, September 22, 2011 4:17 PM
  • Correct. I can see the forms in Design mode, but not in run-time. I have been doing more testing on it and have found that it is related to Modal Forms. The forms are visible in run-time if Modeless. Unfortunately, the application and environment does require these forms to be Modal to remain open at all times.

    Thursday, September 22, 2011 5:16 PM
  • That does not make much sense. May be the top/left etc. got set to wrong numbers in run-time? Or the form doesn't have focus?

    Are you running in screen or as top window?

    Try adding something like 'wait window thisform.top' in the form's init to see if the form is run, but not visible.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog
    Thursday, September 22, 2011 9:59 PM
  • I have narrowed it down to be the FormSet.WindowType.  If set to Modeless, the form will display properly as an auto-centered top level form. Change the WindowType value of the FormSet to Modal, and the form runs (verified by a Wait Window in Form.Init), but is not visible at any level. Since the form is not visible, the only way to regain control is to close VFP and restart it.
    Friday, September 23, 2011 9:53 PM
  • If you change the order of DoCreate and BorderStyle in the .scx file does it still occur?

    in a VFP window, type "use <formname>.scx", scroll down the properties column, hover over the Memo (this pops a tooltip with the data in the memo field).  Locate the DoCreate and BorderStyle properties. Ensure that BorderStyle occurs before DoCreate.  IF you need to you can double click to edit.

    If you find this to be the problem, let me know (gmc94son at hotmail dot com) and I will forward you a prg that recursively finds all forms in a directory and reorders those two properties.

    HTH
    Rob.

     

    Saturday, September 24, 2011 10:59 PM
  • I never used FormSet, so I can not really advise anything here - I think most of the people in VFP world don't use them.
    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog
    Sunday, September 25, 2011 1:26 AM
  • Top level form never were able to be modal, in no windows version. If you set a form to be top level the modal setting simply is ignored. As you experience a problem since changing the OS the question what really changed. Have you tried the nely compiled ex on XP? you can install a virtual machine to do such tests. Modal and Top Level is not compatible to each other by regulation of windows itself, always has been that way. Maybe your project just misses a READ EVENTS eg at the end of your start program.

    Bye, Olaf.

    Sunday, September 25, 2011 12:49 PM