locked
Help with Server Error in Clubsite RRS feed

  • Question

  • User1621561754 posted

    I am getting the following error what do I need to do?

    Server Error in '/' Application.

    The connection name 'ClubSiteDB' was not found in the applications configuration or the connection string is empty.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: The connection name 'ClubSiteDB' was not found in the applications configuration or the connection string is empty.

    Source Error:

    The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

    1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

      <%@ Page Language="C#" Debug="true" %>

    or:

    2) Add the following section to the configuration file of your application:

    <configuration>
       <system.web>
           <compilation debug="true"/>
       </system.web>
    </configuration>

    Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

    Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.

    Stack Trace:

    [InvalidOperationException: The connection name 'ClubSiteDB' was not found in the applications configuration or the connection string is empty.]
       System.Web.Compilation.ConnectionStringsExpressionBuilder.GetConnectionString(String connectionStringName) +2959805
       ASP.default_aspx.__BuildControlSqlDataSource1() +96
       ASP.default_aspx.__BuildControlContent1(Control __ctrl) +208
       System.Web.UI.CompiledTemplateBuilder.InstantiateIn(Control container) +12
       ASP.default_master.__BuildControlContentPlaceHolder1() +101
       ASP.default_master.__BuildControlform1() +87
       ASP.default_master.__BuildControlTree(default_master __ctrl) +193
       ASP.default_master.FrameworkInitialize() +34
       System.Web.UI.UserControl.InitializeAsUserControlInternal() +31
       System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) +1980896
       System.Web.UI.Page.get_Master() +48
       System.Web.UI.Page.ApplyMasterPage() +18
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +543
    

    Wednesday, November 15, 2006 8:55 AM

All replies

  • User959264866 posted
    Check your connectingString. Make sure it is pointing to the Club.mdf
    Wednesday, November 15, 2006 12:53 PM
  • User1621561754 posted

    My problem is I have loaded SLQ 2005 and created several databases  database1, database2, database3 each of this databases are shown in my server explorer in my VS2005  as gremlin.database1.dbo ,gremlin.database2.dbo, and gremlin.database3.dbo also listed are club.mdf and aspnetdb.mdf

    My current connection strings in vs look like this

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <appSettings/>

    <connectionStrings>

    <add name= "3378372ConnectionString" ConnectionString="Data Source=Gremlin;Intial Catalo=database1;Interated Securiy=True"

    providerName="Sytem.Data.SQLClient" />

    <add name="rac_20050428ConnectionString1" connectionString="Data Source=Gremlin;Initial Catalog=database2;Integrated Security=True"

    providerName="System.Data.SqlClient" />

    <add name="racConnectionString1" connectionString="Data Source=Gremlin;Initial Catalog=database3;Integrated Security=True"

    providerName="System.Data.SqlClient" />

    </connectionStrings>

    I also have a connection string that pathed to sqlexpress that was loaded at the time of download of the clubsite. It has the club.mdf included

     

    Any suggestions

    Wednesday, November 15, 2006 1:23 PM
  • User1988740161 posted

    Does anyone have an answer to this question.  I am getting the exact same error message after moving a website into "unlimited" hosting on Godaddy under another website (primary).

     

    The error is coming from the content page default.aspx at the following line

    <asp:SqlDataSource ID="SqlDataSource1" runat="server" ProviderName="System.Data.SqlClient"
                        ConnectionString="<%$ ConnectionStrings:ClubSiteDB %>" SelectCommand="SELECT top 5 [id], [itemdate], [title], [description], [photo] FROM [Announcements] order by itemdate desc">
                    </asp:SqlDataSource>

    Can anyone help?  Thanks, Bev
     

    Tuesday, July 20, 2010 5:59 PM