none
How to remove this annoying blue line after double clicking on an compiler error in Visual Studio 2015 Enterprise

    Question


  • Click here to zoom in I went through ALL options of this product. Didn't find anything that removes it!

    Someone must tell me how to do this, because I can't figure this out myself.

    Believe me I tried! I am so upset and angry now!
    If I won't solve this problem soon, I will uninstall this product from my computer forever!
    Saturday, December 24, 2016 9:49 PM

Answers

  • Go to Tools => Options => Text Editor => General => and under the "Display" label, check "Indicator margin"
    Wednesday, December 28, 2016 6:23 PM

All replies

  • The Visual Studio is working correctly. You clicked on the error, and the IDE is highlighting the line that is responsible for the error.

    You can "remove this annoying blue line" by fixing your code.

    Saturday, December 24, 2016 11:12 PM
  • The Visual Studio is working correctly. You clicked on the error, and the IDE is highlighting the line that is responsible for the error.

    You can "remove this annoying blue line" by fixing your code.

    True, but still I don't want to see this blue line, even if there is an error on any line, because in the past, I didn't see this blue line anywhere in the code, even if there were errors. This is new that suddenly it appears in my code. It's annoying and frustrating me to see it every time I click on an error. I always mess up with many/plenty/numerous, even endless errors when working on everything or every project. I don't want to see this blue line everywhere and all the time. Never! There must be another way and option to remove it, rather than correct the error. Don't worry about me, I am aware of all errors in my program. I am experienced programmer. Intellisense and error list is enough for me, I don't need and I don't want to see this blue line ever! I always succeed to solve all my errors eventually without this blue line and that's what I will always do. So please just tell me how to remove or get rid of it or prevent it from showing already.
    Sunday, December 25, 2016 12:22 AM
  • I am about to uninstall and remove Visual Studio Enterprise 2015 from my computer forever!

    You have been warned!

    Sunday, December 25, 2016 10:48 AM
  • True fact is that when I choose to reset all settings in TOOLS->Import and Export settings..., the blue line disappears and a bullet is shown instead. I don't care about the bullet. It's not annoying and frustraiting me, only the blue line. How's that? What setting does "Reset all settings" overwrites that does it!? Why I don't find it myself!? Why I need to reset all my settings to get rid of this blue line? Why reset all my settings is the only option to get off this blue line? Why Microsoft Visual Studio is so lame!?

    After that I see someone proposed my previous reply as answer, I am really going to uninstall this product from my computer forever and I won't follow this thread anymore. Never!


    Sunday, December 25, 2016 5:37 PM
  • Hi forever a loser,

    You could remove the color line as following steps:

    Choose Tools -> Options -> Environment -> Fonts and Colors -> Display items -> Highlighted Definition:

    In Highlighted Definition, you could set item foreground and item background color to black.

    After setting as above the blue line is gone in my side.

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, December 26, 2016 11:08 AM
  • Go to Tools => Options => Text Editor => General => and under the "Display" label, check "Indicator margin"
    Wednesday, December 28, 2016 6:23 PM