Required Digital Signature for USBSER.SYS file in Windows 7 Embedded Standard OS?


  • The company I work for has a product with a USB Device port implementing the CDC class. Our driver is based on Microsoft's USBSER.SYS driver and we provide the specific INF files so that our product installs as a virtual COM port. It works well on Windows XP, Vista and Windows 7 32-bit & 64-bit versions.

    We need them to test in Windows 7 Embedded standard 32-bit and 64-bit OS. But there is no USBSER.SYS file in both the OS. We read some forum and found to use the Windows 7 Ultimate (32-bit) OS, usbser.sys (with our INF file) in Windows 7 Embedded standard 32-bit OS and it worked properly. And we tried to use the Windows 7 Ultimate (64-bit), usbser.sys file (with our INF file) in Windows 7 Embedded Standard 64-bit OS, but it showed error message like “Driver does not contain digital signature information”.

    For testing purpose, in Windows 7 Embedded Standard 64bit OS, while booting we pressed F8 and selected "Disable driver signature enforcement" to disable the signature checking process and updated the driver properly. After restart the system without pressing F8, It shows the following error message:

    “Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damage, or that might be malicious software from an unknown source. (Code 52).”

    And in “Driver File Details” tab, it shows the Digital Signer as “Not digitally signed”.

    USBSER.SYS driver file is belonging to the Microsoft, and then why it need to digitally sign the driver file?

    Could anyone help us, what is missing to run this INF successfully for Windows 7 Embedded Standard 64-bit OS?

    • Edited by vaionix_live Tuesday, December 11, 2012 12:04 PM
    Tuesday, December 11, 2012 10:55 AM

All replies

  • Did you try the search function?

    It shows that "Compaq USB Modem Driver" contains usbser.sys,

    You'll find it hiding under  Packages > Driver > Modem

    It is rather surprising, since my USB of choice is the FTDI chip (prolific are a pain). I need to find an image with the FTDI in so I can look for this file though.


    Monday, January 07, 2013 2:17 AM
  • To get past the need for a signed usbser.sys, you can install from  E:\DS\Packages\Driver\amd64~winemb-inf-mdmcpq~~~~6.1.7601.17514~1.0 of the WSE7 DVD.

    Then on your target, from an admin command window:      pkgmgr /ip /

    Friday, May 22, 2015 6:05 PM