Getting errors TF31002, TF31003, and TF30063 when trying to export Visual Studio Query to MS Excel RRS feed

  • Question

  • I have seen other forum posts with similar issues, and have walked through various docs. and technet articles, and for the life of me I am not able to get my configuration to work. 

    My setup is that I am using Visual Studio Enterprise 2019, and Excel for O365 64-bit. I have installed the additional Visual Studio packages Azure DevOps Office Integration and Visual STudio Tools for Office.  In Visual Studio, I have connected to my ADO instance, via Manage Servers, and that works great.  Looking at the list of servers in Excel, when I first attempt this, I see the error TF31003, which also list the error TF30063 saying I am not authorized. When I attempt to add a new server, through the Team menu and New List, it automatically fails with the TF31002 error.  

    Lost on trying to make this work, but the functionality is very important as a way to manage my backlog, and would love some guidance.  

    Tuesday, December 3, 2019 12:20 AM

All replies

  • I'm also getting the same error.  This used to work for me...maybe about a month ago.
    Friday, December 6, 2019 12:36 AM
  • Found the solution.  Apparently there is a newer version of the Excel add-in.  If you install this, it should resolve this.
    Friday, December 6, 2019 12:44 AM
  • I've tried the install. The installer has reported successful install a couple of times. I'm using Chrome and Firefox. I can connect to two different Orgs (one in each browser). In both orgs I'm a Project Admin on most of the projects I connect to. In one org I'm an org Admin.

    I've been working on this for a week or so. This quit working for me a bit over a week ago.

    I've removed the servers in the server configuration screen. I re-added the server I needed by copying and pasting the URL (vs using the screen to configure it)<orgname>.

    Back to working like a champ (oh.. and I'll do this first next time)

    Monday, December 23, 2019 8:11 PM