locked
attach a database RRS feed

  • Question

  • Hello team,

    when I open attach database dialog box, the resolution is so bad, everything is so squeezed and unreadable with very, very small fonts, how can I fix this?

    Is there a location or place that ca take care of this issue?

    Regards,

    CloudsInSky



    CloudsInSky

    • Moved by Tom Phillips Saturday, September 22, 2018 6:05 PM SSMS question
    Saturday, September 22, 2018 8:21 AM

All replies

  • Sounds like you are running SSMS on a high-resolution monitor. There is a setting to make SSMS high-DPI aware, see https://blogs.msdn.microsoft.com/sqlreleaseservices/ssms-highdpi-support/ for details.

    Note that you need to be running a recent version of SSMS, SSMS from SQL 2014 won't do. You can get the most recent version of SSMS here: Download SQL Server Management Studio (SSMS) .


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Saturday, September 22, 2018 8:28 AM
  • Hello Erland,

    Can you please send me the exact link?

    Anyway, I don't think that the reason for this is that I am not running the latest version, because I had same issue in 2014.

    The link you sent me is very technical and It seems I had to go registry, so I am not going to do that because I will run to other issues.

    Regards,

    CloudsInSky


    CloudsInSky



    • Edited by cloudsInSky Sunday, September 23, 2018 12:08 AM
    Saturday, September 22, 2018 11:09 PM
  • The exact link of what?

    Yes, there is currently no simple nice checkbox to enable high-DPI support in SSMS, so you will have to work with the manifest file. I guess the assumptions that SSMS is mainly used by developers and thus are assumed to be a bit technical.

    When I googled "high resolution SSMS" i found several links that seemed to described how to do this. You can try any of them and see if you find them easier to understand than the original.

    Else, well, you can always lower the resolution of your monitor.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Sunday, September 23, 2018 9:21 AM
  • Looks like you changed solution Settings on your machine to non-Default = 100% and now all Fonts are to large. Change it back to Default value.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Monday, September 24, 2018 7:18 AM
  • Olaf,

    They are not too big, but they are very small. Here, I pasted it a screenshot and make it bigger for members to see in this forum to see what I am talking about.

    Do you have the path how to make the changes?

    Regards,

    CloudsInSky


    CloudsInSky

    Tuesday, September 25, 2018 3:39 AM
  • Hi cloudsInSky,

    Which Windows OS did you use? Are you using a high-resolution monitor?

    If it is Windows 10, I would suggest you using the following option. Please right-click on the application, then select Properties -> Compatibility -> Change high DPI settings.

    By the way, some older Windows OS and SSMS cannot be compatible with high-resolution monitor, I would suggest you using the latest version of SSMS.

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, September 25, 2018 8:20 AM
  • Hello Erland,

    I googled it a little bit and it seems that I need to go registry which I am not going to do that, and this problem persists with high resolution monitors.

    I am going to hold off on this issue till later.

    Regards,

    CloudsInSky


    CloudsInSky

    Wednesday, September 26, 2018 6:59 AM
  • Hello Olaf,

    How should I do that? Should I go to setting, system and display? Is that what you have in mind?

    Regards,

    CloudsInSky


    CloudsInSky

    Wednesday, September 26, 2018 7:01 AM
  • Hello Teige Gao,

    I played with it; and one time every application shrank so little that I almost passed out. Checking High DPI Scaling didn't fix the problem. 

    During these tests; one time I don't know what I did that every application stayed same size; only Report builder and SSMS grew like a dot on my task bar; but everything inside SSMS grew to the size that I needed, after several years, I was able to see things. It didn't last, I played with it and again I had small fonts in left panel of SSMS and in some of dialog boxes such as an attach database.

    Regards,

    CloudsInSky


    CloudsInSky

    Wednesday, September 26, 2018 7:13 AM
    1. Resetting the layout:
    2. 1 – Start Microsoft SQL Server Management Studio.
    3. 2 – Enter the credentials within the Connect to Server window.
    4. 3 – Within Management SQL Server Management Studio, select “Window” from the top menu bar.
    5. 4 – Select “Reset Window Layout”.

    Ramesh Babu Vavilla MCTS,MSBI

    Wednesday, September 26, 2018 10:34 AM
  • I googled it a little bit and it seems that I need to go registry which I am not going to do that, and this problem persists with high resolution monitors.

    There is now a simpler solution to the problem. Download the preview of SSMS 18.0 where High DPI resolution is enabled by default. https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-2017

    Beware that this is not an upgrade, but a side-by-side install, so you need to make sure that you start the right one.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Wednesday, September 26, 2018 9:54 PM
  • Hello Ramesh,

    Thanks for response, but it didn't do anything to my SSMS.

    Regards,

    CloudsInSky


    CloudsInSky

    Wednesday, September 26, 2018 10:10 PM
  • Thanks,

    It seemed to me that there is no solution to this after researching unless I install a newer version of SSMS.

    Regards,

    CloudsInSky


    CloudsInSky

    Wednesday, September 26, 2018 10:12 PM