locked
Illegal characters in path RRS feed

  • Question

  • I just bought a new Windows 7 laptop. I cannot use Visual Studio with Silverlight. Every time I try to run a Silverlight application, I get a message: "Illegal characters in path". It does this with existing Silverlight applications and with brand new applications that I create and immediately run. This is happening in both VS 2008 and VS 2010. Other type of projects (e.g. WPF) work fine. At this point, I'm at my wits end. PLEASE help!!!
    Wednesday, May 26, 2010 6:50 PM

Answers

  • Publishing to IIS fails, however if I manually copy the files then yes I can access the application.

     

    Thursday, May 27, 2010 9:16 AM
  • Hi Octapi,

    OK.   You'd better check your access urls to see whether there is some invalid character in your url.  Secondly, you'd better compare the different settings between the two websites.

    Best regards,

    Jonathan

    Wednesday, June 2, 2010 3:09 AM

All replies

  •  can you create a new web application in IIS that points to the silverlight web project and navigate directly ?

    (or just browse to the web project testpage.html)

    Try using firefox or another browser.

    use fiddler and process monitor to identify what (if any) paths are causing the issue.

    http://fiddler2.com/fiddler2/

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Thursday, May 27, 2010 8:06 AM
  • Publishing to IIS fails, however if I manually copy the files then yes I can access the application.

     

    Thursday, May 27, 2010 9:16 AM
  • Hi Octapi,

    OK.   You'd better check your access urls to see whether there is some invalid character in your url.  Secondly, you'd better compare the different settings between the two websites.

    Best regards,

    Jonathan

    Wednesday, June 2, 2010 3:09 AM