none
How to fix the Invalid Target Namespace in a new report RRS feed

  • Question

  • Visaul Studio 2010

    Microsoft Visual Studio 2010
    Version 10.0.40219.1 SP1Rel
    Microsoft .NET Framework
    Version 4.0.30319 SP1Rel

    The only winforms report referenced is version 10.0.0.0

    1. Add new item

    2. Report

    3. Add the report

    4. Compile error:

    The report definition has an invalid target namespace 'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition' which cannot be upgraded.

    there are about 400 of these posted on the forums, so far I cannot find a single one that actually identifies the problem and gives a solution. (but then I have not looked through all of them yet)

    Does anyone know of a solution?


    Ed Warren Raising sails on masts not masts on sails
    Thursday, September 1, 2011 12:24 PM

Answers

  • After some searching, with no postive results: I did the following:

    1. created a clean win7 VM and installed vs2010, sp1, clean: the report builder created a report w/o any errors and the  target namespace was:

    'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition'

    So one is lead to believe the namespace is not the problem, but how it is resolved--- way over my head.

    2. Uninstalled Vs and all it's relatives (lightswitch, etc.), uninstalled SQL server <common controls>, then reinstalled them, now it works.. Still not sure why?? 


    Ed Warren Raising sails on masts not masts on sails
    • Marked as answer by Edward Warren Wednesday, September 7, 2011 10:23 AM
    Wednesday, September 7, 2011 10:23 AM