none
Image from Camera (WIA) RRS feed

  • Question

  • Device.ExecuteCommand(wiaCommandTakePicture)

    result in Windows 7 is Null.

    But must be object IItem

     

    Wednesday, October 20, 2010 10:02 AM

All replies

  • Michael,

    I you can post a more complete code sample I'm sure some here can help.

    I found this blog post which may or may not help: http://blogs.msdn.com/b/coding4fun/archive/2006/10/31/912546.aspx?PageIndex=3 

    *******************code from the blog post********************

    Item item = device.ExecuteCommand(CommandID.wiaCommandTakePicture);

    *******************code from the blog post********************

    The blog post contains good examples in c# and vb of how to acquire an image.

    Thanks

    Derek

    Wednesday, October 20, 2010 5:55 PM
  • I use Photo camera Canon PowerShot S2 and your sample don't work too. In Windows XP so is god, but in Windows 7 after

    'executes the device's TakePicture command
    item = SelectedDevice.ExecuteCommand(WIA.CommandID.wiaCommandTakePicture)

    result item=nothing

    I thinks may be problem in this

    different between Win7 and XP in parts of registry:

    ------------------------------------------------------------

    Windows XP

    HKEY_CLASSES_ROOT\CLSID\{D2923B86-15F1-46FF-A19A-DE825F919576}
        =WIA FileSystem USD
        \InProcServer32=C:\WINDOWS\system32\fsusd.dll

    ------------------------------------------------------------

    Windows 7

    HKEY_CLASSES_ROOT\CLSID\{D2923B86-15F1-46FF-A19A-DE825F919576} is empty and fsusd.dll is missing

     

    What is it “WIA FileSystem USD”???

    Friday, October 22, 2010 8:02 AM