none
devenv hangs building one project

    Question

  • Using msbuild on VS 2012 to build an integration services solution.  Command:

    "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv" TBSM.Vision.SSIS.sln /build "Debug"

    Sometimes it goes right through and finishes in a few minutes.  Frequently though, it builds the first two projects fine, then stalls on the third.  In Task Manager, devenv is still consuming 13% of CPU cycles and has been for over an hour.  Note that when it runs, the whole build is done in a few minutes and this project is just one of 20 or so and there's nothing special about it.  If I kill the build and do it again from a cmd prompt, it usually works fine but even then sometimes gets hung.

    What can I do to get consistent results on this? I'm  trying to automate the build but can't since it so often needs manual intervention.

    Thursday, August 25, 2016 12:43 PM

All replies

  • Hi G Britton,

    Since your issue is more related to the MSbuild, I moved your thread to MSbuild forum for better support.

    Thanks for your understanding.

    Best Regards,

    Lake Xiao

    Friday, August 26, 2016 2:39 AM
    Moderator
  • Hi Lake.

    This is not related to MSBuild 

    MSBuild is not used to build Integration Services projects.  You use devenv command line to build Integration Services projects.

    Please move this thread back to the correct forum

    Friday, August 26, 2016 12:47 PM
  • Hi G Britton,

    Sorry for misunderstanding your problem before. I have asked MSBuild expert to move back to general forum.

    I did a test in my side, I create three Integration Services projects in one solution, when i build this solution using Devenv comamnd, I can successfully build it. Please try the following method to narrow down your issue.

    Please try to build the solution in Visual Studio directly? And how about build three new created  Integration Services projects using devenv command line? Does it have same probelm? Also to chekc whether the cause is in your Intergration Services projects. You could try to build the three console applcaitions and check the result.

    If it still have the same issue for the new created projects. I suppose there migth be somethign wrong with your Command line tool.

    Try to use another version of command line tool to build the sln file. You could use VS2015 or VS2013 Command Prompt tool if you have VS2013 or VS2015 installed.

    Please try to repair your Visual Studio 2012 in order to repair the Command Prompt Tool. After that try it again.

    Best Regards,

    Lake Xiao


    Monday, August 29, 2016 2:10 AM
    Moderator
  • It usually builds fine interactively (using the VS GUI).

    Note that the problem only occurs when launched from task manager.

    I will try the same with VS2013 devenv, which I do have installed.

    I think you may be confused about what you call the Command Prompt Tool. In fact, there is just one program, devenv, which is used to launch the VS GUI but also has command line functions such as building solutions.

    Monday, August 29, 2016 1:20 PM
  • Hi G Britton,

    Thanks for your response.

    >>devenv,  which is used to launch the VS GUI but also has command line functions such as building solutions.

    I know this can be used to build the solution via the devenv command line. If the problem only occures when using the devenv command line. I think the problem is more related to the command propmt tool.

    Try to use the vs2013 devenv first, and share the result here.

    Best Regards,

    Lake Xiao

    Monday, August 29, 2016 3:03 PM
    Moderator
  • First auto run with the 2013 version worked fine.  I'll try it a few more times before I pronounce it good.  Of course if it keeps running well, that seems to imply a bug in the 2012 version, which is a drag
    Tuesday, August 30, 2016 3:22 PM
  • Hi G Britton,

    >>that seems to imply a bug in the 2012 version, which is a drag

    If it works well when using 2013 devenv.  I think there should be something wrong with your 2012 Command Prompt tool. Try to repair it via repairing your Vs2012.

    Best Regards,

    Lake Xiao

    Wednesday, August 31, 2016 1:04 AM
    Moderator
  • Spoke too soon.  VS 2013 will not build the project.  I get these errors:

    Microsoft Visual Studio 2013 Version 12.0.21005.1.
    Copyright (C) Microsoft Corp. All rights reserved.
    
    Some errors occurred during migration. For more information, see the migration r
    eport:

    Looks like it wants to upgrade my 2012 project to 2013, which I don't want.

    So, that's not an option.

    Thursday, September 01, 2016 1:02 PM
  • Hi G Britton,

    Since your project was created in VS2012. The Command Prompt tool for VS2012 is the recommended.

    Have you tried repairing your VS2012? After that, using VS2012 devenv to build your project again.

    Best Regards,

    Lake Xiao

    Friday, September 02, 2016 2:04 AM
    Moderator
  • I'd like to try the repair option.  Can you tell me how to do that?  In Control Panel/Programs/Programs and Features, I can see the entry for Microsoft Visual Studio Ultimate 2012.  If I right click on it, the context menu only shows "Change".  if I click on Change I get

    Which is scary, and not what I want to do!  (Visual Studio is most certainly *not* uninstalled, since I've been using it every day.)

     
    Friday, September 02, 2016 12:43 PM
  • Hi G,

    Currently, we are not sure if VS install packages missing or corrupted could lead to this situation, I suggest you insert a good ISO or DVD to repair your VS, not just from the Control Panel.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, September 05, 2016 1:29 AM
    Moderator
  • Now, two other developers are reporting the same behavior -- intermittent hangs during build.
    Friday, November 04, 2016 1:57 PM