locked
Login prompt appearing when opening Office documents RRS feed

  • Question

  • Each time I open an Office document in a SharePoint library, I have to re-enter my credentials.

    I am using MOSS 2007, Windows XP and IE 7.

    I've checked the 'remember my password' option when being prompted for my credentials.

     

    The strangest thing is even that when I press Cancel on the pop-up window asking for my credentials, the document is still opened...

     

    I found already some posts around this matter and tried already following suggestions:

    * I added my site to the trusted sites

    * I checked that 'basic authentication' is unchecked under Central Administration -> Application Management -> Authentication Providers

    * I've added my credentials for the server hosting the SharePoint environment in the managed passwords for my user account in the control panel (though I am not 100% sure of having this done correctly. It is asking upon entering an extra credential for a server name. I entered here the same name as the one appearing on top of the pop-up window asking for credentials, after 'connect to')

     

    Opening .pdf, .zip files is not asking for the credentials. So it is only Microsofts own files which are creating the problem.
    Moreover, using FireFox, you don't have the problem. But I don't think it should be recommended upon selling MOSS to use FireFox with it to have a more user-friendly interface...

     

    Anybody knowing how to fix my issue?

    Thursday, August 16, 2007 12:19 PM

Answers

  • Hi,

    I have solved the issue with following trick. I created the link as follows:

    <a href="javascript:STSNavigate('http://<servername>:<port>/_layouts/download.aspx?SourceUrl=/doc lib name/documentname.doc');">download a copy</a>

    Hope this helps.

    Thanks,
    Gaurav Dixit

    • Marked as answer by Mike Walsh FIN Saturday, February 13, 2010 8:15 AM
    Monday, November 23, 2009 12:58 PM

All replies

  • The fix of adding the site to Trusted Sites works for IE*6*.

     

    For IE7 the equivalent is adding the site to the Intranet Security Zone.

     

    (Note that although this seems mad as Intranet is surely a subset of Trusted, it isn't. It does work! [usually])

     

    Mike Walsh

     

     

    Monday, August 20, 2007 9:18 AM
  • We're having the same problem and adding the site to the intranet zone doesn't help. Any other ideas?

     

    Dana

     

     

    Tuesday, January 8, 2008 8:07 PM
  • What type of authentication are you using?  Only NTLM can automatically send credentials.  If you are using Basic you will always get the prompt regardless of those settings, and Forms uses cookies which requires a completely different set of steps.

     

    Tuesday, January 8, 2008 8:54 PM
  • I'm only using NTLM. Basic is unchecked. I have full access to everything with no prompt, but as soon as I open an Office document I get prompted. As stated by the user who started this thread, even if I click cancel, I still open the document. So I don't understand what is causing the prompt.

     

    Tuesday, January 8, 2008 8:57 PM
  • What OS are you using for your client, and what version of Office?  There is a known issue with Vista/Office 2007 that will sometimes cause this, details at http://blogs.msdn.com/sharepoint/archive/2007/10/19/known-issue-office-2007-on-windows-vista-prompts-for-user-credentials-when-opening-documents-in-a-sharepoint-2007-site.aspx

     

    Tuesday, January 8, 2008 9:04 PM
  •  

    Bryan, thanks for the link. Changing that connection setting does in fact seem to do the trick. Although I could have sworn I've seen this behavior on XP as well. I'll have to do more testing to verify. Thanks again.

     

    Dana

    Wednesday, January 9, 2008 2:54 PM
  • hey all, I'm having almost the exact same problem as patrick in the exact same environment (moss 2007 ie6 and ie7)  firefox does not have this issue i can open all files (txt, zip, pdf, ..etc) except and word and xls (haven't tested ppt or xml files yet in firefox, but for whatever reason not in ie6 or 7.. .  the only difference is, is that hitting the esc key doesn't open the any office documents.

     

    this is only on the extranet, i've changed, and added my site to the trusted on both intranet and internet sites, made sure ot allow auto logon on both and still no good.  this is definitely a office issue and it really shouldn't be.

     

    does anyone have a clue?

    Friday, February 1, 2008 8:41 AM
  • We run a secure and private educational portal for schools and other educational professionals and publish our Sharepoint from behind an ISA 2006 server in Form Based Authentication and still get challenged to authenticate when opening Office documents; in fact get challenged twice in some instancies. We have noticed, however, that once authenticated and you do not close the Office application you are not prompted to authenticate again when opening further documents. Suffice to say that once you have closed the Office application you are challenged again.

     

    Another peculiarity is that we do not get challenged from any private team sites where membership permissions are unique.

     

    We are currently on the case and if a solution is found will share it here. However, anything you can add to help would be appreciated.

     

    • Proposed as answer by Shiva029 Thursday, September 23, 2010 11:06 AM
    Saturday, March 8, 2008 10:15 AM
  • this is the documentation i used to resolve this issue.  while this will resolve all the authenticaion problems it does introduce a few security issues (see below).  also firefox does not ask to authenticate because it caches the documents from sharepoint locally, which will not allow updating documents on the server.  from what i have tried nothing in application management will fix this issue.  this must be done on all computers connecting to sharepoint.  my suggestion is to setup a group policy, which i have done.  so far so good.

     

    Jin

     

    Problem:
    You are prompted to enter your user name and your password when you open a Microsoft Office document in IE.

    This is my documentation that I implement and this will take care of the authentication issues.  however, with it comes security issues that you should relay to your users.  also with firefox the reasons you do not get the authentication issues is because firefox does not use active x and it caches everything to the local cmputer.  essentially you will not be able to
     
    Attention:
    • Only perform the solution on your own computer.
    • Only perform this action on a password-protected computer.
    • Never perform this action on a publicly accessible computer, i.e. at a library or internet cafe.
    Solution:
     
    Make the Portal a Trusted Site in Internet Explorer
    Another solution is to go into Internet Explorer and designate the portal as a "Trusted Site". Once a secure website is designated a "Trusted Site", you are never required to log on again, not even when you initially enter the site. For this reason, we ask that you take great care when implementing this solution.
     

    To make the portal a Trusted Site:

    1.  Open Internet Explorer

    2.  Log on to the portal home page  

    3.  On the Internet Explorer tool bar, select the "Tools" menu, then select "Internet Options".

     

     

    4.  Select the "Security" and than "Trusted Sites" tab

     

     

    5.  Select the "Sites" button

     

    6.  Add the portal address in the "Add this website to the zone" box. Click "Add" and "Close". 

    • If the portal web address is not in the input field, then copy and paste it from the browser address at the top of your browser window.
    • Do not check "Require server verificatoin (https) for all sites in this zone"

     

    7.  Click on the "Custom Level" button.

     

     

    8.  Scroll down to the middle and enable "Display mixed content"

     

    9. Scroll down to the bottom

    • Under "User Authentication/Logon", select "Automatic logon with Current Username and Password" and click "OK"

     

     

    10.  Click "OK" twice to close all dialog boxes

     

    11.  The next time you log on, be sure to select "Remember my password"

     

    Monday, March 10, 2008 5:25 PM
  • Hi,

     

    Try with this Kb:

     

    http://support.microsoft.com/kb/932118/en-us

     

    If the problem is accesing docs from Internet and you are publishing sharepoint with isaserver,this is a common issue and occurs because Word (or other non-web apps) is seen as a new session by ISA and hence the authentication cookie provided to the web browser is only valid for that particular web session and not Word; hence the addtional authetication prompt.

    The common way to fix the issue is to enable a feature called "persistent cookies" which essentially creates a machine cookie which can be used by ALL applications on the machine. The downside to this approach is that this is not a great security solution if used on non-managed PCs like Internet cafes etc.

    A good compromise is to enable persistent cookies only on private computers, this way if the user clicks on the private computer option in the ISA form, they will use persistent cookies, but if they choose public, they will not. The only downside is that if users choose the wrong option , it could mean that a persistent cookie could be applied to a public machine.

    The persistent cookies do have a timeout value, so this provides some level of protection and can be modified to meet your paranoia level  

    Regards,

     

    Hector
     

     

    Tuesday, March 18, 2008 3:56 PM
  • Hi Hrsanchez

     

    How do you enable the feature "persistent cookies". Is this something you should enable on your ISA or your IIS?

     

    Or is this feature enabled just by choosing the "This is a private computer" option upon logon in the ISA form?

     

    Tuesday, March 18, 2008 8:40 PM
  • Hi, Patrik,

     

    Persistent cookies are enabled in the Forms=>Advanced tab on the web listener you are using for SharePoint.

     

    Hector

    Wednesday, March 19, 2008 12:50 PM
  • OK, I have persistent cookies enabled, but I still am having the authentication windows coming up?  What other settings are required? 

    I have the requests passed off to ISA, which has persistent cookies enabled, and my brower has added the site as a trusted site.  Everything is on forms-based-authentication.

    Any ideas?
    Thursday, October 2, 2008 12:13 PM
  • The issue is not restricted to ISA or the Internet.  Within the Government, we require client certificates stored on a smart card (a real pain).  When one opens an Office doc on SharePoint, the Office app has the user network logon available and provides it when challenged by the SharePoint site via integrated Windows authentication (the Office app is considered a separate session from the browser as noted above).  We are then challenged by our smart card middleware to choose a client certificate (because we use more than one).  Exactly the same issue, different symptom.
    Thursday, October 2, 2008 3:44 PM
  • Well I got it to work...partially.

    I had the client IE browser set to Trusted Site, with a custom setting of "automatically logon with current username/password."  Now, with FBA, I get the initial login, then a 2nd authentication window which when I login too, everything afterwards works great.  I can open up documents, check-out, check-in, edit, etc.... without a windows authentication prompt. 

    The question is, why does the 2nd window of authentication come up again?  Didn't I get through with the FBA? 
    Thursday, October 2, 2008 6:22 PM
  • I am having the same problem of double authentication request when opening Office docs from Sharepoint, but only in Window 7.

    XP systems accessing the same docs on the same domain with either IE 6, 7 or 8 have no problem and open fine.

    Trying to open the same doc's within IE 8 on a windows 7 system cause the credentials prompt, but cancelling it still allows the document to open. Only happens with Office docs (pdf's and jpg's etc are fine).

    Strangely if you checkout the document for editing, it opens but doesn't prompt for credentials.

    Has anyone solved this issue yet?


    Wednesday, November 18, 2009 4:18 PM
  • Hi,

    I have solved the issue with following trick. I created the link as follows:

    <a href="javascript:STSNavigate('http://<servername>:<port>/_layouts/download.aspx?SourceUrl=/doc lib name/documentname.doc');">download a copy</a>

    Hope this helps.

    Thanks,
    Gaurav Dixit

    • Marked as answer by Mike Walsh FIN Saturday, February 13, 2010 8:15 AM
    Monday, November 23, 2009 12:58 PM
  • I am having the same problem of double authentication request when opening Office docs from Sharepoint, but only in Window 7.



    Hi kippo,

    I am on the same situation as yours.  I tried the workaround on as advised from the link below.

    http://blogs.msdn.com/sharepoint/archive/2007/10/19/known-issue-office-2007-on-windows-vista-prompts-for-user-credentials-when-opening-documents-in-a-sharepoint-2007-site.aspx

    I used the following registry keys but ran into another error when editing the document.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
    "C:\\Program Files\\Microsoft Office\\Office12\\WINWORD.EXE"="WINXPSP2"
    "C:\\Program Files\\Microsoft Office\\Office12\\EXCEL.EXE"="WINXPSP2"
    "C:\\Program Files\\Microsoft Office\\Office12\\POWERPNT.EXE"="WINXPSP2"

    Please let me know how you go with this issue.

    Cheers,
    deskadmin

    • Edited by Mike Walsh FIN Saturday, February 13, 2010 8:13 AM don't use full quote
    Friday, January 8, 2010 9:02 AM
  • Hi,

    I'm experienced similar problem.

    When I try to access our SharePoint site  there is no problem, but when I try to open document from it, it prompt for password, and if I hit CANCEL the document is open normaly. In our organization this problem is only from clients with VISTA and Windows 7. Clients with XP are fine.

    Other thing which i notice is if I try to access any folder from SPS (for ex. \\servername\sitedirectori\site\Shared documents ), the prompt is appearing again. This happnes again only on VISTA and Windows 7, with XP everthing is fine.

    We are using Windows integrated Authentication , NTLM, Basic is UNCHECKED.

    The SPS site is in form : serverCNAME.local.domain (serverCNAME is different from actual HOST name of the server. It is CNAME). It is written in Alternate access mappings in this form too and is working fine with clients which OS are XP running IE7 or IE8.

    On all clients in Internet Options / Security / Intranet there is record in form " *.local.domain ".
    i also tried in Windows 7 to decrease the level of security for intranet to LOW level with no success.

    Cheers,
    G.Mihalev
    Friday, January 8, 2010 10:19 AM
  • Hi,

    I am experiencing the same issue however I am on windows 7. I tried the settings as above regarding the "Automatic logon with Current Username and Password" however I still get the prompt for credentials. Any ideas if there is a fix for this on windows 7?
    Anesh| http://christopheranesh.blogspot.com/
    Tuesday, January 19, 2010 3:48 PM
  • Hello

    Problem that we are facing is that user get prompted when trying to access office document

    in SharePoint.

    This is native behaviour while using office application in SharePoint.

    reason behind this behaviour is the following:

    when you try to access word document for example. Office application fires up, tries to open the document, and prompts for credentials.  your credentials are already stored on session cookie but unfortunately processes do not share session natively. IE runs in one process and word runs on separate process which means they can not share same cookie so you get prompted for credentials.

    For more insight please refer to Microsoft documentation:

    http://msdn.microsoft.com/en-us/library/bb977430.aspx

    work around would be to :

    Open document within IE (using same process hence sharing same cookie)


    Momo
    • Proposed as answer by Mohamed Hachem Wednesday, January 20, 2010 8:11 PM
    • Unproposed as answer by Mike Walsh FIN Saturday, February 13, 2010 8:13 AM
    Wednesday, January 20, 2010 8:07 PM

  • Problem that we are facing is that user get prompted when trying to access office document


    I've read the same explanation elsewhere and it's great to know. I'm having the same problem as others. We currently running sps 3.0 and our Vista and Win7 users keeps getting prompted for their credentials when they open any MS Office files.

    I've tried all the suggested solutions and still no progress. Is there some way to added the sharepoint site as a trusted site/publisher in MS office so it'll send the credentials??


    • Edited by Mike Walsh FIN Saturday, February 13, 2010 8:14 AM don't use full quote
    Friday, January 22, 2010 6:47 PM
  • I have spent far too long on this one.

    Simpley put Windows XP & Windows 7 is fixable. Vista is not

    Windows XP has no issues with logging in as it knows to use persistant cookies

    Windows 7 slips up because of the different security zones....IE7/8 are in the low zone, Office in the medium and High end Admin processes in the High zone

    Persistant cookies stored in the low zone aren't available to apps in the medium zone
    Make the SharePoint site a trusted site and the cookie gets promoted to the medium zone and hey ho its all works

    Windows Vista has the same issue as Windows 7 but it also has the issue that Windows Vista & Office communicate via webdav which effectively sends your login credrentials up to SharePoint and ignores the persistant cookies. There are registery hacks, and ways of disabling webdav and installing web folders (the old xp system of connecting to drives on sharepoint) but they are all potentially dangerous and shouldn't be deployed.

    Solution: Use SharePoint as an Intranet service, with external access being given via VPN until you upgrade to Windows 7. Or downground everyone to XP.

    MS have been aware of the Vista webdav issue for many years. Its fixed in Windows 7 but nothing has been done about vista

    Tuesday, January 26, 2010 8:05 PM
  • Fin H,

    What's the fix for Windows 7? I can't seem to find a fix that works for me. When I was on Vista, what worked for me was to put office 2007 products in XP Sp2 mode. i did it with GPO making a reg change. This fix doesn't work for Win7. How did you fix your win7 problem?
    Thursday, January 28, 2010 2:11 PM
  • The solution for Vista has been out fo a while : http://support.microsoft.com/kb/943280/en-us

    Fixed it for me.

    Thursday, February 4, 2010 12:15 PM
  • Guarav-
    You are a lifesaver! I've been searching far and wide for a js workaround like this. It worked for me. THANK YOU.
    Joe
    Wednesday, February 10, 2010 6:30 PM
  • Mohamed Hachem:

    Please don't propose your own posts. Propose the good answers of other people - that helps the Moderators which self-proposal doesn't.


    (Moderator)

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    • Proposed as answer by ABitEncrypted Sunday, February 21, 2010 4:10 PM
    Saturday, February 13, 2010 8:14 AM
  • Set WINWORD.EXE to XP SP2 compatibility and that fixed it for me.  Tried everything else listed above first without success.  I am running on Win 7 through Forefront Threat management Gateway (ISA 2010).
    Sunday, February 21, 2010 4:14 PM
  • We i have read through teh entire forum and have tested this well. no matter what, it will still prompt for credentials.

    KB http://support.microsoft.com/kb/838028 explains the same though it is not published for Office 2007 but the behavior is the same.

    1. if you have a site which prompts for credentials at the time of login, office would also prompt for credentials but if the versioning is not enabled, it should work fine.

    Else

    to you would have to publish teh site anonymously.

    KB838028

    You may be prompted for authentication when you open Office files. This behavior occurs if the Web server requires authentication to process an OPTIONS call to the URI of the folder. Changes to the server configuration can typically be made to avoid this problem by giving anonymous users browse permissions to the folder. Browse permissions are also know as list permissions. The prompt for authentication is expected if the server requires authentication.
    Tuesday, February 23, 2010 5:17 PM
  • Hi Gaurav,

    Please let me know Where to add this js. Thanks,
    Friday, March 5, 2010 2:28 PM
  • Hello

    the solution to login prompt is checking  "Use Remote Interfaces" to true in the actual site permissions level

    Site Permissions

    Permission

    Full Control

    Design

    Contribute

    Read

    Limited Access

    Use Remote Interfaces

    X

    X

    X

    X

    X

     

    Yee

     

     


    Momo
    Friday, March 5, 2010 5:14 PM
  • Replying to Mahamed Hachem:
    Use Remote Interfaces  is  "Use SOAP, Web DAV, or SharePoint Designer interfaces to access the Web site. "
    I believe it will reduce the security level of the site.
    Sara
    Thursday, March 18, 2010 9:43 PM
  • I dont know if this has been resolved or not but a very helpful source is the following link

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/023f4b23-3ce6-4d83-8cb0-7398b88ba6ab/?prof=required

     

    Uninstalling WebDav from your Sharepoint Servers will resolve the problem. Above link also talks about the misconception where you need WebDav installed as part of server but actually Sharepoint works with its own version of WebDav. Besides Password prompts, you also resolve the Open in Windows Explorer issues by uninstalling WebDav. Hope it helps.l


    Jawad
    Wednesday, May 12, 2010 3:27 PM
  •  

    HI All

    i had this problem from long time . finally we solved and the problem was on Host header configuration during create web application, you shouldn't PUT THE FQDN never that was the main problem

    Ex. Sharepoint.contoso.local with prompt for Authentication or re-authenticate 

    Ex2.Sharepoint only and you creat Canme for you dns point to the IP address  that will work

    to change the Host Header or Site URL after creation follow this :

    to make it simple, please follow the following steps to configure AAM (alternate access mapping)

    1. On the Alternate Access Mappings page, click Edit Public URLs .

    2. If the mapping collection that you want to modify is not specified, then choose one.
      In the Alternate Access Mapping Collection section,
      click Change alternate access mapping collection on the Alternate Access Mapping Collection menu.

    3. On the Select an Alternate Access Mapping Collection page, click a mapping collection.

    4. In the Public URLs section, you may add new URLs or edit existing URLs in any of the following text boxes: Default, Intranet, or you can change the Default from  http:// Sharepoint.contoso.local  to http://Sharepoint
    5. Click Save .

    Now you’ll have to switch over to your DNS server.

    1. Within the DNS Management Console and Under Forward Lookup Zones:
      Add a new Primary Zone with your new domain name.
      Add a new Host (A) to the records for http://Sharepoint and point the IP Address to the sharepoint server

    DON'T Ever Make any modifications from IIS make all from Central Administration

    Cheers,

    • Proposed as answer by Nayrbrey01830 Friday, July 9, 2010 1:37 PM
    Monday, June 21, 2010 7:50 AM
  • The FQDN removal fixed the issue for me.  WSS 3.0 on 2003 Server with a mixed XP/Vista/7 Environment all with office 2007.
    Friday, July 9, 2010 1:37 PM
  • If your site is a FQDN then you need to implement this fix http://support.microsoft.com/?id=943280

    For Vista machines pre SP1 you need to apply the hotfix and implement the regkey fix in the article.  IF you have Vista Sp2 then the hotfix is not needed but the regkey is.

    For Windows7 all you will need to do is the regkey fix.

    Registry information

    To use this hotfix, you have to modify the registry.
    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

    322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

    After you apply this hotfix, you have to create a registry entry. To do this, follow these steps:

    1. Click Start, type regedit in the Start Search box, and then press ENTER.
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
    3. On the Edit menu, point to New, and then click Multi-String Value.
    4. Type AuthForwardServerList, and then press ENTER.
    5. On the Edit menu, click Modify.
    6. In the Value data box, type the URL of the server that hosts the Web share, and then click OK.

      Note You can also type a list of URLs in the Value data box. For more information, see the "Sample URL list" section in this article.
    7. Exit Registry Editor.

    After this registry entry is created, the WebClient service will read the entry value. If the client computer tries to access a URL that matches any of the expressions in the list, the user credential will be sent successfully to authenticate the user, even if no proxy is configured.

    Note You have to restart the WebClient service after you modify the registry.

    Sample URL list

    The following is a sample URL list:

    https://*.Contoso.com
    http://*.dns.live.com
    *.microsoft.com
    https://172.169.4.6
    

    This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, July 9, 2010 3:43 PM
  • Why is this marked as Answer????
    Tuesday, September 21, 2010 3:03 AM
  • Hi everyone, I spent a couple days trying to fix this problem and thought it would be good to share the fix that worked for us. Our users were getting prompted multiple times to login when opening word documents. Some on xp and some on windows 7, most using IE 8. If the user hit cancel two or three times the document would eventually open but not very professional. We have a domain policy that sets the IE internet options > security > local intranet > custom level > 'automatic login with current user name and password. We are using Sharepoint 2010. 

    Fix

    Open your main intranet site page with credentials that allow full control over permissions. I am assuming your sub-sites and document libraries are inheriting permissions from the parent site. 

    Click on site actions then site permissions. We will assume again that you are controlling user access with the built in group called "intranet visitors". Click on this group and check the settings. In our case we've added the domain group 'domain users' so anyone logged onto the domain will fall under this permission level. By default this group will have permission levels of Read and Limited Access. 

    Next click on permission levels then click on Read. Scroll down to site permissions and find the setting "Use Client Integration Features". In our case this was unchecked, we checked it and submitted the change. After this our problem went away for all our users. I think this needs to be checked in order for the browser to properly pass along credentials to the web application. 

    Tuesday, September 28, 2010 5:30 PM
  • I have probably spent hours, if not days, scouring technet and the internet for an answer for these symptoms.  My particular issue happens with my XP pcs which are running Office 2010, IE8, and they are accessing MOSS 2007 Office files.  This does not happen with my Windows 7 pcs.  The sharepoint site is part of the "Trusted Sites" zone and it is set to "Low".  Here is what I have found regarding my particular issue.

    Issue: This issue occurs when a user changes their password on a Windows XP pc.  They have saved their login information while accessing an Office document before.  Stored login information does not seem to change and causes Office files to not open correctly from the sharepoint website because the PC seems to use "bad" login information.  There may be 2 username/password prompts but one does not show itself because the information is saved.  Clearing the stored information through normal methods (Internet Explorer’s saved passwords and XP’s “Stored User Names and Passwords”) does not work.  I have not been able to confirm (yet) that if a user does not save their login information that they do/don't encounter this issue.

    Symptoms: This only happens with Office files on sharepoint.  The issue does not happen while using a 3rd party browser.  Symptoms include but not limited to: a delay in opening the file, possibly multiple login prompts, file may eventually open, file might not save, and a login prompt while closing the file.  

    Fix: This can be done with the Admin or users's account.  First close all Internet Explorer windows.  Go to this location for the user with the issue: C:\Documents and Settings\%Username%\Application Data\Microsoft\Credentials.  There may be multiple folders and I believe they may safely be renamed.  Rename each folder by adding a “.bac” (no quotations) to it so they can be restored if there is an issue.  Go back to the sharepoint website, login, and test opening an Office document.  It worked for me!

    I hope this helps others because of the amount of time I spent trying to find an answer.

    Tuesday, November 23, 2010 5:23 PM
  • Thanks to all for suggestions on how to fix this. I have created a tutorial to solve the login prompt once and for all.

    http://www.uv.mx/personal/gvera/2010/09/28/sharepoint-login-prompt-when-accessing-files-in-a-document-library/

    Hope it helps you.

    Tuesday, November 30, 2010 7:19 PM