locked
dynamic content RRS feed

  • Question

  • I am fairly new to expression web.

    I have inherited a web site using Expression , I am putting in some new functions using asp text box , when I preview I get 'this page may contain dynamic content that requires a web server to be previewed correctly', when the page displays it does not show the text box, but everything else is OK.(the page saves as .aspx)

    Could this be the web server or is there something that I've ommitted.

    Monday, April 19, 2010 12:49 PM

Answers

  • Actually, Jim, not necessarily. It may be supposed to install automatically, and does for many, but it didn't when I installed EW2 originally. IIRC, that was the reason for my very first post to this forum. I followed the instructions in the EW Help file (very easy, BTW, and consider why those instructions are in the Help file ;-).

    Anyway, for whatever reason, it didn't install for me, and the installation was a snap following Help.

    cheers,
    scott


    C'mon, folks. This isn't rocket science, nor neurosurgery. It's "Expression" (singular) "Web" (singular), in that order, followed by a version numeral if you wish to be specific. It is often abbreviated "EW." It is not "Web Expression," "Expressions Web," "Web Expressions," or plain "Expression" or "Expressions." Not using the correct name indicates either ignorance or laziness. Most folks would rather avoid the appearance of either.
    • Marked as answer by juddhill Wednesday, April 28, 2010 5:36 PM
    Monday, April 19, 2010 7:55 PM

All replies

  • Do you have the Development Server installed (comes with EW). This server will allow you to view aspx pages on your local box.

    Monday, April 19, 2010 1:17 PM
  • No its not installed. Is there a download and if so which version do I need.
    Monday, April 19, 2010 2:55 PM
  • Actually, it is installed. It does that automatically. Go to the menu item Site>Site Settings...>Preview and check the box to use the developmental server.

    Jim

    Monday, April 19, 2010 4:08 PM
  • Actually, Jim, not necessarily. It may be supposed to install automatically, and does for many, but it didn't when I installed EW2 originally. IIRC, that was the reason for my very first post to this forum. I followed the instructions in the EW Help file (very easy, BTW, and consider why those instructions are in the Help file ;-).

    Anyway, for whatever reason, it didn't install for me, and the installation was a snap following Help.

    cheers,
    scott


    C'mon, folks. This isn't rocket science, nor neurosurgery. It's "Expression" (singular) "Web" (singular), in that order, followed by a version numeral if you wish to be specific. It is often abbreviated "EW." It is not "Web Expression," "Expressions Web," "Web Expressions," or plain "Expression" or "Expressions." Not using the correct name indicates either ignorance or laziness. Most folks would rather avoid the appearance of either.
    • Marked as answer by juddhill Wednesday, April 28, 2010 5:36 PM
    Monday, April 19, 2010 7:55 PM
  • In this case it probably did install but probably doesn't make any difference since the OP mention "asp" files and a "legacy" site which most likely means his site is using Classic ASP. For that the testing server won't work. IIS will need to be installed and configured to support Classic ASP to test locally.
    MS MVP Expression Tutorials & Help http://by-expression.com
    Monday, April 19, 2010 8:35 PM
  • The OP talked about .aspx pages, and the "asp textbox", which could simply be <asp:TextBox>, which is asp.net.  Until the OP chimes in, I'm thinking this is asp.net, not asp, and should preview through the development server.
    Monday, April 19, 2010 9:38 PM
  • Are you talking about asp or asp.net?  You haven't clarified that.

    If asp.net, you don't need IIS to preview locally.

    If asp, you do, to preview locally.  If you don't have it, whether you can install it or not depends on your operating system.  ...But answer the first question first.

    (And no, IIS is not loaded with the development web server.  They are two different servers.)

    Friday, April 23, 2010 4:44 PM
  • OK i've had our IT boys  update the site server and that has cleared the ''this page may contain dynamic content that requires a web server' .However when I put in a asp.text box this does not appear when viewing the web site , but it does appear on my local pc using the Microsoft development sever on my local host, any ideas  ?

    My local pc is networked to a web server.

    thanks

    Wednesday, April 28, 2010 5:35 PM
  • Post a link to the page.

    Wednesday, April 28, 2010 6:58 PM