locked
How can I change the behaviour of this forums Body input field?

    Question

  • I am working with English Windows 8 Pro and English Visual Studio Express for Windows 8 on a machine with German keyboard layout on an Austrian IP address and get to this forum via the VS inbuilt Menu - HELP - MSDN Forums.

    So for some reason, whenever I write a post in this forum some of my words get capitalized automatically altough I want them the way I am typing them - since my post is English not German! So I permanently have to go back an change the first letters of a lot of words back to what I've typed, since some idiotic logic thought to be cleverer than me.

    In Addition most of my typed words are marked unknown with a wavy red line - sure they are not German These are English words - or at least should be ;-) - so stop arguing with me!

    How can I stop this annoyance?

    Thursday, January 10, 2013 10:50 AM

Answers

  • That behavior shouldn't be specific to the forum. I'd expect you to see it universally, although if your other forums are in German that is probably the behavior you want there. I believe the spell checking tied to your input language. I'd ask in the http://answers.microsoft.forum for Windows 8 (or possibly IE, but I think spell checking is Windows) for tips on how to set that.

    --Rob

    • Marked as answer by Scruff.R Monday, January 14, 2013 8:31 AM
    Thursday, January 10, 2013 5:50 PM
    Owner

All replies

  • That behavior shouldn't be specific to the forum. I'd expect you to see it universally, although if your other forums are in German that is probably the behavior you want there. I believe the spell checking tied to your input language. I'd ask in the http://answers.microsoft.forum for Windows 8 (or possibly IE, but I think spell checking is Windows) for tips on how to set that.

    --Rob

    • Marked as answer by Scruff.R Monday, January 14, 2013 8:31 AM
    Thursday, January 10, 2013 5:50 PM
    Owner
  • Thanks Rob,

    I was not aware, that choosing a keyboard layout takes precedence over the selected system language.

    When I setup Windows I chose English as system language, but opted for the German keyboard layout, which apparently made Windows think I want to read in English but write in German, which I was not aware of, since it does not really make sense to me ;-)

    So I had to add the German keyboard layout as additional input option to the English language setting, re-select English as system language and then activate the additional German keyboard layout under the English system language.

    Now it works, but I still find it awkward, that choosing a keyboard layout implicitly changes the input language (at least at setup time).

    Monday, January 14, 2013 8:41 AM