locked
Problems with roles when uploading it to the web RRS feed

  • Question

  • User-796050626 posted

    hi there, I downloaded the starter site and installed it locally, that was fine worked great. I configured an admin role through the intergrated part of VWD. I have a webhost4life server and i created the database, uploaded the files, changed the connection string in the web.config file and it doesnt work, i get an error with roles, like so

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

    Source Error:

    Line 78:   </connectionStrings>
    Line 79: 	<system.web>
    Line 80: 		<roleManager enabled="true"/>
    Line 81: 		<authentication mode="Forms"/>
    Line 82: 		<compilation debug="true">

    what can i do? i have had a look and some one said changing the role management but i have tried that and it dosnt seem to work, any ideas?

     

    Regards

    Jez

    Saturday, August 4, 2007 8:54 PM

All replies

  • User-1563988197 posted

    Try running it locally with your hoster's database. See if it works then.

    Sunday, August 5, 2007 12:28 AM
  • User-796050626 posted

    Hi there, tried that and it worked! no problem, but i was still able to log in using the Admin user that i set up in WVD using website menu > ASP.NET configuration, so i think it must have something to do with that, also some other people mentioned that the "membership default provider" which is listed in the original web.config needs to be changed but im not sure.

     i copied that web.config file to the live one and still got the same error, any ideas?

    Sunday, August 5, 2007 6:07 PM
  • User-796050626 posted

    silly me didnt set the sub folder that i was using as a .net app!

    Sunday, August 5, 2007 6:21 PM