locked
Javascript: Error on Windows App Cert Kit (Release Preview)

    Question

  • When I run the Windows App Cert Kit, i got this error:

    *************************

    Performance test 

    FAILED 
    Bytecode generation
    • Error Found: The bytecode generation test detected the following errors: ◦This package was deployed for development or authoring mode. Uninstall the package and re-install it normally.
    • Impact if not fixed:  As a performance optimization to accelerate JavaScript execution time, JavaScript files ending in the ".js" extension generate bytecode when the app is deployed. This optimization significantly improves start-up and ongoing execution times for JavaScript.  
    • How to fix: You may need consider one or more of these steps to fix the issue:
    - Ensure that event logging is enabled
    - All JavaScript files are syntactically valid; otherwise exclude the respective files from the package
    - Please note that you should uninstall all previous versions of the app before deploying
    Otherwise exclude the respective files from the package. 

    *************************
    Can anyone give any directions?


    Alex Nosse

    Tuesday, June 12, 2012 9:41 PM

Answers

  • You might be running the Cert Kit against a version of the app that was deployed when you run the app directly from Visual Studio (ie: "deployed for development or authoring mode").

    1) Uninstall the application from your local machine

    2) Make sure you have the configuration dropdown in Visual Studio set to Release

    3) Create the deployment package through the 'Store" menu.  Right click on the project, then Store -> Create App Package.

    4) Follow the steps through the wizard.  When you reach the end, it will ask you if you want to run the Windows App Cert Kit. 

    • Marked as answer by Alex Nosse Wednesday, June 13, 2012 6:12 PM
    Wednesday, June 13, 2012 4:45 PM

All replies

  • The Cert Kit found one or more .html, .js, or .css files that are not saved as "Unicode (UTF-8 with signature) - Codepage 65001". To save this way, open the file in Visual Studio, do File Save As, select "Save with Encoding..." (drop down from the Save button), and select the encoding above.

    Wednesday, June 13, 2012 4:36 PM
  • You might be running the Cert Kit against a version of the app that was deployed when you run the app directly from Visual Studio (ie: "deployed for development or authoring mode").

    1) Uninstall the application from your local machine

    2) Make sure you have the configuration dropdown in Visual Studio set to Release

    3) Create the deployment package through the 'Store" menu.  Right click on the project, then Store -> Create App Package.

    4) Follow the steps through the wizard.  When you reach the end, it will ask you if you want to run the Windows App Cert Kit. 

    • Marked as answer by Alex Nosse Wednesday, June 13, 2012 6:12 PM
    Wednesday, June 13, 2012 4:45 PM
  • Thanks! 

    Alex Nosse

    Wednesday, June 13, 2012 6:13 PM
  • Had same problem. Strange
    - I did remove with remove-appxpackage

    - I did check for UTF8 as Kraig explains

    Still only your step 3 does the trick. Apparently the VS deployment includes some invalid files, but the created app package does not.

    Thanks.

    Wednesday, September 26, 2012 9:16 PM
  • Im getting this error now... ive packaged my app in the past just fine but now it keeps telling me "This package was deployed for development or authoring mode. Uninstall the package and re-install it normally"

    It is set to release.. ive tried everything yet WACK still thinks its deployed for development....

    I know how to package apps as ive done it before.

    Windows 8 is full off stupid vague errors... awesome for developers


    When the WACK errors on this Bytecode generation why dosnt it tell you which file.... how vague is that.... "you have an error with a file but its up to you to go through all your files in your project and figure it out blind...."

    Might be a good idea to let the WACK development team know that it needs to let people know which files are causing the error...

    Also if UTF8 is required why the hell are you not auto encoding it to that when we save a file.... you allow us to select  an encoding type yet we can only use utf8 or it will fail validation...
    Friday, January 11, 2013 10:47 AM
  • i am also face same error as above if you get solution please tell me what i do ?

    Thank You in Advance

    Saturday, January 12, 2013 10:47 AM
  • You might be running the Cert Kit against a version of the app that was deployed when you run the app directly from Visual Studio (ie: "deployed for development or authoring mode").

    1) Uninstall the application from your local machine

    2) Make sure you have the configuration dropdown in Visual Studio set to Release

    3) Create the deployment package through the 'Store" menu.  Right click on the project, then Store -> Create App Package.

    4) Follow the steps through the wizard.  When you reach the end, it will ask you if you want to run the Windows App Cert Kit. 

    Thanks Dave!

    Step 3 is what I was missing. It's working now.

    Wednesday, February 20, 2013 5:46 PM
  • Hei, I consider it done. But, I tried to re-package and found the same problem.

    So, Do I have to reinstall my VS and other updates? Please advise me...

    T_T

    Friday, April 26, 2013 12:47 AM
  • Its not really working to me . . . Please suggest me . . .
    Friday, April 26, 2013 12:48 AM
  • I too had this issue.  I have done all steps necessary I would think anyways :)  isn't 100 times enough

    1.uninstalled/reinstalled  

    2. Set the App config to -----> release

    3. created the store  ---->  app package

    still no luck. 


    We really need an updated release of the Certification Kit this is definitely flawed-I pass all tests but this one.  Seems if the certification kit were more accurate there would be many more apps in the store.  Thanks Alex for the advice :)

    Saturday, June 01, 2013 4:45 PM
  • If your running Windows App Cert Kit from the standalone try creating a package using the store menu then it will give you the option to certify from there.
    Monday, February 17, 2014 6:06 PM