none
Inf2Cat getting a "parameter format not correct" error. RRS feed

  • Question

  • I am attempting to test the .CAT signing process and I am looking to create a .cat file from an INF file.  I downloaded and installed WDK and am trying to use Inf2Cat.exe.  I have located the inf2cat file and in the command I run:

    inf2cat /driver:C:\Drivers\ /os:6_3_X86

    I get an error saying "parameter format not correct"

    the inf file is in the directory and I checked that there was a:

    CatalogFile=Driver.cat

    entry under the version heading.

    Also, the INF file we are using is based on a windows signed driver we are using from a 3rd party, but we are making some changes to the PID and VID and USB descriptors.

    I tried using the same command on another INF file of another driver and it worked correctly. 

    Any insight would help. 

    Thanks,

    Thursday, September 28, 2017 11:23 PM

Answers

  • Fixed it.  In my path (not the same as in the example I gave) there was a space in the folder name.  Apparently Inf2Cat doesn't like this.

    originally it was this, which was giving the error.

    Inf2Cat /driver:C:\USB Drivers\ /os:6_3_86

    I changed to:

    Inf2Cat /driver:C:\Drivers\ /os:6_3_86

    This worked.

    Thursday, September 28, 2017 11:30 PM