none
Error in deploying BAM Workbook RRS feed

  • Question

  • Hi All,

    I'm pretty new to BAM, when i deploy BAM definition-BAM.xlsx file for the first-time..i'm facing below error. Can anyone help to solve this?

    using 'BAMPrimabrImport' BAM Primary Import database on server '..

    Error: The BAM configuration XML is not in the database. Contact your system admin..

    Thursday, May 30, 2013 12:32 PM

Answers

  • Hi,

    "when i deploy BAM definition-BAM.xlsx"

    You have to export the *.xlsx (Excel workbook) to an XML file which you have to use for deployment not the excel work book. Are you doing that?


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    • Marked as answer by NewBie_BAM Tuesday, June 11, 2013 6:09 AM
    Thursday, May 30, 2013 1:05 PM
  • This error is very often the result of an unconfigured or mis-configured BAM. I'd recommend that you execute the command "bm get-Config -FileName:BizTalkBAMConfiguration.xml" under C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking and then examine the output file to see if BAM is configured properly or not. The output file looks like

    <?xml version="1.0" encoding="UTF-8"?>
    <BAMConfiguration xmlns="http://schemas.microsoft.com/BizTalkServer/2004/10/BAM">
    	<GlobalProperty Name="BAMVRoot">http://[yourserver]:80/BAM</GlobalProperty>
    	<GlobalProperty Name="MaxAlertableActivityViews">63</GlobalProperty>
    	<DeploymentUnit Name="PrimaryImportDatabase">
    		<Property Name="ServerName">[your DB Server]</Property>
    		<Property Name="DatabaseName">BAMPrimaryImport</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="StarSchemaDatabase">
    		<Property Name="ServerName">[your DB server]</Property>
    		<Property Name="DatabaseName">BAMStarSchema</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="AnalysisDatabase">
    		<Property Name="ServerName">[your DB server]</Property>
    		<Property Name="DatabaseName">BAMAnalysis</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="ArchivingDatabase">
    		<Property Name="ServerName">[your DB server]</Property>
    		<Property Name="DatabaseName">BAMArchive</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="CubeUpdateDTS">
    		<Property Name="ConnectionTimeOut">120</Property>
    		<Property Name="UseEncryption">0</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="DataMaintenanceDTS">
    		<Property Name="ConnectionTimeOut">120</Property>
    		<Property Name="UseEncryption">0</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="Alert">
    		<Property Name="DBServer">[your DB Server]</Property>
    		<Property Name="ApplicationDatabaseName">Application</Property>
    		<Property Name="InstanceDatabaseName">BAMAlerts</Property>
    		<Property Name="GeneratorServerName">[your BAM server]</Property>
    		<Property Name="ProviderServerName">[your DB Server]</Property>
    		<Property Name="DistributorServerName">[your server]</Property>
    		<Property Name="SmtpServerName">[SMTP Server name]</Property>
    		<Property Name="AlertMailFrom">[configured e-mail from]</Property>
    		<Property Name="FileDropUNC">\\[your BAM server]\alerts</Property>
    	</DeploymentUnit>
    </BAMConfiguration>

    Your file should like like what I've included and should have valid values against []. If there are values mismatched, then you should rectify the XML and use the "bm update-config -FileName:<configuration file>.xml" to apply the updated config and then try importing the activity.

    Regards.

    Regards.

    • Marked as answer by Pengzhen Song Thursday, June 6, 2013 9:29 AM
    Thursday, May 30, 2013 1:07 PM

All replies

  • Hi, Please refer given below thread

    http://social.msdn.microsoft.com/Forums/en-US/biztalkgeneral/thread/16fefa1f-00c9-4a4d-8a3c-4a6e6a83f84c

    Thanks,

    Chandra

    

    Thursday, May 30, 2013 12:47 PM
  • Hi,

    "when i deploy BAM definition-BAM.xlsx"

    You have to export the *.xlsx (Excel workbook) to an XML file which you have to use for deployment not the excel work book. Are you doing that?


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    • Marked as answer by NewBie_BAM Tuesday, June 11, 2013 6:09 AM
    Thursday, May 30, 2013 1:05 PM
  • This error is very often the result of an unconfigured or mis-configured BAM. I'd recommend that you execute the command "bm get-Config -FileName:BizTalkBAMConfiguration.xml" under C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking and then examine the output file to see if BAM is configured properly or not. The output file looks like

    <?xml version="1.0" encoding="UTF-8"?>
    <BAMConfiguration xmlns="http://schemas.microsoft.com/BizTalkServer/2004/10/BAM">
    	<GlobalProperty Name="BAMVRoot">http://[yourserver]:80/BAM</GlobalProperty>
    	<GlobalProperty Name="MaxAlertableActivityViews">63</GlobalProperty>
    	<DeploymentUnit Name="PrimaryImportDatabase">
    		<Property Name="ServerName">[your DB Server]</Property>
    		<Property Name="DatabaseName">BAMPrimaryImport</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="StarSchemaDatabase">
    		<Property Name="ServerName">[your DB server]</Property>
    		<Property Name="DatabaseName">BAMStarSchema</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="AnalysisDatabase">
    		<Property Name="ServerName">[your DB server]</Property>
    		<Property Name="DatabaseName">BAMAnalysis</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="ArchivingDatabase">
    		<Property Name="ServerName">[your DB server]</Property>
    		<Property Name="DatabaseName">BAMArchive</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="CubeUpdateDTS">
    		<Property Name="ConnectionTimeOut">120</Property>
    		<Property Name="UseEncryption">0</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="DataMaintenanceDTS">
    		<Property Name="ConnectionTimeOut">120</Property>
    		<Property Name="UseEncryption">0</Property>
    	</DeploymentUnit>
    	<DeploymentUnit Name="Alert">
    		<Property Name="DBServer">[your DB Server]</Property>
    		<Property Name="ApplicationDatabaseName">Application</Property>
    		<Property Name="InstanceDatabaseName">BAMAlerts</Property>
    		<Property Name="GeneratorServerName">[your BAM server]</Property>
    		<Property Name="ProviderServerName">[your DB Server]</Property>
    		<Property Name="DistributorServerName">[your server]</Property>
    		<Property Name="SmtpServerName">[SMTP Server name]</Property>
    		<Property Name="AlertMailFrom">[configured e-mail from]</Property>
    		<Property Name="FileDropUNC">\\[your BAM server]\alerts</Property>
    	</DeploymentUnit>
    </BAMConfiguration>

    Your file should like like what I've included and should have valid values against []. If there are values mismatched, then you should rectify the XML and use the "bm update-config -FileName:<configuration file>.xml" to apply the updated config and then try importing the activity.

    Regards.

    Regards.

    • Marked as answer by Pengzhen Song Thursday, June 6, 2013 9:29 AM
    Thursday, May 30, 2013 1:07 PM
  • thank you all..

    BAM after proper installation working fine..

    exported as xml and deployed .its working fine now

    Tuesday, June 11, 2013 6:11 AM