locked
Use sp_configure 'user instances enabled' to generate user instance Help RRS feed

  • Question

  • User-1238392870 posted

     I just downloaded the club starter kit and I tried to build but the following error was generated.

    Server Error in '/ClubWebSite3' Application. Generating user instances in SQL Server is disabled. Use sp_configure 'user instances enabled' to generate user instances.

    I tried the solution that I found on the web that states

     

    Open the SQL Server Management Studio Express. This is the downloadable program in the same site where you downloaded the SQL Server 2005 express used to manage SQL Server 2005 Express.
    In the query editor type this text: exec sp_configure 'user instances enabled', 1.
    Then type: Reconfigure.
    Then restart the SQL Server database.

    I ran the above query but still get this error.

    I know that it has something to do with installing  SQL Server Management Express.

    Am I better off uninstalling this feature or can I troubleshoot through it. 

     

    Wednesday, June 20, 2007 11:37 PM

All replies

  • User-1418567014 posted

    I get the same problem, how to reslove this issue?

     

    Thanks

    Sunday, October 14, 2007 4:38 PM
  • User-1964325223 posted

    I had made an WebParts Demo application, But when i want to see this application in Browser an error comes.

    Generating user instances in SQL Server is disabled. Use sp_configure 'user instances enabled' to generate user instances.

    Can anyone suggest me what the problem is?

    Friday, January 11, 2008 1:01 AM
  • User1557762817 posted

    Hi,

      I recently installed Visual Web Developer 2008 and have been creating demos, etc.  The DB creation and access worked fine.  In order to follow some of the online webcasts I installed SQL 2005 Express and that is when the problem started with the sp_configure Error Message as described in this thread.  I was not able to use any of my demos for DB access after this point.  I then uninstalled SQL 2005 Express edition but the problem still occurs in the VWD environment.  Isn't VWD suppose to be self contained?  Why is the solution now to install SQL 2005 Express and execute the sq_configure command?  Installing SQL 2005 Express caused the problem in the first place and a subsequent uninstall didn't reverse the changes so the problem persisted.  Is there anyone that has a detailed solution?  Is it to reinstall SQL 2005 Express?  Is this even compatible with VWD 2008 Express?

       Thanks for any advice.

    Robert

    Wednesday, January 16, 2008 3:42 PM
  • User1557762817 posted

    Someone posted this link from Scott Guthrie which got me started on the right path:

     http://weblogs.asp.net/scottgu/archive/2005/08/25/423703.aspx

     Also, Scott's webpage has some demonstrations which were also helpful.

    http://www.scottgu.com/talks.aspx

     

    One thing I will mention is this:  Make sure when changing the connectionString in the web.config file to leave off the .mdf when using the "Initial Catalog" parameter.  I did not remove the extension .mdf from the new DB (which I created in SQL2005 with aspnet_regsql.exe) when changing from the "AtachDbFilename" to the "Initial Catalog" parameter.  I spent several hours wondering why my connection could not be made in the ASP.NET Configuration wizard.

    <configuration><?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p><o:p> </o:p>    <connectionStrings><o:p></o:p>        <remove name=”LocalSqlServer”/><o:p></o:p>        <add name="LocalSqlServer" connectionString="Data Source=localhost;Initial Catalog=appservicesdb;Integrated Security=True" providerName="System.Data.SqlClient"/><o:p></o:p>    </connectionStrings><o:p></o:p><o:p> </o:p>

    </configuration>

     

    One thing I am curious about though is, in actual practice, do most companies create new providers (for each web app they are working on) and do not even use the defaults used in VS and VWD? 

     

    Saturday, January 19, 2008 2:38 PM
  • User-1512833334 posted

    Hi guys,

    I don't know if this is the answer or not but I had the same error and I made the following changes to my web.config file and everything is working fine now.  I was using a remote sql server 2005 database.

    Hope this helps.

    <connectionStrings>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=;Initial Catalog=;User ID=;Password=;" providerName="System.Data.SqlClient"/>

    <remove name="ClubSiteDB"/>

    <add name="ClubSiteDB" connectionString="Data Source=;Initial Catalog=;User ID=;Password=;" providerName="System.Data.SqlClient"/>

    </connectionStrings>

    Thanks Stoater

    Wednesday, February 6, 2008 12:48 PM
  • User1392116443 posted

     Hi to all, i've used this instruction and now application is running.

    To activate "user istance" use this istruction:

    EXEC sp_configure 'user instances enabled', 1;
    RECONFIGURE;
    [:D]

     

     

    Monday, July 21, 2008 4:52 PM
  • User1102332668 posted

    Hi to all, yes i'm too use that instruction and everithing works ok...

    Note: the service it's must stop and iniciate after run this...

     

    Wednesday, July 23, 2008 6:21 PM
  • User-55569844 posted

    I'm CURIOUS at to what circumstances cause this sudden cessation of the availability. To my knowledge, I didn't do anything explicitly to cause it. However, there was a "suspicious" Windows Update that mentioned SQL Server around at the time.

    Inquiring minds NEED to know why these kinds of "showstoppers" erupt!

    tia ... :)  KevInKauai

    Wednesday, August 6, 2008 5:43 PM
  • User-660410471 posted

    Thank you!

    Removing the extension ".mdf" from the connection string helped me install DotNetNuke on Sql Server 2008 Express.

     

    Saturday, December 20, 2008 5:40 AM
  • User-697512575 posted

    HI,

     

    Thanks!!!!!!!!!!!!Wink 

    Monday, February 8, 2010 12:19 AM
  • User-247615575 posted

    Thank you very much.

    Smile


    Thursday, December 23, 2010 12:23 AM
  • User1536672466 posted

    "user instances enabled" this only for express edition not for enterprise edition  what i should do and i made it create a database but when i go web.config still point to datasourse "./express" not to the new database when you change the connection string datasourse it make a problem in the connection


    Wednesday, June 15, 2011 3:31 PM
  • User1536672466 posted

    there a way to move all of that manualy and in very easy way

    take the created database after changing web configuration then change the provider name don't leave it deafult then put your connection string it worked with me very will

    Saturday, June 18, 2011 12:23 PM