locked
Certification error: "The application silently terminates at launch" RRS feed

  • Question

  • We're trying to get our app published, but the application review returns negative with the mention "The application silently terminates at launch"

    However, we cannot reproduce this issue with our own test devices or the emulator. Furthermore, unhandled exceptions in our app are submitted (via a REST call) to our server, but none have been received.

    Other than purchasing the device used by the app reviewers, are there any other steps we can take to solve this issue?

    Monday, June 1, 2015 1:09 PM

Answers

All replies

  • Best guess is that your dev phone / emulators have a setting that is missing from the app downloaded from the store.  

    Where is the rest service that is reporting errors?  Is it in the unhandled exception event in app.xaml.cs or vb?   

    In your dashboard are you getting any crash reports?

    Tuesday, June 2, 2015 4:25 PM
  • Hello Stein,

    Testing should always be done with a Beta app as emulators or sideloaded apps do not pull all of the functions that the app would normally use in the store.  A Beta app will behave just like an app published to the store.  If you create a Beta and still cannot find the issue please contact Dev Center Support.

    -Miles


    Windows and Windows Phone Dev Center Support

    Send us your feedback about the Windows Platform

    Tuesday, June 2, 2015 8:51 PM
  • Error reporting is done in an 'unhandled exception' event handler added in App.xaml.cs. It's tested and works with manually triggered exceptions.

    The dashboard isn't getting any exceptions either.

    We've already tried with a Beta app distributed trough the store, but it runs fine on our devices after installation.

    We'll see about obtaining the same device as used by the app reviewer, and if that fails we'll contact dev center support.


    Wednesday, June 3, 2015 1:03 PM
  • Have you been able to track down your issue? I've got the same issue as you:

    • Beta application works fine
    • Side loading on my devices works fine
    • Unhandled exception reports in the App.xaml.cs are not being submitted to my REST service for this crash, but works otherwise
    • App keeps failing certification with "The app silently terminates at launch." as the reported problem.

    I'm stuck and can't figure out how to track down this issue.


    --- Bob --- 


    • Edited by Bob Bunn Friday, September 4, 2015 2:30 PM
    Friday, September 4, 2015 2:30 PM