none
best way to deploy .net 3.5? RRS feed

  • Question

  • My new .net application needs .net 3.5 framework.  I have found it is commonly not install though (even with windows vista).  Further, finding and installing .net 3.5 is a bit of a pain.

    Therefore I want my msi to deploy the .net 3.5 framework.  My question is, what is the best way to do this?  I really hate to include the entire framework in my msi as that inflates the size of my install massively.  Is there a way to include the launcher or something that would kick off the framework install from my applications msi install?  What do most people do for this?
    Monday, October 13, 2008 8:38 PM

Answers

  • If disk space is an issue, try opening the Prerequisites dialog and selecting "download prerequisites from the component vendor's site".

    This will cause the setup.exe to not be built with the NetFx 3.5 installer, but will download it from Microsoft.com when it needs to install it on a client computer.

    David Guyer - Deployment Technologies Group PM
    • Marked as answer by Figo Fei Monday, October 20, 2008 3:16 AM
    Tuesday, October 14, 2008 6:10 AM