none
kinectmonitor service absent / not running RRS feed

  • Question

  • I just got my Kinect v2 with a Kinect Adaptor for Windows. Everything runs great (if a little slow) on my Acer laptop, but on my developer desktop, after it goes through the plug-and-play install dance, the kinectmonitor and kinectservice fails to run (or possibly install?). It's weird. When I run the Kinect v2 Configuration Verifier it shows that I have a supported USB 3.0 port, and it shows the Kinect v2 is connected. But I get "Required Kinect software not detected". I ran services.msc and sure enough the kinectmonitor service isn't not even in the list, let alone running.

    I have an AMD Radeon HD 6450 with the latest drivers. It apparently supports DX11. Renesas USB 3.0 eXtensible Host Controller again with latest drivers. Inter i7, 8 cores total. But this sure doesn't seem like a hardware thing.

    I am running Windows 10 (build 10074), which might be a factor, but I did a cursory Google search and didn't get any hits relating to that.

    Any ideas? I have done the obligatory reboot and reconnect the device, but no joy.

    Monday, May 4, 2015 12:50 AM

All replies

  • Hello therealkenc,

    I am pretty sure I had a machine with the exact same USB controller. It didn't work either. Somebody in the Confirmed List of USB 3 [...] thread using the Renesas USB 3.0 Controller mentioned the same. I can exclude Windows 10 as I tried it myself with the Kinect v2 sensor. However I thought the performance might be worse than Windows 8.1. Did you try to install the SDK first? I am confused because of your "plug-and-play install dance".

    Best regards,

    Alex

    Monday, May 4, 2015 9:00 AM
  • Windows 10 is not an issue, it is fully supported, but the OS is still in preview so can't confirm what type of performance issues may occur. You can download the SDK directly and that will put on the monitor/runtime/service components needed for Kinect to operate correctly. When you first plug-in the sensor, you have to wait ~1min for the firmware flash process to complete. If you connect the device what do you see in device manager?

    Carmine Sirignano - MSFT

    Tuesday, May 5, 2015 7:11 PM
  • On my laptop the drivers / services installed automatically when the device was connected (plug-and-play dance). The Kinect demos ran without the installing the SDK.

    On my desktop, I ended up having to install the SDK, then run the Kinect driver installer manually to uninstall and reinstall. That got it working. Why? Who knows.

    The Renesas USB 3.0 Controller was detected as supported by the verification tool. I should have mentioned that explicitly in my initial post. It appears to be working for what it is worth.

    Thanks for the replies.

    Tuesday, May 5, 2015 9:05 PM
  • In most cases, connecting the sensor to the system will auto(magically) download the driver/runtime components from Windows Update service. In most cases, this is all that is needed, but if there was a hick-up(failed component, partial install) there could have been issues.

    if you don't need the SDK you can also just install the runtime components for v2 from here http://www.microsoft.com/en-us/download/details.aspx?id=44559.


    Carmine Sirignano - MSFT

    Friday, May 8, 2015 5:30 PM