none
.Net 4.0 Installation failure - Fatal Error RRS feed

  • Question

  • Recieving a Fatal Error message. Looked into all the information I could find here and nothing is working for me. Tried cleaning all other .Net with the cleanup utility and rebooting. Tried clearing out temp files. Ran as administrator, etc. Here is the short log file:

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = C:\2e67484b0aa74e1fd111f8337a8dd8\\Setup.exe /x86 /x64 /ia64 /web
    TimeZone = Central Daylight Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 12
    Exe (C:\2e67484b0aa74e1fd111f8337a8dd8\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\Users\ERICWE~1\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (C:\2e67484b0aa74e1fd111f8337a8dd8\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (C:\Users\ERICWE~1\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20121014_204041180-MSI_netfx_Core_x64.msi.txt
    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:05:42).

    the vslog file can be located here:

    http://www.mediafire.com/download.php?lyavdetygetbc4b

    Looking forward to getting some help with this!! Thanks.

    Monday, October 15, 2012 2:01 AM

Answers

  • Hi Eric,

    I’ve checked the log files and find the error messages below:

    MSI (s) (70:C0) [17:59:04:888]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIFAF6.tmp, Entrypoint: SchedSecureObjectsRollback
    Action start 17:59:04: SchedSecureObjectsRollback.
    SchedSecureObjectsRollback:  Failed to store ACL rollback information with error 0x80070424 - continuing
    SchedSecureObjectsRollback:  Failed to store ACL rollback information with error 0x80070424 - continuing

    Based on your error message, I found a thread following below.

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/64f8765e-d1d5-4002-b181-f829432f0d96

    Its content is:

    The error 0x80070424 might happen because the Windows update issues, would you please perform the steps mentioned in this article: http://support.microsoft.com/kb/968002 first?

    Then, please try some common troubleshooting steps:

    1.       Before install Visual Studio, you should finish the steps below first:

    -          Turn off your anti-virus/antispyware software during installation;

    -          Install the latest Windows updates from the Windows Update site: http://windowsupdate.microsoft.com;

    -          Complete or dismiss Windows Update before installation. (And don't forget to turn it on later)

    2.       Go to Add/remove programs in the control panel, check whether there are any components of .NET Framework 4.0 be installed
    If so, uninstall the .NET Framework 4.0 components.

    3.       Then run the .NET Framework setup with Administrator privilege:

    -          Make sure your user account is in Administrators group

    -          Right-click the installer -> Properties -> Security tab -> add your account with Full control.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, October 16, 2012 1:07 AM
    Moderator