locked
Error upon creation of Integration Services RRS feed

  • Question

  • After I aborted my installation of the tools that come with Katmai, I could not create Integration Services project nor add package to an existing project. I get the following error

    Constructor on type 'Microsoft.DataTransformationServices.Wizards.EtlProjectWizardInitializer' not found.

    I've removed anything that had the word 'Katmai' in Add/REmove programs. I've also reinstalled the 2005 tools. Still no luck. I'm just wondering if anyone here has encountered this error.
    Monday, July 23, 2007 1:20 PM

Answers

  • This sounds like one of the known bugs for Katmai.

     

    If this is the same issue that I'm thinking of, it's because the component which handles our project creation is pointing to the Katmai files.

     

    In the registry, the keys under (CLSID, CurVer):

    HKEY_CLASSES_ROOT\Microsoft.SqlServer.Management.UI.WizardManager

     

    Should be the same as:

     

    HKEY_CLASSES_ROOT\Microsoft.SqlServer.Management.UI.WizardManager.9

     

    The values should be:

     

    CLSID = {4503861B-5694-45AE-94DD-BC6541316FB7}

    CurVer = Microsoft.SqlServer.Management.UI.WizardManager.9

     

    If CurVer is Microsoft.SqlServer.Management.UI.WizardManager.10, then this is the issue that we've seen.

     

    Note, I can't recommend tweaking the registry by hand... but if uninstalling SQL Server and Visual Studio doesn't fix the issue, this might be an alternative.

     

    It's odd that you're still hitting it after uninstalling everything, but I guess aborting the installation might have left you in a bad state. I know that a number of setup related issues have been resolved since the June CTP, and hopefully the issue that put you into this state was one of them. Make sure that when you reinstall, you have no instances of Visual Studio running.

     

    ~Matt

    Tuesday, July 24, 2007 5:24 PM
  • There is a workaround to get the SQL Server 2005 tools working when it is installed with Katmai server.

    You need to update this file "<drive>:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\Business Intelligence Projects\DataTransformationsProject.vsz".

     

    Replace the "Microsoft.SqlServer.Management.UI.WizardManager" with "Microsoft.SqlServer.Management.UI.WizardManager.9". Save the change and restart the SQL Server 2005 tools. You should be able to create the new projects.

     

     

    Thursday, July 26, 2007 2:21 PM

All replies

  • I guess the abort did not rollback completely, but then its just my guess.
    Did you try re-installing katmai tools and do a complete un-install after that?.
    Monday, July 23, 2007 6:11 PM
  • Hi sir. I did a complete uninstall of Katmai db and tools. I'll try to reinstall it again, maybe it will help. I just repaired my VS2005Pro installation thinking it can solve the problem but still no luck. Sad
    Tuesday, July 24, 2007 3:24 AM
  • [Microsoft follow-up]

     

    Possible katmai bug here guys.

     

    Tuesday, July 24, 2007 4:29 AM
  • This sounds like one of the known bugs for Katmai.

     

    If this is the same issue that I'm thinking of, it's because the component which handles our project creation is pointing to the Katmai files.

     

    In the registry, the keys under (CLSID, CurVer):

    HKEY_CLASSES_ROOT\Microsoft.SqlServer.Management.UI.WizardManager

     

    Should be the same as:

     

    HKEY_CLASSES_ROOT\Microsoft.SqlServer.Management.UI.WizardManager.9

     

    The values should be:

     

    CLSID = {4503861B-5694-45AE-94DD-BC6541316FB7}

    CurVer = Microsoft.SqlServer.Management.UI.WizardManager.9

     

    If CurVer is Microsoft.SqlServer.Management.UI.WizardManager.10, then this is the issue that we've seen.

     

    Note, I can't recommend tweaking the registry by hand... but if uninstalling SQL Server and Visual Studio doesn't fix the issue, this might be an alternative.

     

    It's odd that you're still hitting it after uninstalling everything, but I guess aborting the installation might have left you in a bad state. I know that a number of setup related issues have been resolved since the June CTP, and hopefully the issue that put you into this state was one of them. Make sure that when you reinstall, you have no instances of Visual Studio running.

     

    ~Matt

    Tuesday, July 24, 2007 5:24 PM
  • Moving to the Katmai SSIS forum.
    Tuesday, July 24, 2007 7:31 PM
  • There is a workaround to get the SQL Server 2005 tools working when it is installed with Katmai server.

    You need to update this file "<drive>:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\Business Intelligence Projects\DataTransformationsProject.vsz".

     

    Replace the "Microsoft.SqlServer.Management.UI.WizardManager" with "Microsoft.SqlServer.Management.UI.WizardManager.9". Save the change and restart the SQL Server 2005 tools. You should be able to create the new projects.

     

     

    Thursday, July 26, 2007 2:21 PM
  • This weekend, I reinstalled both my VS2005Pro and SQL2005Dev as a final brute force solution. I was hoping that this would also erase in the registry the entry key that points to the non-existing or invalid dll. I noticed that even for the supposed "fresh" install, the layout of my IDE did not change and the problem was still there.

    Thanks so much for the replies guys. Feng, I will apply your solution.


    Monday, July 30, 2007 2:06 AM
  • I applied both solutions here. I don't care which one did it but the important thing is my headache is over. Thank you so much again! More power to you guys!
    Monday, July 30, 2007 2:48 AM
  • Just do "massage":

    1) uninstall SqlServer Workstation Components (SSIS) (Change/Remove programms: Change: Choise Integration Components to uninstall)

    2) install it once more

     

     

    Wednesday, October 31, 2007 7:27 PM

  • hi

    You can also try going to Control Panel' s Programs and Features.
    Choose Microsoft SQL Server 2005 and click the Uninstall button on top of the
    window. On the window that opens when you click Uninstall button, choose
    Workstation Components in the below list and ensure "Remove SQL Server 2005
    instance components" checkbox is UNchecked so only Workstation Components
    will be removed and your SQL Server instances will stay where they are ...
    Tuesday, May 19, 2009 5:59 PM