locked
keep toghether property is not working properly with groups in ssrs 2008 r2 while export to pdf RRS feed

  • Question

  • Hi All,

    keep toghether is not working properly with groups in ssrs 2008 r2 while export to pdf.

    i want item records of group should not be overflow to next page , if the page space is less for group records then group should be start from next page.

    for this i have set the group Keep Toghether=true but it does not impact.

    so, if anyone knows the solution , please tell me what should i do.

    Tuesday, June 12, 2012 9:13 AM

All replies

  • Hi There

    Can you please right click on the tablex and go to properties and try to set keep together on one page if possible and see if the problem get resolved

    Many thanks

    Syed  

    Tuesday, June 12, 2012 9:37 AM
  • Hi There

    I am talking about tablix property "keep together on one page if possible"

    Many thanks

    Syed

    Wednesday, June 13, 2012 4:56 AM
  • Hi,

    yes i already set this property of tablix.

    Wednesday, June 13, 2012 5:10 AM
  • Hi Devendra,

    Thanks for your posting.

    The PDF renderer is a physical page renderer and, therefore, has pagination behavior that differs from other renderers such as HTML and Excel. For such an issue, as what you have done, it is usually recommended that we select the target group and set the "Keep Together" property to "True". This can avoid page break within an instance of a group in some cases. But this behavior may not work as expected if the inner group have too many instances. In this issue, you can also try to adjust the rows height or the Margins.

    Personally, I recommend you that submit this suggestion at https://connect.microsoft.com/SQLServer/. If the suggestion mentioned by customers for many times, the product team may consider to add the feature in the next SQL Server version. Your feedback is valuable for us to improve our products and increase the level of service provided.

    Thanks for your understanding.

    Regards,
    Mike Yin

    Saturday, June 16, 2012 8:20 AM
  • Hi Mike,

    Thanks for reply.

    So, you want to say that  it is a known issue of SSRS 2008 R2.

    If yes , is there any fix release for this issue is released or not.

    Monday, June 18, 2012 5:45 AM
  • Hi Devendra,

    Thanks for your posting.

    Yes, the issue exists in SSRS 2008 R2 as well. If enabling the "KeepTogether" property of the group doesn't work perfectly, we may need to modify the Top/Bottom Margins to see if it works. 

    One another workaround is to add conditional page breaks to the target group. For example, if we want to add page break to the Region group if the Region field is "North America" or "Europe", we can use the following steps:

    1. Click the "Region" group from the Row Groups pane, expand the "Group" item from the Properties pane on the right of the Design surface.
    2. Expand the "PageBreak" item, set the "BreakLocation" to "End", and set the "Disabled" property based on the following expression:
    =iif(Fields!Region.Value="North America" or Fields!Region.Value="Europe",false,true)

    In this way, we can add page break to the specific instance of a group according to the layout of the report.

    The screenshot below is for your reference:

    Hope  this helps.

    Regards,
    Mike Yin

     

    Monday, June 18, 2012 4:42 PM
  • Hi Mike,

    Thanks for your Reply.

    we can not go with page break solution , due to it will increase the no of pages in PDF that is not acceptable to the customer because they want exact result like in SSRS 2008 R1.

    so , can you help me what values should be for top/bottom margins for resolving this problem, while in SSRS 2008 R1 we did'nt set any Keep Together , Page Break properties, even all is working fine , but after migrated to SSRS 2008 R2 issues are coming as i have mentioned and by setting properties like Keep Together also does not impact.

    For your information it is not the case in all reports , in some reports keep together is working fine but in some reports it is not working.

    So, can you tell me what could be reasons that after migration from SSRS 2008 R1 to SSRS 2008 R2 reports does not behave like R1 and issues coming like this.

    Thanks in advance.

    Regards,

    Devendra

    Tuesday, June 19, 2012 4:12 AM
  • Hi Devendra,

    Since the same report works fine in SSRS 2008, I think it is feasible to add conditional page breaks to the target group. This should not add the page numbers because the two reports will look like the same after we re-organize the report. If possible, I suggest that you reproduce the report in SSRS 2008 and compare the two reports to find out which locations we should add the page breaks to in the current report.

    As for adjusting the margins, we can try different values such as 1.2, 0.75, 0.5, 0.3 etc. and check the results. Please understand that modify the margins may also cause page numbers changes.

    Regards,
    Mike Yin 

    Tuesday, June 19, 2012 9:38 AM
  • Hi Mike,

    I already try page breaking, currently we have 8 pages and after apply page break at End it increases the page count to 26 and if set Between , Page count becomes 17, because now each group is coming on seperate page while i want that records og the group does not overflow to the next page, if space not available to start the next group then page should be break and group sholud start from next page, simply all the records inside that group should be keep together.

    as you can see in the above attached screen shot that some records of Material group are coming on this page and rest are coming on the page while in SSRS 2008 it's not happening while there is no page break no keep together property is set after that all is well.

    fyi, i attached SSRS 2008 screen shot of 3 page as below and for SSRS 2008 R2 refer above screen shot.


    Wednesday, June 20, 2012 3:45 AM
  • Hi, 

    I had the same problem, and it seems to be solved setting the property "keep together" to true on the next static column following the row group. 

    I had a row group, and after that two static row groups. To show the static groups, you have to activate the advance mode.

    I hope it helps future questions.

    • Proposed as answer by nikzk Friday, January 4, 2019 12:49 PM
    Wednesday, December 11, 2013 11:20 AM
  • I spent hours on this case and you just gave me the right solution! Thank you so much Mcfornier :)
    Tuesday, August 23, 2016 2:29 PM
  • How to turn on Group Panel advanced mode: 
    https://technet.microsoft.com/en-au/library/dd255242(v=sql.100).aspx
    Thursday, March 1, 2018 4:25 AM