Background image with no shell RRS feed

  • Question

  • Hi, I am using WEC7, and removed all shells, I only use my own application at bootup. But i am not able to seta background, is there a solution to that?



    I cant see image, is there a solution to that?

    It only bothers me when bootloader will finish the black background will apear  then my application will run.



    • Edited by LukecPivk Saturday, February 16, 2013 7:26 PM
    Saturday, February 16, 2013 7:24 PM

All replies

  • Try as below :

    reg setting ...


    bib file setting ...

    Background.bmp    $(_FLATRELEASEDIR)\Background.bmp               NK        S

    Make sure you have the bmp image in the FILES folder and your final image NK contains the bmp file.

    --- Misbah

    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India)

    • Edited by Misbah Khan Monday, February 18, 2013 5:19 AM
    Monday, February 18, 2013 5:13 AM
  • I am not sure that the above mentioned method will work. Above method uses control panel to show the screen background.

    i think, since the control panel is depending on the shell (since it is using shell APIs), not sure the control panel will load successfully without the shell support. so the above option may not can see the implementation of loading the background image in the following path


    simple solution you can launch a simple application and draw the background image then load your bigger application for that.


    Monday, February 18, 2013 7:55 AM
  • Yes, i agree with the answer above.

    I wrote a launcher application to launch my UI application and draw an image on the screen before that.

    Eg :

    In my launcher application i was calling as :

    bRet = CreateProcess(L"\\Mounted Volume\\SplashScreens\\Screen.exe",\
                    NULL, NULL, &ProcessInfo);


        bRet = CreateProcess(L"\\Mounted Volume\\GUI.exe",\
                    NULL, NULL, &ProcessInfo);

    Screen.exe was drawing image on screen and GUI.exe was my console application (UI)

    Under my project.reg i did the following settings to launch my launcher application :

    ;For Auto launching of Application  <misbah>


    Launcher application was built with the kernel and was part of the NK.bin

    You can follow this approach, and i hope this will resolve the issue.

    ---- Misbah

    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India)

    Monday, February 18, 2013 11:30 AM