none
Chaning C++ Text Editor Color Coding back to normal

    Question

  • I want to use Visual Studio 2015 and see black text, like 2012 has it. For a C++ project in VS 2015, I create a new code file and type #include. That text is gray. I thought #include it was blue before? I prefer my color coding to remain the same as it was. MS keeps changing things and I have to learn yet another new thing. Then I have to think about color coding when I want to think about what I'm doing, the code that I write, not text color coding.

    To put this back to what I'm used to for C++ projects (default of VS 2012) I went to Tools->Options->Environment->Fonts and Colors. I selected Text Editor settings and set Foreground color to black. I'll take all black text over new color coding any day. The setting did not take. #include is still gray.

    How can I fix this?


    Saturday, December 5, 2015 4:12 PM

Answers

  • Hi Joel_Z,

    Please try the solution which is provided by Gabriel in that feedback:

    It can be found under Tools --> Options --> Environment --> Fonts and Colors; to get there much more quickly, just press Ctrl+Q for Quick Launch and type in "fonts" (no quotes). Under "Display items" simply find the entry "Preprocessor Keyword" and change its color;

    I have tested this work-around with Visual Studio 2015 on Windows 8.1 in my side, it works for me.

    Best Regards,
    Weiwei

    • Marked as answer by Joel_Z Thursday, December 17, 2015 7:49 PM
    Thursday, December 17, 2015 5:44 AM
    Moderator

All replies

  • to the top
    Sunday, December 6, 2015 3:29 PM
  • Hi Joel_Z,

    This forum is discuss Visual Studio Setup and installation                                       

    As your issue is related to VS general question, I help you move this case to Visual Studio general questions forum for dedicated support.

    Thank you for your understanding.

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, December 7, 2015 5:31 AM
    Moderator
  • Hi Joel_Z,

    Which VS2015 Environment did you use? Which kind of VC++ App did you create?

    I remember that it really had this issue before, but I test it in my side after I installed the VS2015 update 1. It seems that it uses the default color now.

     For example, I just create a simple Win32 project or VC++ unit test project, the "#include" has the default color now. So please install the VS2015 update 1 for your VS2015, and then check it again.

    If still no help, please also reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, December 8, 2015 6:43 AM
    Moderator
  • Hi Joel_Z,

    Which VS2015 Environment did you use? Which kind of VC++ App did you create?

    I remember that it really had this issue before, but I test it in my side after I installed the VS2015 update 1. It seems that it uses the default color now.

     For example, I just create a simple Win32 project or VC++ unit test project, the "#include" has the default color now. So please install the VS2015 update 1 for your VS2015, and then check it again.

    If still no help, please also reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Its a default installation. I didn't pick an environment other than whatever is default. The project is a C++ native console app.  The setup and installation had just completed. I should not need to be reset right after that?
    Wednesday, December 9, 2015 12:20 AM
  • I reset settings. Same problem.

    Wednesday, December 9, 2015 12:26 AM
  • Hi Joel_Z,

    Based on your VS version informaiton, we could know that you don't install the VS2015 update 1. So please install the VS2015 update 1 in your side, and then test it again.

    https://www.visualstudio.com/news/vs2015-update1-vs

    I could repro this issue in my side using the VS2015 without the update 1, but it works well in my another VS2015 with update 1, so I think it is the update package's issue.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, December 9, 2015 6:47 AM
    Moderator
  • Hi Joel_Z,

    Based on your VS version informaiton, we could know that you don't install the VS2015 update 1. So please install the VS2015 update 1 in your side, and then test it again.

    https://www.visualstudio.com/news/vs2015-update1-vs

    I could repro this issue in my side using the VS2015 without the update 1, but it works well in my another VS2015 with update 1, so I think it is the update package's issue.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    well, I ran the update and the problem remains.

    Wednesday, December 9, 2015 7:48 PM
  • Hi Joel_Z,

    What is your Windows Environment? I test it in my VS2015 Enterprise version with update 1 in my windows 10, it really works well. One possible reason is that it would be related to the windows Environment.

    I test it in my VS2015 Enterprise version without update 1 in the windows 8.1 machine, it really has this issue, so I doubt that it would be related to the windows Environment, I will install the update 1 and check it again in my windows 8.1 machine. I will update it later.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, December 10, 2015 11:29 AM
    Moderator
  • Hi Joel_Z,

    What is your Windows Environment? I test it in my VS2015 Enterprise version with update 1 in my windows 10, it really works well. One possible reason is that it would be related to the windows Environment.

    I test it in my VS2015 Enterprise version without update 1 in the windows 8.1 machine, it really has this issue, so I doubt that it would be related to the windows Environment, I will install the update 1 and check it again in my windows 8.1 machine. I will update it later.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Even though Win10 is released, I prefer win7x64 and that is my OS environment. The environment includes VS2013 Update 5.

    Thursday, December 10, 2015 2:30 PM
  • Hi Joel_Z,

    I could repro this issue in my side using the same Environment as yours, it still has this issue in the Windows 8.1 even if I install the update 1. But it worked well in the VS2013.

    I think it would be a real issue.

    You can submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx,Microsoft engineers will evaluate them seriously.

    If you submit it, please share me the link here, I will help you vote it.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, December 11, 2015 2:50 AM
    Moderator
  • Hi Joel_Z,

    I could repro this issue in my side using the same Environment as yours, it still has this issue in the Windows 8.1 even if I install the update 1. But it worked well in the VS2013.

    I think it would be a real issue.

    You can submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx,Microsoft engineers will evaluate them seriously.

    If you submit it, please share me the link here, I will help you vote it.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    I've already posted about the problem here. If you would like the problem posted somewhere else, feel free to do so.
    Friday, December 11, 2015 1:45 PM
  • Hi Joel_Z,

    Since the connect report site collects all feedbacks of the latest VS products, so we often submit them there.

    I help you submit a feedback here:

    https://connect.microsoft.com/VisualStudio/feedbackdetail/view/2126065/vs2015-update-1-c-text-editor-color-coding-is-gray-in-windows-8-1-and-windows-7

    You could vote it.

    Sincerely,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 14, 2015 3:31 AM
    Moderator
  • Un-proposed since the problem isn't fixed, nor is there any work-around. Its a clear regression. Telling me what I already know is not an answered post :). I gave you up-votes. Hope that is enough.
    • Edited by Joel_Z Wednesday, December 16, 2015 7:05 PM
    Wednesday, December 16, 2015 7:03 PM
  • Hi Joel_Z,

    Please try the solution which is provided by Gabriel in that feedback:

    It can be found under Tools --> Options --> Environment --> Fonts and Colors; to get there much more quickly, just press Ctrl+Q for Quick Launch and type in "fonts" (no quotes). Under "Display items" simply find the entry "Preprocessor Keyword" and change its color;

    I have tested this work-around with Visual Studio 2015 on Windows 8.1 in my side, it works for me.

    Best Regards,
    Weiwei

    • Marked as answer by Joel_Z Thursday, December 17, 2015 7:49 PM
    Thursday, December 17, 2015 5:44 AM
    Moderator
  • Hi Joel_Z,

    Please try the solution which is provided by Gabriel in that feedback:

    It can be found under Tools --> Options --> Environment --> Fonts and Colors; to get there much more quickly, just press Ctrl+Q for Quick Launch and type in "fonts" (no quotes). Under "Display items" simply find the entry "Preprocessor Keyword" and change its color;

    I have tested this work-around with Visual Studio 2015 on Windows 8.1 in my side, it works for me.

    Best Regards,
    Weiwei


    I had already uninstalled VS2015. I take your word for the work-around. Much appreciated.
    Thursday, December 17, 2015 7:50 PM