locked
Starting SQL Server Agent and SQL Server RRS feed

  • Question

  • Hi there,
            I try to deploy one SSRS report. It throws an error

    "The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing."


    then we found than the two services are not running.
    They are "SQL Server Agent" and "SQL Server". 
             I am not able to start these two in "services.msc"

    Kindly someone help me to deploy the report.

    Thanks in advance,

    ~ Deva ~
    Tuesday, July 14, 2009 5:04 AM

Answers

  • Hi Prakash,
              Thanks for your reply.
    In our configuration manager i previously enabled the "VIA" service.
    This actually prevents me to start the above mentioned services.

    After disabling the "VIA" everthing is working good.

    This is for others finding the solution for the same.


    Deva
    ~ Deva ~
    • Marked as answer by Raymond-Lee Wednesday, July 22, 2009 9:08 AM
    Wednesday, July 15, 2009 11:13 AM

All replies

  • Hi Deva,

    ReportServer database is the central component of Reporting Services and hence when the SQl Server which hosts the reporting services database is not running, Report server will not be accessible.

    You need to check where your report server database is located( This infor can be located at All programs->sql server -> Config tools->reporting services config) and make sure that the particular database server is running.

    I dont think you would need SQL Server Agent job to be running for accessing Reporting services, SQL Server agent is mostly used for scheduling jobs etc., You should ideally post your SSRS queries at http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/threads as this is SSAS forum.

    Thanks,

    Prakash.P
    Tuesday, July 14, 2009 6:39 AM
    Answerer
  • Hi Prakash,
              Thanks for your reply.
    In our configuration manager i previously enabled the "VIA" service.
    This actually prevents me to start the above mentioned services.

    After disabling the "VIA" everthing is working good.

    This is for others finding the solution for the same.


    Deva
    ~ Deva ~
    • Marked as answer by Raymond-Lee Wednesday, July 22, 2009 9:08 AM
    Wednesday, July 15, 2009 11:13 AM