locked
Having a problem with the personal Website Template RRS feed

  • Question

  • User249751994 posted
    I am trying to use the Personal website Template. I am working with the Web  Application site at this point. However I am having some problems creating an acceptable Password. I keep getting this error code, (Password length minimum: 7. Non-alphanumeric characters required: 1). I have tried many combination to no success. I have come to the conclusion that there must be something else that I am missing.  <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p> <o:p></o:p>Any help with this matter would be greatly appreciated!<o:p></o:p>

     

    Saturday, April 5, 2008 2:06 PM

Answers

  • User1052258516 posted

    I have tried combinations like pipwax1 justin1P and many more correct me if I am wrong The tow passwords mentioned here should qualify as having meet the criteria.

    Try adding one of the following characters ! @ # $ % ^ & * ( ) _ + to what you have already entered.

    Also the default settings for the Membership provider (it is what handles your login settings) is setup this way to offer a better level of security by making users enter a stronger password than most users would make.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, April 5, 2008 3:27 PM

All replies

  • User1564875471 posted

    hi

    yes , this is the deafult membership settings... it doesnt allow a password less than 7 characcters.....

    however , you can change this settings , in wen.config file , you can set the membership configuration as follows:

     

        <membership defaultProvider="SqlMembershipProvider" userIsOnlineTimeWindow="15">
                <providers>
                    <clear />
                    <add
                      name="SqlMembershipProvider"
                      type="System.Web.Security.SqlMembershipProvider"
                      enablePasswordRetrieval="false"
                      enablePasswordReset="false"
                      requiresQuestionAndAnswer="false"
                      requiresUniqueEmail="true"
                      passwordFormat="Clear"
                      minRequiredPasswordLength="1"
                      minRequiredNonalphanumericCharacters="0"
                      />
                </providers>
            </membership>

     

    if you already have this settings , just add the following

             if you want to store the password as clear text  : passwordFormat="Clear"

    to set the minimum required password length( this allow 1 cahracter password ) :minRequiredPasswordLength="1"


    to set the number of minum allowed non alpha... ( this will make it unrequired at all)  :  minRequiredNonalphanumericCharacters="0"

    Saturday, April 5, 2008 2:41 PM
  • User249751994 posted

    I have tried combinations like pipwax1 justin1P and many more correct me if I am wrong The tow passwords mentioned here should qualify as having meet the criteria.

    Saturday, April 5, 2008 2:43 PM
  • User249751994 posted

    I am having trouble finding the wen.confg page. What file would that be under?

    Saturday, April 5, 2008 2:48 PM
  • User1052258516 posted

    I have tried combinations like pipwax1 justin1P and many more correct me if I am wrong The tow passwords mentioned here should qualify as having meet the criteria.

    Try adding one of the following characters ! @ # $ % ^ & * ( ) _ + to what you have already entered.

    Also the default settings for the Membership provider (it is what handles your login settings) is setup this way to offer a better level of security by making users enter a stronger password than most users would make.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, April 5, 2008 3:27 PM
  • User1564875471 posted

    Hi

    I Created a personal  website , the Web.Config file Is directly located in the main website directory ...

    you need to open that file ... and place the meberhip settings under  <system.web >  Node...

     

     

    Saturday, April 5, 2008 3:32 PM
  • User249751994 posted

    Thanks a Million! That did the trick!

    Sunday, April 6, 2008 3:07 PM