none
Issue with SFTP ARM Template RRS feed

  • Question

  • Hi All,

    I am trying to generate the SFTP(FTP-SSH) connector for Logic App. I have found the GitHub URL for this
    https://github.com/Azure/azure-quickstart-templates/blob/master/101-logic-app-ftp-to-blob/azuredeploy.json.

    {
          "type": "Microsoft.Web/connections",
          "apiVersion": "2018-07-01-preview",
          "location": "[parameters('location')]",
          "name": "[parameters('ftpConnectionName')]",
          "properties": {
            "api": {
              "id": "[subscriptionResourceId('Microsoft.Web/locations/managedApis', parameters('location'), 'ftp')]"
            },
            "displayName": "ftp",
            "parameterValues": {
              "serverAddress": "[parameters('ftpServerAddress')]",
              "userName": "[parameters('ftpUsername')]",
              "password": "[parameters('ftpPassword')]",
              "serverPort": "[parameters('ftpServerPort')]",
              "isssl": "[variables('ftpisssl')]",
              "isBinaryTransport": "[variables('ftpisBinaryTransportftpisssl')]",
              "disableCertificateValidation": "[variables('ftpdisableCertificateValidation')]"
            }
          }
        }


    But the Issue is upon using this, i am getting below error.

    "Code":"BadRequest","Message":"Input parameters are invalid. See details for more information. Details:errorCode: ParameterNotDefined. Message: Parameter 'serverAddress' is not allowed on the connection since it was not defined as a connection parameter when the API was registered..","Target":null,"Details":[{"Message":"Input parameters are invalid.


    Its Straight error that, Wrong Params are being passed. Can some one help on this.



    Monday, June 22, 2020 7:13 AM

All replies

  • Hi Lokanath,

    I was also facing similar issue. However, was able to solve it. Please find below the parameterValues object with proper field name:

    "parameterValues": {
                    "hostName": "[variables('SftpServerAddress')]",
                    "userName": "[variables('SftpUsername')]",
                    "password": "[variables('SftpPassword')]",
                    "portNumber": "[variables('SftpServerPort')]",
                    "acceptAnySshHostKey": true,//I didn't need this field in my connection
                    "sshHostKeyFingerprint": "testdata", //I didn't need this field in my connection
                    "rootFolder": "/" //I didn't need this field in my connection
                }

    Please try this. Hope this works for you as well.

    Thursday, July 9, 2020 1:54 PM