locked
SSDT startup as normal user RRS feed

  • Question

  • hi folks,
    I was wondering if there are any specific settings for Group Policies to allow SSDT 2014 to start up for *regular* users, without prompting for Admin/Elevated privileges.  I have tried tinkering w/ disabling the UAC  (https://www.youtube.com/watch?v=QZsC4A8J9-o)    and other articles on the Net , but to no avail.

    Thanks much for any thoughts,

    Cos

    Friday, April 6, 2018 6:09 PM

Answers

All replies

  • thanks Vikram,
    for some reason, after I create the task and shortcut as an Admin, to test the Task, it works Ok.
    However, when I log off and log back in as the Standard user, the shortcut does not seem to get invoked.

    if I create the task originally, as "Log in under different privs" again, the task under the Standar user does not fire or files in the background.  (for Windows 2012R2).

    I reviewed the article a number of times, tried a few permutations but still at a los.

    any other thoughts, is there any way to accomplish this without the use of Task Scheduler?

    thanks much,
    Cos

    Friday, April 6, 2018 8:11 PM
  • Hi Cos,

    Thanks for your posting.

    This forum is for Visual Studio IDE issues, as your question is more related to SSDT, I will recommend you post this thread on SSDT forum to get a quick answer.

    And I also found a related article about which might help.

    https://support.microsoft.com/en-sg/help/2000257/sql-server-installation-fails-if-the-setup-account-doesn-t-have-certai

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, April 9, 2018 8:08 AM
  • thx, will take this to the SSDT forum.

    Cos

    Monday, April 9, 2018 1:44 PM
  • it seems the SSDT (accessable through SQL Server 2014 folder)  is Visual Studio 2013  found at 
    C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe

    would that make any difference?  
    I've posted on the SSDT forum, as recommended, although not sure if that would make any effective difference.

    thank you,
    Cosmin

    Monday, April 9, 2018 1:50 PM
  • Can you launch VS as a normal user?

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Wednesday, April 11, 2018 7:31 AM
    Wednesday, April 11, 2018 7:30 AM
  • Visual Studio 2012 can be launched fine, with no problem, as a normal user.
    Visual Studio 2013 and SSDT 2014 need elevated permissions.  I have a call into MS, shortly, to see how this can be mitigated and will reply back with any findings.

    thx,

    Cos

    Wednesday, April 11, 2018 3:55 PM
  • found the solution at:  

    https://prajwaldesai.com/disable-user-account-control-using-group-policy/

    i
    mplemented and tested and looks OK.

    thx

    • Marked as answer by Cos2008 Wednesday, April 11, 2018 5:38 PM
    Wednesday, April 11, 2018 5:38 PM