none
The "Parameters" section under "Manage Report" will not display

    Question

  • This is in reference to the "Parameters" section in the SSRS 2017 web UI after clicking the Ellipses > Manage, and is NOT about parameters displaying in the report.  I tried to add a screenshot but it won't let me.

    We upgraded from SQL Server 2016 to SQL Server 2017.  This also required us to reinstall SSRS as it was not included with SQL Server 2017.  We are using Visual Studio 2017 to produce RDLs, and then uploading them with the SSRS interface.

    We are now re-uploading RDLs and have made the following notations:
    -RDLs were working as expected with SQL Server 2016
    -RDLs do not produce any errors when uploading to SSRS
    -After an RDL is uploaded, the report runs as expected, however, when we click the ellipses (…) and then 'Manage' to manage the report, the parameters section will not display
    -The Properties/Data Sources/Subscriptions/etc... menu items all work except for 'Parameters'.
    -After clicking the 'Parameters' menu item, the 'wait-indicator-spinner' is shown but the page never loads.
    -After testing by creating a new RDL and by editing an existing one, we have narrowed this issue down to reports that include a <DataSetReference> element in <ReportParameter>.<ValidValues>.
    -We have even tried a DataSet with a query of "SELECT 1" to rule out that the dataset itself was causing the issue, but it appears to be only the reference that the SSRS interface cannot handle.

    Does anyone know what could be causing this issue?

    Wednesday, February 27, 2019 9:52 PM

All replies

  • Hi LukeSQL

    According to your description , we could not reproduce your issue .

    If possible you could check in the following ways to get more detailed information .

    • Restart the ssrs service, clean the browser cache, and then test if it works fine or not .
    • Open the developer tools in browser , check if there exist any error in console , or any error status in the network tab.
    • You could try to enable the ssrs http log and ssrs log, and then offer the detailed information to us.

    You could post the correspond information to cloud disk (one drive , google drive) , and attach the url here.

    Hoping for your reply.

    Best Regards,

    Eric Liu


    Best Regards, Eric Liu MSDN Community Support Please remember to click Mark as Answer if the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread.

    Thursday, February 28, 2019 2:42 AM