locked
An error occured while trying to create new web application RRS feed

  • Question

  • Hi,

     When I am trying to create a new web application, I am getting an error saying that "The current custom error settings for this application prevent the details of the application error from being viewed". Please look at the below screen shot.


    Sekar - Our life is short, so help others to grow


    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Mark As Answer

    • Edited by SekThang Wednesday, January 2, 2013 12:36 PM
    Wednesday, January 2, 2013 12:35 PM

Answers

  • Hi All,

     Thanks for all your helping information. I am planning to reinstall and re-config whole the things from scratch.

    Regards,

     Sekar


    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Marked as answer by SekThang Monday, January 7, 2013 9:18 AM
    Monday, January 7, 2013 9:18 AM

All replies

  • Hi 

    When you try creating you webapplication then as you showed this error occurs. Did you see your created application in Manager Web Application list. ?

    Are you trying to create Claims based Authentication web app??


    Thanks, Ali Yasir

    Wednesday, January 2, 2013 12:38 PM
  • Hi,

    This is error message is not the friendly error. We need to find out the real error message. You can check the event reviewer for more detailed error message. Or you can change the web.config file to turn the mode to on like shown in the picture you provided. The web.config file is located here:

    1. Stored at inetpub\wwwroot\wss\Virtual directories folder\[Central Admin PortNo]\web.config
    2. Stored at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\ADMIN\web.config
    3. Stored at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\Layouts\web.config

    Change the <customErrors mode=”RemoteOnly”> to <customErrors mode=”on”>. Perform an IIS reset after changing the web.config file(make a copy of these file before making any changes).

    Then create a web application again. If you still cannot create the web application, a detailed error message will show up. You can share that error so that we can better understand your issue.

    For similar issues, please refer to these sites:

    Problem and Solution: Error while creating web application in SharePoint 2010: http://www.c-sharpcorner.com/blogs/6839/problem-and-solution-error-while-creating-web-application-i.aspx

    error while creating new web application in sharepoint 2010: http://sharepoint.stackexchange.com/questions/9323/error-while-creating-new-web-application-in-sharepoint-2010

    Sharepoint 2010 Server Error '/' in Application: http://it.toolbox.com/blogs/wss-search/sharepoint-2010-server-error-in-application-42707

    Thanks,

    Entan Ming


    Entan Ming
    TechNet Community Support

    Thursday, January 3, 2013 6:36 AM
  • Hi Entan,

     I tried all the steps which you mentioned in the above thread. However I am not able to resolve it. If you have any other steps please let me know.


    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Thursday, January 3, 2013 9:45 AM
  • Hi,

    Please modify the web.config file to allow show detailed error message on page. Or you can refer to error log for more detailed information. The error log is located at: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS. Please share these error message, so that we can better understand your issue.

    Thanks,

    Entan Ming


    Entan Ming
    TechNet Community Support

    Thursday, January 3, 2013 10:18 AM
  • Hi SekThang

    you can try below , it have work in my case

    To turn on friendly error messages in your web applications web.config (found via INETPUB).

    • Disable Custom Error Pages by setting this web.config entry:  customErrors=off
    • Enable Stack Traces by adding this property to the SharePoint SafeMode tag also in web.config: CallStack=”true”

    This will give real error, then and then only we can figurout what is the issue.


    Please mark answer , if you think answer is helpful or correct.

    Thursday, January 3, 2013 12:03 PM
  • Hi Sekar,

    Please provide the options which you have selected while creating the web application(alternatively post a screen shot of the filled create web application form before you click on Ok)

    Regards,

    Srikanth

    Thursday, January 3, 2013 4:39 PM
  • Hi All,

     Thanks for all your helping information. I am planning to reinstall and re-config whole the things from scratch.

    Regards,

     Sekar


    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Marked as answer by SekThang Monday, January 7, 2013 9:18 AM
    Monday, January 7, 2013 9:18 AM