locked
IIS Manager Error: The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020) RRS feed

  • Question

  • User-1865415349 posted

    This is IIS 7 in Windows Vista Ultimate. The web site is stopped and when I try to start it the error message (in subject) appears.

    In EventLog(System) I get the following following errors:

    Source: HttpEvent

    Msg: Unable to bind to the underlying transport for [::]:80. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine. The data field contains the error number.

    --------------------------------------------------------------------------------------------------------------------------------- 

     Source: IIS-W3SVC

    Msg: The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 1. The site has been disabled. The data field contains the error number.

    I'm at a loss. I have no clue as to what is wrong. Any help would be greatly appreciated.

    Tuesday, March 13, 2007 2:16 PM

All replies

  • User264806290 posted

    This is an issue with binding conflict. There is another application that is using port 80. If you change the bindings for the default website to 8080 [for test purpose] it will work.

    You can run NETSTAT -ano and find out the PID for the process that is using port 80, then you can compare that PID with the process name in task manager [may be skype.exe?]

    HTH,

    AJ

    Tuesday, March 13, 2007 2:47 PM
  • User-1865415349 posted
    Thank you, that solved it.
    Tuesday, March 13, 2007 2:55 PM
  • User1420765406 posted

    LOL.. Thanks for the heads up.. I just loaded skype and was having problems after this... Been pulling my hair out trying to get to the root cause, I did the netstat and found a listener on 80 but the pid really didn't give a good indication...

    I wanna move skype off 80... That seems to be a better method since I have control of my router... I might just delay start skype so IIS will own the port first, see if that causes "Smart Skype" to move off the port...

    Anyway, Thank you! I didn't think skype was on it...

    Tm. 

     

     

     

    Wednesday, March 21, 2007 11:08 AM
  • User989702501 posted
    Yes, skype will change to other port if 80 is taken.

    I have been using IIS and skype for quite sometime.
    Monday, March 26, 2007 4:29 AM
  • User-1467303052 posted

     Hi, I have a similar issue and the solution on this post did not resolve my problem. Port 80 doesnt seem to be used by any program after running netstat -ano. I also changed the binding from 80 to 8080 just to try that and I still got the same error. I really need help as I have a site that I want to put up. Can someone help me resolve this issue PLEASE. I just cant start the default IIS website.

    Wednesday, February 20, 2008 11:32 AM
  • User1073881637 posted

    I would turn off all related IIS services, set them to manual, reboot your machine and type netstat -an -p tcp and see if anything is listening on port 80.

    Saturday, February 23, 2008 11:54 PM
  • User1576531646 posted

    Thank you, thank you, thank you.

    I've spent hours on the same problem, then read your forum and sorted within minutes.

    My problem was not skype but Kontiki hogging port 80.

    :)

    Saturday, April 5, 2008 2:09 PM
  • User-554427789 posted

    Thank you for the pointer.

    Skype was indeed hogging port 80 and turning it off solved my problem as well.

    Saturday, May 10, 2008 7:06 AM
  • User2009917062 posted

    Thanks this has solved my problem in starting the Default Web Site.

    But when i tried to host the web site .. Im rec Service Unavailable 503 Error.

     Both the IIS server and Default Website are running.

     Suggestions my apperciated

     

     - Sam

    Friday, May 30, 2008 10:01 PM
  • User1073881637 posted

    did you reset IIS and make sure nothing was contending for port 80?  Check the httperr logs to see what error you are seeing. 

    Saturday, May 31, 2008 12:44 AM
  • User150156398 posted

    Thanks guys, same problem with me here.

    Solved now.

     

    thanks again.

    Sunday, June 15, 2008 5:17 AM
  • User-547376791 posted

    I did netstat -ano and got this

     

    TCP    0.0.0.0:42             0.0.0.0:0              LISTENING       3540
    TCP    0.0.0.0:53             0.0.0.0:0              LISTENING       1460
    TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       1336
    TCP    0.0.0.0:81             0.0.0.0:0              LISTENING       3792
    TCP    0.0.0.0:82             0.0.0.0:0              LISTENING       3792
    TCP    0.0.0.0:88             0.0.0.0:0              LISTENING       452

     

    I didnt know what was pid 1336 i killed it, when i tried to start the wesite same error: cant start blablabla. And when i do netstat -ano it shows again, but when i try to kill it again id says that it dont exist.Any solution?

     

    Sorry for my bad english 

    Tuesday, November 11, 2008 9:52 PM
  • User989702501 posted

    shows again? what PID then? what program is that ?

    Wednesday, November 12, 2008 8:23 AM
  • User-547376791 posted

    The same PID. It says http when i do -ao.

    But when i try to kill it says that it doesnt exisit that pid its wierd 

    Wednesday, November 12, 2008 8:25 AM
  • User989702501 posted
    the program id 1336 is HTTP? what is that? not inetinfo.exe ? can you get process explorer to find out what is that program binding to port 80? maybe it auto restart when u killed it.
    Wednesday, November 12, 2008 8:28 AM
  • User-547376791 posted

     Apache.exe, a feel so stupid

    Wednesday, November 12, 2008 8:45 AM
  • User989702501 posted

    @@ glad you found it.

    Wednesday, November 12, 2008 8:47 AM
  • User-547376791 posted

    I forgot to say thank you, thank you! 

    Wednesday, November 12, 2008 9:05 AM
  • User-547376791 posted

    Sorry again me, i dont want to open another topic i want to ask another thing:) Well now everything works fine exept the php i will handle with that later. When i try to open the website local it works fine. But, when i try to open the website from another computer not connected to the server it says:

     The server at ****** is taking too long to respond.
    # The site could be temporarily unavailable or too busy. Try again in a few
        moments.

    #   If you are unable to load any pages, check your computer's network
        connection.

    #   If your computer or network is protected by a firewall or proxy, make sure
        that Firefox is permitted to access the Web.

     

    Any help about this?:D Thank you 

    Wednesday, November 12, 2008 10:44 AM
  • User1073881637 posted

    If it works locally, but not remotely.  It's most likely a local firewall or router blocking port 80.  On your remote box type , telnet x.x.x.x 80 (replace x.x.x.x with real ip address) and see if you have a black screen.  This will tell if connectivity is there. 

    Wednesday, November 12, 2008 1:31 PM
  • User-547376791 posted

     Thank you very much m8. I set my server except i cannot test now php because i got error like this:

     You do not have permission to view this directory or page due to the access control list (ACL) that is configured for this resource on the Web server.

    This is my last asking help question here :D If you can answer ill be thankfull a lot :D

     

    Thanks

    Thursday, November 13, 2008 9:09 AM
  • User-1341446551 posted

     if you get this when you try to browse the page ... check if the IIS ID's have the proper permissions on the resource...

    Friday, November 14, 2008 5:16 PM
  • User-1236133841 posted

     I have a similar problem with a Small Business Server 2003.  The IIS service cannot be started and after following KB 890015 I don't find any processes using port 80 from netstat -anop TCP.  When I check the registry for the ListenOnlyList, there isn't a value, it is not present indicating the default setting of 0.0.0.0.  However, I did look at the running processes in Taskmgr and noticed that the Apache.exe is shown.

     

    Any suggestions for this situation?

    Monday, January 5, 2009 5:49 PM
  • User989702501 posted

    Err... so either make apache binds on other port or make sure IIS and apache bind to different IP.

    Tuesday, January 6, 2009 7:21 AM
  • Tuesday, January 6, 2009 7:35 AM
  • User143133081 posted

    I am having the same problem. I have 3 test/development site setup on a serve.  They are using ports 1028, 1029 and 1030. Recently, 2 of sites automatically stop and when trying to restart I get the same error.

    I have change the ports and then after a day, the same thing happens.  I have run netstat -ano and found that "cimlistener" is using those ports. 

     TCP    127.0.0.1:1028         127.0.0.1:1029         ESTABLISHED     1292
     TCP    127.0.0.1:1029         127.0.0.1:1028         ESTABLISHED     1292

     

    I just find it strange that even if I change the ports, they lock up.  Any suggestions ?

    Sunday, January 11, 2009 8:38 PM
  • User989702501 posted

    So there you go.. that cimlistener program is conflicting with the port you using.

    You can either use other port say 8080, 8081 which not so commonly used by others. or if you are using server OS, setup multiple site with single IP on the same port 80 via different host header.. google for more info.

    Monday, January 12, 2009 9:14 AM
  • User-1545287761 posted

     I am having the same problem and getting the same error as most are talking about on here. Tried all suggestions and found the only thing using port 80 is 127.0.0.1 which would be my localhost I believe. Anyways, would this cause the error I am getting? I'm trying to learn some stuff about IIS as we haven't had any coursework yet in web development for my MIS degree. I have port forwarding setup on my router for port 80, and don't think this would be causing the error. Any suggestions?

    Friday, January 16, 2009 2:54 PM
  • User1073881637 posted

    type netstat -ano and see the PID numbers.  Open task manager and see what process is using it.

    Friday, January 16, 2009 7:13 PM
  • User989702501 posted

    Tried all suggestions? what are those? what's the output of netstat -ano ?

    Sunday, January 18, 2009 12:29 AM
  • User-157117040 posted

    After using some of the suggestions here I have found that process 0 is the process that is tied to port 443 which i am trying to free up so that my iis part of my exchange server can run.  This process is part of the system idle processes and I really don't want to kill that process.  Not sure how to move forward from here.

    Tuesday, August 11, 2009 12:05 PM
  • User511787461 posted

    What do the following commands (from an elevated command prompt) say?

    %windir%\system32\inetsrv\appcmd.exe list sites
    netsh http show servicestate

    Tuesday, August 11, 2009 12:29 PM
  • User-157117040 posted

    First Command:

    SITE "Default Web Site" (id:1,bindings:net.tcp/808:*,net.pipe/*,net.msmq/localhost,msmq.formatname/localhost,https/*:443:,state:Stopped)
    SITE "Redirect Site" (id:2,bindings:http/*:80:,state:Stopped) 

    Second Command is a bit longer:

    Snapshot of HTTP service state (Server Session View):
    -----------------------------------------------------

    Server session ID: FD00000320000001
        Version: 1.0
        State: Active
        Properties:
            Max bandwidth: 4294967295
            Timeouts:
                Entity body timeout (secs): 120
                Drain entity body timeout (secs): 120
                Request queue timeout (secs): 120
                Idle connection timeout (secs): 120
                Header wait timeout (secs): 120
                Minimum send rate (bytes/sec): 150
        URL groups:
        URL group ID: FC00000340000001
            State: Active
            Request queue name: Request queue is unnamed.
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited

    Server session ID: FF00000220000003
        Version: 2.0
        State: Active
        Properties:
            Max bandwidth: 4294967295
            Timeouts:
                Entity body timeout (secs): 120
                Drain entity body timeout (secs): 120
                Request queue timeout (secs): 65535
                Idle connection timeout (secs): 120
                Header wait timeout (secs): 120
                Minimum send rate (bytes/sec): 240
        URL groups:
        URL group ID: FE00000240000001
            State: Active
            Request queue name: DefaultAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: FD00000240000001
            State: Active
            Request queue name: MSExchangeServicesAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: FC00000240000001
            State: Active
            Request queue name: DefaultAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: 4294967295
                Timeouts:
                    Entity body timeout (secs): 120
                    Drain entity body timeout (secs): 120
                    Request queue timeout (secs): 65535
                    Idle connection timeout (secs): 120
                    Header wait timeout (secs): 0
                    Minimum send rate (bytes/sec): 0
                Logging information:
                    Log directory: C:\inetpub\logs\LogFiles\W3SVC1
                    Log format: 0
        URL group ID: FB00000240000001
            State: Active
            Request queue name: DefaultAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: FA00000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
                Authentication Configuration:
                    Authentication schemes enabled:
                        NTLM
                        Negotiate
                    Authentication settings:
                        Receive context handle
        URL group ID: F900000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F800000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F700000240000001
            State: Active
            Request queue name: MSExchangeUMAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F600000240000001
            State: Active
            Request queue name: MSExchangeSyncAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F500000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F400000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F300000240000001
            State: Active
            Request queue name: MSExchangeAutodiscoverAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F200000240000001
            State: Active
            Request queue name: MSExchangeServicesAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F100000240000001
            State: Active
            Request queue name: DefaultAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: F000000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: EF00000240000001
            State: Active
            Request queue name: MSExchangeAutodiscoverAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: EE00000240000001
            State: Active
            Request queue name: DefaultAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: 4294967295
                Timeouts:
                    Entity body timeout (secs): 120
                    Drain entity body timeout (secs): 120
                    Request queue timeout (secs): 65535
                    Idle connection timeout (secs): 120
                    Header wait timeout (secs): 0
                    Minimum send rate (bytes/sec): 0
                Logging information:
                    Log directory: C:\inetpub\logs\LogFiles\W3SVC2
                    Log format: 0
        URL group ID: ED00000240000001
            State: Active
            Request queue name: MSExchangeUMAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: EC00000240000001
            State: Inactive
            Request queue name: RemotingAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: EB00000240000001
            State: Active
            Request queue name: DefaultAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: EA00000240000001
            State: Active
            Request queue name: MSExchangeOWAAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited
        URL group ID: E900000240000001
            State: Active
            Request queue name: MSExchangeAutodiscoverAppPool
            Properties:
                Max bandwidth: inherited
                Max connections: inherited
                Timeouts:
                    Timeout values inherited

    Request queues:
        Request queue name: MSExchangeAutodiscoverAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 0
            Controller process ID: 4044
            Process IDs:

        Request queue name: MSExchangeOWAAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 1
            Controller process ID: 4044
            Process IDs:
                4476

        Request queue name: DefaultAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 0
            Controller process ID: 4044
            Process IDs:

        Request queue name: RemotingAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 0
            Controller process ID: 4044
            Process IDs:

        Request queue name: MSExchangeUMAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 0
            Controller process ID: 4044
            Process IDs:

        Request queue name: MSExchangeServicesAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 0
            Controller process ID: 4044
            Process IDs:

        Request queue name: MSExchangeSyncAppPool
            Version: 2.0
            State: Active
            Request queue 503 verbosity level: Limited
            Max requests: 1000
            Number of active processes attached: 0
            Controller process ID: 4044
            Process IDs:

        Request queue name: Request queue is unnamed.
            Version: 1.0
            State: Active
            Request queue 503 verbosity level: Basic
            Max requests: 1000
            Number of active processes attached: 1
            Process IDs:
                1080

    Tuesday, August 11, 2009 12:42 PM
  • User-157117040 posted

    First command:

    SITE "Default Web Site" (id:1,bindings:net.tcp/808:*,net.pipe/*,net.msmq/localhost,msmq.formatname/localhost,https/*:443:,state:Stopped)
    SITE "Redirect Site" (id:2,bindings:http/*:80:,state:Started)

    Second Command:

    Tuesday, August 11, 2009 1:07 PM
  • User-157117040 posted

    The redirect site listed above works fine.  I can connect to that just fine but the first site does not.

    Tuesday, August 11, 2009 1:28 PM
  • User511787461 posted

    What exactly is running in process-id 1080?

    Friday, August 14, 2009 2:38 PM
  • User-157117040 posted

    I apologize, usually I double and triple check the answers given by the experts but I guess this time I asked an extra question to soon.  With the tools provided in the previous posts I was able to come across a PCHelpware process that was grabbing control of port 443 before IIS.  Thanks for your reply anilr.  And rest of forum.

    Friday, August 14, 2009 5:06 PM
  • User-1977365625 posted

    Very helpful post.

    cheers!
    Guru

    Tuesday, September 29, 2009 12:25 AM
  • User1724128306 posted

     Can you people help me out in this one...

     I can't see any thing on my IIS manager. There is no default website, just i want to know how to store websites in iis manger.

    And i am using the WINDOWS VISTA Home premium.  I enabled everything in iis manger, is located in windows feature.

     

    Wednesday, October 28, 2009 2:01 PM
  • User989702501 posted

    Any error msgs during turn on/off the IIS component?
    And when you fire up IIS Manager, you got nothing? no app pool, default website /etc.

    Wednesday, October 28, 2009 8:42 PM
  • User-157117040 posted

    Any error msgs during turn on/off the IIS component?
    And when you fire up IIS Manager, you got nothing? no app pool, default website /etc.

     You may want to uninstall iis and reinstall it, doesn't sound like its default settings are correct.

    Thursday, October 29, 2009 8:36 AM
  • User806733620 posted

    skype.exe was the problem

     stop skype and restart iis

    Thanks

    Wednesday, April 21, 2010 2:02 AM
  • User-978148633 posted

    Great stuff!! saved me hours of troubleshooting :) Thank You

    Tuesday, October 19, 2010 11:45 AM
  • User-1299551009 posted
    skype was screwing my iis was also, goto skype settings and uncheck the checkbox in advanced. IIs works then.....
    Tuesday, October 25, 2011 8:58 AM
  • User989702501 posted

    Mm.. I'm so curious about your OS and the Skype's version.

    I did a test last week on a R2, and wanted to use skype on the box, so I deploy it.
    out of the box everything work fine :) by now skype installer should be 'smart' enough to bind to the port 80 anymore.

    Thursday, October 27, 2011 1:48 AM
  • User608976117 posted
    my issue was with Teamviewer blocking 443 :)
    Friday, January 13, 2012 9:45 AM
  • User-972363958 posted

    HI,

    i get this stupid error, but this is not a solution for me the ports im getting is following:

    UDP    172.30.248.95:53       *:*                                    1180
    UDP    172.30.248.95:67       *:*                                    1160
    UDP    172.30.248.95:68       *:*                                    1160
    UDP    172.30.248.95:69       *:*                                    3724
    UDP    172.30.248.95:137      *:*                                    4
    UDP    172.30.248.95:138      *:*                                    4
    UDP    172.30.248.95:2535     *:*                                    1160
    UDP    172.30.248.95:4011     *:*                                    3724
    UDP    172.30.248.95:5041     *:*                                    3724
    UDP    [::]:123               *:*                                    856
    UDP    [::]:1434              *:*                                    1728
    UDP    [::]:54853             *:*                                    1180
    UDP    [::1]:53               *:*                                    1180
    UDP    [::1]:69               *:*                                    3724
    UDP    [::1]:5041             *:*                                    3724
    UDP    [::1]:54851            *:*                                    1180

     if i change port to *8080 there's no problem but with 80 it just wont work .. i dont have skype installed or any other of those programs. Just got a simple sccm installation on my 2008 R2 x64 server. 

    // Ola

    Tuesday, February 28, 2012 4:24 AM
  • User989702501 posted

    what about the TCP ports binding, you only list UDP.

    HTTP is on TCP. you running 'netstat -ano' ?

    Wednesday, February 29, 2012 1:52 AM
  • User521890537 posted

     Use command netstat -n to list all connections.

    Filter port 80 -> netstat -ano | findstr :80

    Friday, March 2, 2012 1:25 AM
  • User608976117 posted
    you are looking in the wrong place, look at the task manager and see the apps running, if you can't see it, start killing one by one until it works... most likely is a service
    Friday, March 2, 2012 9:34 AM
  • User989702501 posted
    Should only kill the one that is binding on port 80, hence the netstat -ano command,  killing all one by one will only put the system in unstable stage.
    Sunday, March 4, 2012 5:41 AM
  • User275306433 posted

    The problem is with Binding port. To change the binding port:

    1. Open Internet Information Services (IIS) Manager.
    2. Select the Web site that you wish to configure.
    3. In the Action pane, click Bindings.
    4. Click Add to add a new site binding, or click Edit to change an existing binding.
    5. Click OK to apply the changes.
    Tuesday, February 18, 2014 5:37 AM
  • User-591340961 posted

    Change the web site port no by default it's 80 change some other 

    Thursday, November 6, 2014 1:13 AM
  • User-1540811998 posted

    Hi,

    In my case, i only quit of skype and work fine.

    Regards

    Wednesday, February 25, 2015 3:06 PM
  • User-985716112 posted

    Quit of skype worked for me too .. Upssss .. at-last... tried so much ..Cry

    Friday, August 7, 2015 4:24 AM
  • User-535532787 posted

    Internet Information Services (IIS) Manager
    ---------------------------
    The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)
    ---------------------------
    OK  
    ---------------------------

    C:\Users\>netstat -aon |find ":8089"
      TCP    0.0.0.0:8089           0.0.0.0:0              LISTENING       1556

    I Found splunk uses the same port,  resolved the issue

    Thanks

    Thursday, October 17, 2019 3:50 PM