none
Can't Install .NET Framework 4.6.2 on Windows Embedded 8.1 Industry Pro/Windows Update Not Working Correctly RRS feed

  • Question

  • When I run the offline installer this pops up:

    Warnings:
    Setup may not run properly because the Windows Modules Installer Service is not available on this computer.

    I've tried fixing this problem my starting the service manually and editing the registry. Neither of those things worked.

    At the end of the installation, it presents me with: Installation Did Not Succeed

    .NET Framework 4.6.2 has not been installed because: The parameter is incorrect.

    Along with this, the Windows Updater Service seems to be offering me two of the same updates I've already installed and doesn't seem to be offering anything new.

    Update for Windows 8.1 for x64-based Systems (KB2990967)

    Update for Windows 8.1 for x64-based Systems (KB3063843)


    Monday, April 3, 2017 2:48 PM

All replies

  • Sounds like you have done the basic steps to resolve the issues. The service is there and running, but the install fails. The only suggestion is to clear out Windows Update files, which might be stuck. Otherwise, you might want to elevate the question directly to Microsoft tech support.


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Monday, April 3, 2017 3:43 PM
    Moderator