locked
(SOLVED) Secondary Server Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' RRS feed

  • Question

  • User878022173 posted

    --------------------------------------------------------------

    EDIT: WE NOW HAVE A WORKAROUND FOR THIS ERROR:

    1. UN-INSTALL the Web Farm Agent from the Secondary server (no need to reboot).

    2. On the Controller, select Repair for the Secondary, and this time it should get past the RunMethod successfully and in the trace you will see it installing the various downloaded components on the Secondary and bring to the Ready For Load Balancing state (=Yes).

    With much thanks to CJ from the WFF team!! Good luck finding the cause of the error guys!

    Cheers,

    Richard

    --------------------------------------------------------------

    Hi, 

    I have been trying to get WFF working and although the Primary Server joins the farm and is successfully started, the Secondary Server fails with the following error:

    Failed to run operation 'ProvisionPlatform'.  Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server '<SERVERIP>'.  Exception in response stream.  The 'META' start tag on line 8 does not match the end tag of 'HEAD'. Line 10, position 3.  Exception in response stream.  The 'META' start tag on line 8 does not match the end tag of 'HEAD'. Line 10, position 3.

    These are brand new VM's running WS2008 R2 in a Workgroup (Public Network) with Core Networking and Remote Admin allowed on the firewalls. I have checkted that RPCSS and MPSSVC running on both servers.

    I did install Web PI on the Secondary Server - was that a mistake? Or do I need to enable ARR on this server (I thought the WFF does that).

    When I try to either Repair or start from scratch with adding the Secondary, the same error occurs and it also errors the Primary (ie. Ready for NLB becomes No instead of Yes, with the same error listed).

    Thanks,

    Richard

     

    Wednesday, September 29, 2010 5:27 AM

All replies

  • User878022173 posted

    The exact error is as follows:

    Failed to run operation 'QueryInstalledProducts'.  Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server 'ip.ip.ip.ip'.  Exception in response stream.  The 'META' start tag on line 8 does not match the end tag of 'HEAD'. Line 10, position 3.  Exception in response stream.  The 'META' start tag on line 8 does not match the end tag of 'HEAD'. Line 10, position 3.

    Has anyone else had this error? Anyone know how to fix it? Obviously the Secondary server is not responding with correctly formatted xml, which is meant (I assume) to be telling the Primary Server what products are installed already.

    I installed ARR and Web Deploy on the Secondary, but it made no difference.

    I tried from scratch with another clean Secondary Server. Same error.

    Please help - we need these up in time for the Windows Phone launch next month as we are a showcase partner.

    Thanks,

    Richard

    Thursday, September 30, 2010 2:16 PM
  • User878022173 posted

    FYI the log for WebPI on the Secondary only contains:

     DownloadManager Information: 0 : Loading product xml from 'https://go.microsoft.com/fwlink/?LinkId=193533'
    DownloadManager Information: 0 : Product manager downloading: https://go.microsoft.com/fwlink/?LinkId=193533
    DownloadManager Information: 0 : Loading product xml from 'https://www.microsoft.com/web/webpi/2.0/WebApplicationList.xml'
    DownloadManager Information: 0 : Product manager downloading: https://www.microsoft.com/web/webpi/2.0/WebApplicationList.xml
    DownloadManager Information: 0 : Filtering by majorOS: 6, minorOS: 1, majorSP: 0, minorSP: 0, productType: 7, architecture: x64
    DownloadManager Information: 0 : Filtering by majorOS: 6, minorOS: 1, majorSP: 0, minorSP: 0, productType: 7, architecture: x64

    Thursday, September 30, 2010 5:29 PM
  • User-350889266 posted

    It looks like the WebPI feed WFF is trying to use is actually an HTML page.  Have you changed the location of the WebPI feed WFF uses?

    Thursday, September 30, 2010 6:27 PM
  • User2086242793 posted

    Hi,

    You don't need to install ARR or webdeploy on the secondary or primary machines (here I am assuming that your primary machine is not your controller machine). WFF service will automatically install those products for you. You need WebPI and WebDeploy on the controller machine. The error which you are getting happens if the agent service on the failing secondary machine, gets a webPage instead of a feed. You can try accessing http://www.microsoft.com/web/webpi/2.0/Webproductlist.xml" from the failing secondary box and see if you get Web PI 2.0 feed. This is the URL which WFF used by default and can be found webfarm.xml at %windir%\System32\inetsrv\config\schema. If you have trouble accessing the URL from the secondary machine, you need to fix that.

    Let me know if you need more help.

    Thanks,

     

    Thursday, September 30, 2010 8:05 PM
  • User-1660770209 posted
    I'm having the exact same problem. The first server is fine, the second gives the error about the 'META' start tag. I've confirmed that the second machine can definitely get to that URL. I've rebooted, checked the firewall, etc.
    Friday, October 1, 2010 6:06 PM
  • User-1464647883 posted

    Can you please provide detailed repro steps so that we can try to get an in house repro of this issue at our end? We will need as much details as you can provide right from how you installed the OS, what architecture, SKU you installed and what changes (firewall/ports etc) you did to the machines and what steps did you take to setup the farm (UI/powershell etc).

    Thanks
    CJ (WFF QA team)

    Friday, October 1, 2010 7:50 PM
  • User-350889266 posted

    According the log file it's trying to load an fwlink (https://go.microsoft.com/fwlink/?LinkId=193533). Lately we've discovered this fwlink sometimes returns an HTML page with a meta-refresh to do the redirection which will give the error you're seeing.

     You could try bypassing the fwlink and pointing WebPI directly to: https://www.microsoft.com/web/webpi/2.0/Webproductlist.xml

    I think Gurpreet knew how to change the WebPI XML location for WFF.

    Friday, October 1, 2010 8:06 PM
  • User-1660770209 posted
    My system doesn't have the fwlink url, it has the full direct link specified and is experiencing the problems.

    <attribute name="feedUrl" type="string" defaultValue="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml" />

    To be clear, the webfarm.xml file should live only on the controller machine, right? Here's my setup:

    Software: Web Farm Framework 2 beta
    Controller Machine: Windows 7 Ultimate x64. Not joined to a domain.
    Primary Web Server: Windows Server 2008 R2 Web Edition in a Hyper-V VM. Joined to a domain. 192.168.2.61
    Secondary Web Server: Windows Server 2008 R2 Web Edition in a Hyper-V VM. Joined to a domain. 192.168.2.62

    The WPI is installed on both servers, but the Web Farm Framework was not. All three machines can access the WebproductList.xml file through IE. For me the problem seems intermittent. Sometimes I can provision a server, other times I can't.

    The two web servers have had their firewalls opened up for RemoteAdministration. MSDeploy is installed on both, along with a pretty default ASP.NET feature install. Anything else?

    Here's one of the errors I get:

    Failed to run operation 'ProvisionPlatform'. Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server '192.168.2.61'. Exception in response stream. The 'META' start tag on line 8 does not match the end tag of 'HEAD'. Line 10, position 3. Exception in response stream. The 'META' start tag on line 8 does not match the end tag of 'HEAD'. Line 10, position 3.
    Friday, October 1, 2010 9:27 PM
  • User878022173 posted

    Hi,

    You don't need to install ARR or webdeploy on the secondary or primary machines (here I am assuming that your primary machine is not your controller machine). WFF service will automatically install those products for you. You need WebPI and WebDeploy on the controller machine. The error which you are getting happens if the agent service on the failing secondary machine, gets a webPage instead of a feed. You can try accessing http://www.microsoft.com/web/webpi/2.0/Webproductlist.xml" from the failing secondary box and see if you get Web PI 2.0 feed. This is the URL which WFF used by default and can be found webfarm.xml at %windir%\System32\inetsrv\config\schema. If you have trouble accessing the URL from the secondary machine, you need to fix that.

    Let me know if you need more help.

    Thanks,

     

     

     

    Hi Gurpreet,

    Primary machine is not the controller. The controller has WebPI and WebDeploy installed.

    Primary and Secondary had basic Windwos 2008 R2 installed, with Firewalls opened for Remote Admin and Core Networking. Not on domain, public network.

    The reason I said I started installing other things like ARR etc. on the Secondary was simply to see if it made a difference, obviously it did not.

    On the Secondary, if I go to %windir%\System32\inetsrv\config\schema there is a webfarm.xml file, and this is all it contains:

    <configSchema>
        <sectionSchema name="webFarms">

            <collection addElement="webFarm">
                <attribute name="name" type="string" required="true" isUniqueKey="true" validationType="siteName"/>
                <attribute name="enabled" type="bool" defaultValue="true"/>

                <collection addElement="server">
                    <attribute name="address" type="string" required="true" isUniqueKey="true" validationType="nonEmptyString"/>
                    <attribute name="enabled" type="bool" defaultValue="true"/>
                </collection>
            </collection>
        </sectionSchema>
    </configSchema>

    If I try to open webfarm.xml file in IE, IE just sits there saying "Connecting..." forever.

    So now I have created another Secondary server (Windows 2008 R2). Opened the same firewall options. Installed nothing extra. Same error. On this machine there is NO webfarm.xml file in windir%\System32\inetsrv\config\schema.

    FYI both machines can see the WebProductList.xml feed in IE when I go to that link directly in IE.

    Thanks,

    Richard

    Saturday, October 2, 2010 5:00 AM
  • User878022173 posted

    According the log file it's trying to load an fwlink (https://go.microsoft.com/fwlink/?LinkId=193533). Lately we've discovered this fwlink sometimes returns an HTML page with a meta-refresh to do the redirection which will give the error you're seeing.

     You could try bypassing the fwlink and pointing WebPI directly to: https://www.microsoft.com/web/webpi/2.0/Webproductlist.xml

    I think Gurpreet knew how to change the WebPI XML location for WFF.

    Thanks andrew, that is exactly the problem.

    I would love to know how to I change the WebPI XML location for WFF...Gurpreet...anyone?

    This is the contents of the webfarm.xml file on the Controller - it seems to have the correct address and NOT the fwlink:

    <configSchema>
      <sectionSchema name="webFarms">
        <collection addElement="webFarm">
          <attribute name="name" type="string" required="true" isUniqueKey="true" validationType="siteName"/>
          <attribute name="enabled" type="bool" defaultValue="true"/>
          <attribute name="runAgentAsAdmin" type="bool" defaultValue="true" />
          <attribute name="autoEnableAgent" type="bool" defaultValue="true" />
          <attribute name="adminUserName" type="string" />
          <attribute name="adminPassword" type="string" encrypted="true" defaultValue="[enc:AesProvider::enc]" />
          <attribute name="minimumServers" type="int" defaultValue="0" />
          <attribute name="agentUrl" type="string" defaultValue="http://{0}:8173/WEBFARMAGENTSERVICE/" />
          <attribute name="agentAuthenticationType" type="string" defaultValue="NTLM" />
          <attribute name="restartServerOnConfigurationChange" type="bool" defaultValue="true" />
          <attribute name="primaryServer" type="string" />
          <attribute name="loadBalancerProvider" type="string" defaultValue="Arr" />
          <attribute name="periodicRuntimeData" type="timeSpan" defaultValue="00:00:01" />
          <attribute name="enableRuntimeData" type="bool" defaultValue="true" />
          <attribute name="stopOnInstall" type="bool" defaultValue="true" />
          <attribute name="maximumStoppedServers" type="int" defaultValue="1" />
          <attribute name="agentRetryTime" type="timeSpan" defaultValue="00:05:00" />
          <attribute name="frontEndUrl" type="string" />
          <element name="platformProvision">
            <attribute name="syncPlatformFromPrimary" type="bool" defaultValue="false" />
            <attribute name="periodicSync" type="timeSpan" defaultValue="00:05:00" />
            <attribute name="feedUrl" type="string" defaultValue="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml" />
            <collection addElement="platform">
              <attribute name="productId" type="string" isUniqueKey="true" />
            </collection>
          </element>
          <element name="applicationProvision">
            <attribute name="syncWebServerFromPrimary" type="bool" defaultValue="false" />
            <attribute name="periodicSync" type="timeSpan" defaultValue="00:00:30" />
            <collection addElement="syncProvider">
              <attribute name="providerName" type="string" required="true" validationType="nonEmptyString" />
              <attribute name="path" type="string" required="true" validationType="nonEmptyString" />
              <collection name="syncProviderSetting" addElement="add" removeElement="remove" clearElement="clear">
                <attribute name="name" type="string" required="true" isUniqueKey="true"/>
                <attribute name="value" type="string"/>
              </collection>
            </collection>
          </element>
          <element name="customProviderSettings">
            <collection addElement="customProvider">
              <attribute name="name" type="string" required="true" isUniqueKey="true" />
              <collection addElement="setting">
                <attribute name="name" type="string" required="true" isUniqueKey="true" />
                <attribute name="value" type="string" required="true" />
              </collection>
            </collection>
          </element>
          <collection addElement="server">
            <attribute name="address" type="string" required="true" isUniqueKey="true" validationType="nonEmptyString"/>
            <attribute name="enabled" type="bool" defaultValue="true"/>
          </collection>
        </collection>
      </sectionSchema>
    </configSchema>

    Thanks,

    Richard

    Saturday, October 2, 2010 5:37 AM
  • User878022173 posted

    Can you please provide detailed repro steps so that we can try to get an in house repro of this issue at our end? We will need as much details as you can provide right from how you installed the OS, what architecture, SKU you installed and what changes (firewall/ports etc) you did to the machines and what steps did you take to setup the farm (UI/powershell etc).

    Thanks
    CJ (WFF QA team)

    We are using Tagadab.com VPS service, so these are virtual machines setup from their image files of Windwos 2008 R2; they appear to be vanilla R2 installs. Steps to repro (which I have done 3 times now, so you should have no trouble repro'ing this):

    We have 3 VM's running Windows 2008 R2 Standard on a Workgroup in a Vlan, Public Network type. They all have the same root admin, same password.

    Controller - this has WebPI and WFF installed

    Primary & Secondary with nothing installed.

    All machines have the Windows Firewall open for Core Networking, Remote Admin

    Create the WebFarm using the Wizard, add the IP of the Primary Server. Wat for it to get to the "Yes" state in Ready for Load Balancing.

    Add the Secondary Server, tick the "Provision" box. The trace shows it runs GetInstalledProductsQuery and sees that WebPI and WFF are not on the Secondary, so it trys to download WebPI.msi and WFF.msi and copy them to the Secondary server, which appears to work. It then executes and delete them. Then it runs the GetInstalledProductsQuery a second time, and fails. When I check the Secondary server, the 2 products were not installed. So I installed them manually, which worked. Then I re-run adding the Secondary server and it fails GetInstalledProductsQuery every time. It is NOT intermittent, it always fails with the same error posted originally.

    Thanks,

    Richard

    Saturday, October 2, 2010 6:42 AM
  • User878022173 posted

    According the log file it's trying to load an fwlink (https://go.microsoft.com/fwlink/?LinkId=193533). Lately we've discovered this fwlink sometimes returns an HTML page with a meta-refresh to do the redirection which will give the error you're seeing.

     You could try bypassing the fwlink and pointing WebPI directly to: https://www.microsoft.com/web/webpi/2.0/Webproductlist.xml

    I think Gurpreet knew how to change the WebPI XML location for WFF.

     I think the WebPI log file does help illumminate what the problem might be, since I have just noticed that the fwlink in the WebPI log actually refers to WebApplicationList.xml NOT WebProductList.xml - 2 different feeds. There is no problem on any of the 3 servers opening either the WebApplicationList.xml file or the WebProductList.xml file in IE.

    If I open WebPI on any of the servers, it shows the list of applications (ie. the feed is being read correctly by WebPI).

    It is WFF that seems to have the problem reaching it's xml file, the link for which is stored in the webfarm.xml file on the controller. This link is the WebProductList.xml one - https://www.microsoft.com/web/webpi/2.0/Webproductlist.xml

    So how do we get WFF to see that file correctly?

    Saturday, October 2, 2010 12:45 PM
  • User2086242793 posted

    You should not change the webfarm.xml. What I meant was you can add an attribute "feedUrl" in the ApplicationHost.config file and WFF will use that URL to download the products.

    Here is an example on how my webfarms element looks like after adding the attribute in ApplicationHost.config file. But you should not need to do this, because the default value of feedUrl is http://www.microsoft.com/web/webpi/2.0/WebproductList.xml, I am trying to find out if you have added feedUrl attribute in ApplicationHost.config file.

     <webFarms>
            <webFarm name="WFF" enabled="true" adminUserName="{0}\Administrator" adminPassword="somePassword" primaryServer="demoprimary" feedUrl="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml">
                <server address="demoprimary" enabled="true" />
                <server address="demosecondary" enabled="true" />
                <platformProvision syncPlatformFromPrimary="true" />
                <applicationProvision syncWebServerFromPrimary="true" periodicSync="00:00:30">
                </applicationProvision>
            </webFarm>
        </webFarms>

    Monday, October 4, 2010 4:16 PM
  • User-1464647883 posted

    We have not been able to reproduce this in our testing. Is there any way you can setup a remote connection to your machines for us to investigate this? Or is it possible for you to export the VMs and send them over to us?

    Monday, October 4, 2010 8:01 PM
  • User878022173 posted

    You should not change the webfarm.xml. What I meant was you can add an attribute "feedUrl" in the ApplicationHost.config file and WFF will use that URL to download the products.

    Here is an example on how my webfarms element looks like after adding the attribute in ApplicationHost.config file. But you should not need to do this, because the default value of feedUrl is http://www.microsoft.com/web/webpi/2.0/WebproductList.xml, I am trying to find out if you have added feedUrl attribute in ApplicationHost.config file.

     <webFarms>
            <webFarm name="WFF" enabled="true" adminUserName="{0}\Administrator" adminPassword="somePassword" primaryServer="demoprimary" feedUrl="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml">
                <server address="demoprimary" enabled="true" />
                <server address="demosecondary" enabled="true" />
                <platformProvision syncPlatformFromPrimary="true" />
                <applicationProvision syncWebServerFromPrimary="true" periodicSync="00:00:30">
                </applicationProvision>
            </webFarm>
        </webFarms>

     

     

    Hi Gurpreet, sorry for slow reply I have been ill.

    We have not changed the webfarm.xml.

    I agree that we should not need to amend the ApplicationHost.config file but I believe it is worth trying your suggestion. However, when I add the feedUrl attribute to the webfarm element, IIS cannot read the file - it says it is an unknown attribute.

    Very odd that you have it working in your config file if IIS does not recognise the attribute. Just so you know I put it in the same place, here is a copy of the config (I removed the secondary server for now):

       <webFarm

       serverAutoStart="false"
       name="Tx3Farm"
       enabled="true"
       adminUserName="{0}\Administrator"
       adminPassword="[****]"
       primaryServer="ip.ip.ip.ip"
       feedUrl="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml">


                <server address="ip.ip.ip.ip" enabled="true" />
                <platformProvision syncPlatformFromPrimary="true" />
                <applicationProvision syncWebServerFromPrimary="true" />


       </webFarm>

    Wednesday, October 6, 2010 9:24 AM
  • User878022173 posted

    We have not been able to reproduce this in our testing. Is there any way you can setup a remote connection to your machines for us to investigate this? Or is it possible for you to export the VMs and send them over to us?

     

     

    I think it will take too long to send the VM's, so I've sent you a PM with the remote login details. Please confirm receipt.

    Thanks,

    Richard

    Wednesday, October 6, 2010 9:26 AM
  • User-1451607909 posted

    My mistake.

    It should be:

     <webFarms>
            <webFarm name="WFF" enabled="true" adminUserName="{0}\Administrator" adminPassword="somePassword" primaryServer="demoprimary" >
                <server address="demoprimary" enabled="true" />
                <server address="demosecondary" enabled="true" />
                <platformProvision syncPlatformFromPrimary="true" feedUrl="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml"/>
                <applicationProvision syncWebServerFromPrimary="true" periodicSync="00:00:30">
                </applicationProvision>
            </webFarm>
        </webFarms>

    Wednesday, October 6, 2010 3:07 PM
  • User878022173 posted

    My mistake.

    It should be:

     <webFarms>
            <webFarm name="WFF" enabled="true" adminUserName="{0}\Administrator" adminPassword="somePassword" primaryServer="demoprimary" >
                <server address="demoprimary" enabled="true" />
                <server address="demosecondary" enabled="true" />
                <platformProvision syncPlatformFromPrimary="true" feedUrl="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml"/>
                <applicationProvision syncWebServerFromPrimary="true" periodicSync="00:00:30">
                </applicationProvision>
            </webFarm>
        </webFarms>

    Thanks I'll try that now and post again.

    Wednesday, October 6, 2010 3:20 PM
  • User878022173 posted

    My mistake.

    It should be:

     <webFarms>
            <webFarm name="WFF" enabled="true" adminUserName="{0}\Administrator" adminPassword="somePassword" primaryServer="demoprimary" >
                <server address="demoprimary" enabled="true" />
                <server address="demosecondary" enabled="true" />
                <platformProvision syncPlatformFromPrimary="true" feedUrl="http://www.microsoft.com/web/webpi/2.0/WebproductList.xml"/>
                <applicationProvision syncWebServerFromPrimary="true" periodicSync="00:00:30">
                </applicationProvision>
            </webFarm>
        </webFarms>

    Thanks I'll try that now and post again.

    Just logged on to the Controller to find that WFF is working with NLB enabled across the Primary and Secondary sucessfully!

    I assume that CJ has fixed it...can't wait to find out what he did! The applicationhost.config file does not have the feedUrl added, so it wasn't that (as you suspected it might not be).

     

    Wednesday, October 6, 2010 3:25 PM
  • User-1464647883 posted

    Hi Richard, I uninstalled the following from the servers-<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>

    Primary<o:p></o:p>

    URL Rewrite       - not sure if you really need this on Primary & Secondary<o:p></o:p>

    ARR                      - not sure if you really need this on Primary & Secondary<o:p></o:p>

    ECache                - if you do not need ARR, you don’t need this.<o:p></o:p>

    WFFv2                - if you do not need ARR, you don’t need this.<o:p></o:p>

    WebPI                 - WebPI need not be installed on primary and secondary for WFF v2 to work. WFFv2 will automatically load required assemblies of WebPI without installing full WebPI<o:p></o:p>

     

    Secondary<o:p></o:p>

    WFF v2<o:p></o:p>

    WebPI<o:p></o:p>

     

    Then, I removed both servers from the farm and re-added them.
    Now the farm is in good state.

    Thursday, October 7, 2010 12:50 PM
  • User878022173 posted

     

    Thanks CJ, appreciate the fast response and for fixing the farm...but I think we still have a rogue error here that needs tracking down.

    I have built another clean WS2008R2 machine and tried to add that as a Secondary also to this now working farm. The same error occurs on that machine too!

    I have emailed you the details to see if you can reproduce it.

    Regards,

    Richard

     

    Thursday, October 7, 2010 2:31 PM
  • User878022173 posted

    WORKAROUND:

    To get round this error:

    1. UN-INSTALL the Web Farm Agent from the Secondary server (no need to reboot).

    2. On the Controller, select Repair for the Secondary, and this time it should get past the RunMethod successfully and in the trace you will see it installing the various downloaded components on the Secondary and bring to the Ready For Load Balancing state (=Yes).

    With much thanks to CJ from the WFF team!! Good luck finding the cause of the error guys!

    Richard

     

     

    Thursday, October 14, 2010 4:13 PM
  • User1624460637 posted

    What do you do when the workaround does not work?

     When ever I try to add a secondary server to the farm I get this...

    Failed to run operation 'RunRemote'.  Failed to run method 'Microsoft.Web.Farm.SyncApplicationsRemoteMethod' on server 'iciweb-p3'.  Exception in response stream.  Object of type 'webServer' and path '' cannot be created.  (10/22/2010 12:12:53 PM) An error occurred when the request was processed on the remote computer.  Object of type 'webServer' and path '' cannot be created.  One or more entries in the manifest 'webServer' are not valid.  Unable to access the IIS configuration system. Please make sure you have IIS 7 (or later) installed.  Could not find a part of the path 'C:\Windows\system32\inetsrv\config\schema'.  Exception in response stream.  Object of type 'webServer' and path '' cannot be created.  (10/22/2010 12:12:53 PM) An error occurred when the request was processed on the remote computer.  Object of type 'webServer' and path '' cannot be created.  One or more entries in the manifest 'webServer' are not valid.  Unable to access the IIS configuration system. Please make sure you have IIS 7 (or later) installed.  Could not find a part of the path 'C:\Windows\system32\inetsrv\config\schema'.

    Failed to run operation 'ProvisionApplications'.  Failed to run method 'Microsoft.Web.Farm.SyncApplicationsRemoteMethod' on server 'iciweb-p3'.  Exception in response stream.  Object of type 'webServer' and path '' cannot be created.  (10/22/2010 12:12:53 PM) An error occurred when the request was processed on the remote computer.  Object of type 'webServer' and path '' cannot be created.  One or more entries in the manifest 'webServer' are not valid.  Unable to access the IIS configuration system. Please make sure you have IIS 7 (or later) installed.  Could not find a part of the path 'C:\Windows\system32\inetsrv\config\schema'.  Exception in response stream.  Object of type 'webServer' and path '' cannot be created.  (10/22/2010 12:12:53 PM) An error occurred when the request was processed on the remote computer.  Object of type 'webServer' and path '' cannot be created.  One or more entries in the manifest 'webServer' are not valid.  Unable to access the IIS configuration system. Please make sure you have IIS 7 (or later) installed.  Could not find a part of the path 'C:\Windows\system32\inetsrv\config\schema'.

    Failed to run operation 'AddServer'.  Failed to run method 'Microsoft.Web.Farm.SyncApplicationsRemoteMethod' on server 'iciweb-p3'.  Exception in response stream.  Object of type 'webServer' and path '' cannot be created.  (10/22/2010 12:12:53 PM) An error occurred when the request was processed on the remote computer.  Object of type 'webServer' and path '' cannot be created.  One or more entries in the manifest 'webServer' are not valid.  Unable to access the IIS configuration system. Please make sure you have IIS 7 (or later) installed.  Could not find a part of the path 'C:\Windows\system32\inetsrv\config\schema'.  Exception in response stream.  Object of type 'webServer' and path '' cannot be created.  (10/22/2010 12:12:53 PM) An error occurred when the request was processed on the remote computer.  Object of type 'webServer' and path '' cannot be created.  One or more entries in the manifest 'webServer' are not valid.  Unable to access the IIS configuration system. Please make sure you have IIS 7 (or later) installed.  Could not find a part of the path 'C:\Windows\system32\inetsrv\config\schema'.

    if I make the secondary server primary it works - but the primary will not come up as a secondary.

    Any ideas?

    Friday, October 22, 2010 3:30 PM
  • User878022173 posted

    Stuart,

    I don't think you are going to get much help on this thread for two reasons:

    1. This thread (ie. my problem) has been solved.

    2. Your problem is a different issue. You can see that the Web.Farm.SyncApplications is the remote method that is failing for you, whereas for me it was the Web.Farm.GetInstalledProducts

    Sorry I can't help with that, and the workaround I posted was for this error, not the error you have posted. I would advise you to start a new thread.

    Regards,

    Richard

    Tuesday, October 26, 2010 6:27 AM