none
Webservice works on Workstation but failed on 2003 Server with error: TCP error code 10060: RRS feed

  • Question

  • I developed a Web service and it works fine when I run from my local workstation. My web service call another web service outside company network(Through proxy).

    When I deployed this service to 2003 Server (IIS6.0) I am getting below error.

    Could not connect to https://URL/.
    TCP error code 10060: A connection attempt failed because the connected party
    did not properly respond after a period of time, or established connection
    failed because connected host has failed to respond 54.231.122.14:443

    Below is my web.config setting:

    <system.serviceModel>

        <bindings>

          <basicHttpBinding>

            <binding name="BasicHttpBinding_MYShippingService" closeTimeout="00:01:00"

            openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"

            allowCookies="false" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard"

            maxBufferSize="65536" maxBufferPoolSize="524288" maxReceivedMessageSize="65536"

            messageEncoding="Text" textEncoding="utf-8" transferMode="Buffered"

            useDefaultWebProxy="true">

              <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"

              maxBytesPerRead="4096" maxNameTableCharCount="16384"/>

              <security mode="Transport">

                <transport clientCredentialType="None" proxyCredentialType="None" realm=""/>

                <message clientCredentialType="UserName" algorithmSuite="Default"/>

              </security>

            </binding>

          </basicHttpBinding>

        </bindings>

        <client>

          <endpoint address="https://URL/"

          binding="basicHttpBinding" bindingConfiguration="BasicHttpBinding_MYShippingService"

          contract="MYWebService.MYShippingService" name="BasicHttpBinding_AdsiShippingService"

          behaviorConfiguration="DisableServiceCertificateValidation" />

        </client>

        <behaviors>

          <endpointBehaviors>

            <behavior name="DisableServiceCertificateValidation">

              <clientCredentials>

                <serviceCertificate>

                  <authentication certificateValidationMode="None"  revocationMode="NoCheck" />

                </serviceCertificate>

              </clientCredentials>

            </behavior>

          </endpointBehaviors>

        </behaviors>

      </system.serviceModel>   

     

      <system.net>

        <defaultProxy useDefaultCredentials="true">

          <proxy usesystemdefault="True" bypassonlocal="True"/>

        </defaultProxy>

        <settings>

          <servicePointManager checkCertificateName="false" checkCertificateRevocationList="false" />

        </settings>

      </system.net>  

    <u5:p> </u5:p>

    Source code from I am calling the web service:

    IWebProxy objProxy = WebRequest.GetSystemWebProxy();

    objProxy.Credentials = new NetworkCredential(objMapping.ProxyUserID, objMapping.ProxyUserPwd);<u5:p> </u5:p>

    WebRequest.DefaultWebProxy = objProxy;

    Please let me know, if IIS server or my code required any change.

    Lakshman T

    Wednesday, February 19, 2014 7:20 PM

Answers

  • Hi,

    I saw that you were using https. In order to config the wcf service to use the https, please try to check the following:
    HTTP transport security requires an SSL certificate to be registered with IIS. If you do not have an SSL certificate you can use IIS to generate a test certificate. Next you must add an SSL binding to the web site and configure the web site’s authentication properties. Finally you need to configure the WCF service to use HTTPS.

    For more information, please try to refer to:
    #How to: Configure an IIS-hosted WCF service with SSL:
    http://msdn.microsoft.com/en-us/library/hh556232(v=vs.110).aspx .

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, February 20, 2014 2:03 AM
    Moderator