none
Party Resolution / Duplicate document arriving with 997. RRS feed

  • Question


  • I have a partner configured to send acknowledgements and have associated a send port with the partner.  I'm dropping in my 850 and receiving the 997 to the send port, but I'm also receiving a 2nd document that is a copy of my 850 with the global party properties applies.

    The incoming header:
    ISA~00~          ~00~          ~01~123PARTNER      ~01~MY1234567     ~100111~1009~U~00400~000019127~0~P~>!
    GS~PO~PARTNER123~MY1234567~20100111~1009~13434~X~004010!
    ST~850~0145!

    The header that's showing up with the 997 as a duplicate, or rewritten 850
    ISA~00~          ~00~          ~ZZ~BTS-SENDER     ~ZZ~RECEIVE-PARTNER~100128~2242~U~00401~000000152~0~T~>!
    GS~ZZ~BTS-SENDER~RECEIVE-APP~20100128~2242~152~X~004010!
    ST~850~0145!

     

    You'll notice that in the original document, the Interchange Sender ID used (123PARTNER) is different than Sender's Code (PARTNER123).  Perhaps I haven't properly configured the Party for this scenario?

    I know that 'BTS-SENDER', 'RECEIVE-PARTNER' and 'RECEIVE-APP' are default values from the global settings, which tells me there's a Party resolution issue..  What I don't understand is why they're being applied here.  I know this means I haven't configured my Party correctly, but I've been over it a number of times - and after all, if the party were configured incorrectly the acknowledgement wouldn't be sent to the send port associated with the party.

    Has anyone seen this before?  Thank you very much for any thoughts you have.

    Nate

    Friday, January 29, 2010 1:29 PM

Answers

  • Hi,
        Please check . you may have two send ports suscribing to the same type of document. And one send port is associated to your party and other is not. So One output is coming with your party properties applied and one is with global party.

       Please check send ports filters.



    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    • Marked as answer by Nate Jacobs Friday, January 29, 2010 3:28 PM
    Friday, January 29, 2010 2:25 PM

All replies

  • Hi,
        Please check . you may have two send ports suscribing to the same type of document. And one send port is associated to your party and other is not. So One output is coming with your party properties applied and one is with global party.

       Please check send ports filters.



    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    • Marked as answer by Nate Jacobs Friday, January 29, 2010 3:28 PM
    Friday, January 29, 2010 2:25 PM
  • Gyan -

    That was exactly it.  Thank you VERY much. 

    Nate
    Friday, January 29, 2010 3:27 PM