none
Visual Studio stops responding while loading VS2015 solution

    Question

  • I have an existing VS 2015 solution. When I try to open that solution using Visual Studio Enterprise 2017, it hangs and doesn't respond. Please help.
    Tuesday, March 14, 2017 12:45 PM

Answers

  • Hi Vishwanath Uppala,

    Thanks for posting here.

    I have created some projects in one solution with Visual Studio 2015, then open the solution with Visual Studio 2017, but not encountered this issue. I would like give you some troubleshootings to resolve this issue:

    1. Is there great quantity projects in that solution which cause the hang? You can try create a new solution with several projects in Visual Studio 2015, then open it in the Visual Studio 2017.
    2. Check your projects whether include testsettings files or not, and if you rename or delete them, are you able to open the solution then?

    Besides, this issue is being discussed on the Microsoft Developer Community, and Visual Studio team are trying to investigate this issue. Hope you can find some help from the Developer Community:

    https://developercommunity.visualstudio.com/content/problem/24938/vs2017-not-responding-when-opening-a-solution.html

    You can also follow up your issue with this Developer Community.

    If above not help you, could you please share us a sample to reproduce this issue? Thanks.


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 15, 2017 7:49 AM

All replies

  • Hi Vishwanath Uppala,

    Thanks for posting here.

    I have created some projects in one solution with Visual Studio 2015, then open the solution with Visual Studio 2017, but not encountered this issue. I would like give you some troubleshootings to resolve this issue:

    1. Is there great quantity projects in that solution which cause the hang? You can try create a new solution with several projects in Visual Studio 2015, then open it in the Visual Studio 2017.
    2. Check your projects whether include testsettings files or not, and if you rename or delete them, are you able to open the solution then?

    Besides, this issue is being discussed on the Microsoft Developer Community, and Visual Studio team are trying to investigate this issue. Hope you can find some help from the Developer Community:

    https://developercommunity.visualstudio.com/content/problem/24938/vs2017-not-responding-when-opening-a-solution.html

    You can also follow up your issue with this Developer Community.

    If above not help you, could you please share us a sample to reproduce this issue? Thanks.


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 15, 2017 7:49 AM
  • Thanks Leo,

    Yes, I had Local.testsettings file, after deleting it the solution loaded in VS2017. Is this known issue?

    Wednesday, March 15, 2017 9:21 AM
  • Hi Vishwanath Uppala,

    I'm glad that help to you. This issue is encountered by many people, but this issue is being discussed by Visual Studio team, the results will be announced soon, you can follow up with above link for the final results.


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 15, 2017 11:48 AM