locked
Remote Access and Windows Firewall RRS feed

  • Question

  • Hi all,

    I have a Windows Server 2003 with SQL Server 2005.
    I´ve configured the following itens to allow remote connecitions:

    [code]
    WORKAROUND
    Warning If you use Registry Editor incorrectly, you may cause
    serious problems that may require
    you to reinstall your operating system. Microsoft cannot
    guarantee that you can solve problems that result from using
    Registry Editor incorrectly. Use Registry Editor at your own
    risk.To work around this problem, follow these steps on the
    computer that Windows XP SP2 is installed on:

    1.    Make sure that the Log On As account for the MSDTC service
    is the Network Service account. To do this, follow these steps:
    a.     Click Start, and then click Run.
    b.     In the Run dialog box, type Services.msc, and then click OK.
    c.     In the Services window, locate the Distributed Transaction
    Coordinator service under Name in the right pane.
    d.     Under the Log On As column, see whether the Log On As
    account is Network Service or Local System.

    If the Log On As account is Network Service, go to step 2.
    If the Log On As account is Local System, continue with these steps.
    e.     Click Start, and then click Run.
    f.     In the Run dialog box, type cmd, and then click OK.
    g.     At the command prompt, type Net stop msdtc to stop the MSDTC service.
    h.     At the command prompt, type Msdtc –uninstall to remove MSDTC.
    i.     At the command prompt, type regedit to open Registry Editor.
    j.     In Registry Editor, locate, and then delete the following subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC
    k.     Close Registry Editor.
    l.     At the command prompt, type Msdtc –install to install MSDTC.
    m.     At the command prompt, type Net start msdtc to start
    the MSDTC service.

    Note The Log On As account for the MSDTC service is set
    to the Network Service account.

    2.    To allow the network transaction, you must enable
    MSDTC. To do this, follow these steps:
    a.     Click Start, and then click Run.
    b.     In the Run dialog box, type dcomcnfg.exe, and then click OK.
    c.     In the Component Services window, expand Component
    Services, expand Computers, and then expand My Computer.
    d.     Right-click My Computer, and then click Properties.
    e.     In the My Computer Properties dialog box, click
    Security Configuration on the MSDTC tab.
    f.     In the Security Configuration dialog box, click to
    select the Network DTC Access check box.
    g.     To allow the distributed transaction to run on this
    computer from a remote computer, click to select the Allow Inbound check box.
    h.     To allow the distributed transaction to run on a
    remote computer from this computer, click to select the Allow
    Outbound check box.
    i.     Under the Transaction Manager Communication
    group, click to select the No Authentication Required option.
    j.     In the Security Configuration dialog box, click OK.
    k.     In the My Computer Properties dialog box, click OK.


    3.    Configure Windows Firewall to include the MSDTC
    program and to include port 135 as an exception. To do this,
    follow these steps:

    a.     Click Start, and then click Run.
    b.     In the Run dialog box, type Firewall.cpl, and then click OK.
    c.     In Control Panel, double-click Windows Firewall.
    d.     In the Windows Firewall dialog box, click Add
    Program on the Exceptions tab.
    e.     In the Add a Program dialog box, click Browse,
    and then locate the Msdtc.exe file. By default, the
    file is stored in the Installation drive:\Windows\System32 folder.
    f.     In the Add a Program dialog box, click OK.
    g.     In the Windows Firewall dialog box, click to select
    the msdtc option in the Programs and Services list.
    h.     Click Add Port on the Exceptions tab.
    i.     In the Add a Port dialog box, type 135 in the Port
    number text box, and then click to select the TCP option.
    j.     In the Add a Port dialog box, type a name for the
    exception in the Name text box, and then click OK.
    k.     In the Windows Firewall dialog box, select the name
    that you used for the exception in step j in the
    Programs and Services list, and then click OK.
    [/code]

    But, when the Windows firewal on the server is "On", remote connections
    are not allowed, despite I´ve configured the Exceptions on the firewall.

    Is there another task to solve this problem?

    thanx!!!!
    Wednesday, September 20, 2006 1:37 PM

Answers

  • Sorry, I´ve posted like a new thread....

    Now it´s working!!!!

    On the firewall server, I´ve added the default por 1433.
    Wednesday, September 20, 2006 2:27 PM