locked
Can't retrieve Stream Analytics sample data from IoTHub RRS feed

  • Question

  • Hi, I am currently running numerous ASA jobs, that are all receiving and processing data. However, when I try to extract a sample, I receive the following error:

    No events found for 'iniothub'

    No events found for 'iniothub'. Start time: Donnerstag, 27. Juli 2017, 10:06:34 End time: Donnerstag, 27. Juli 2017, 10:09:34 Last time arrival: Donnerstag, 27. Juli 2017, 14:08:25 Diagnostics: While sampling data, no data was received from '24' partitions.

     

    The input source is a IoTHub. I have tried with different time periods and various other stream analytics jobs I have running (connected to the same IoTHub) - all with the same error. Note that data is coming in, and has been for the past few days. 

    Any suggestions how to resolve this issue ?

    Thanks,

    Martin

    Thursday, July 27, 2017 2:12 PM

All replies

  • Hi,

    Thanks for reporting this. We're sorry for the inconvenience. Let me look what happens with the sample data feature.

    Thanks

    JS

    Thursday, July 27, 2017 4:01 PM
  • Hi -  thanks for the quick reply! Any chance you can tell me by when this issue is investigated/ resolved?

    Thanks,

    Martin

    Friday, July 28, 2017 10:29 AM
  • Hi Martin,

    Here's the different reasons that bring this error message:

    1. No data is received
    2. ASA receives data, but there is a serialization error (e.g. not a valid JSON format)
    3. IoT Hub or Event hub takes time to establish connection. In some cases, ASA times out before receiving the first event from Iot Hub or Event Hub. In this case, a workaround would be to use a longer time range (e.g. 1 hour). You can set the starting time in the past, so you don't have to wait 1 hour.

    You may experience the 3rd issue mentioned. Can you try the workaround and let us know if it fixes the problem.

    Thanks,

    JS

    Monday, July 31, 2017 6:23 PM
  • Hi JS,

    Thank you for your reply.

    Note that we are receiving data to the IoTHub and actively using this in multiple stream analytics jobs. So receiving and processing the json data is not the problem. Only when we want to get SAMPLE data, we get an error message. I have increased the time, see below, and it is still not working.

    No events found for 'iniothub'
    <time class="fxs-notificationmenu-notification-title-subtitle fxs-portal-title" data-bind="attr: { datetime: $root.func._timestampToString(timestamp) }, text: $root.func._timestampToString(timestamp)" datetime="13:16" style="font-weight:inherit;line-height:18px;margin-right:15px;color:#444444;"></time>
    No events found for 'iniothub'. Start time: Mittwoch, 2. August 2017, 09:14:01 End time: Mittwoch, 2. August 2017, 12:17:01 Last time arrival: Mittwoch, 2. August 2017, 13:15:53 Diagnostics: While sampling data, no data was received from '24' partitions.

    For the time period i selected for sample data we received around 80,000 messages.

    What else could this issue be related to?

    Best,

    Martin

    Wednesday, August 2, 2017 11:25 AM