locked
can not get asp.net to work RRS feed

  • Question

  • User-102514116 posted

    I have a vps I have installed asp.net 3.5 on it but wen I try to upload my default.aspx page the try to go to it I get file not found But the file is there I do have the iis 6.0 config to use asp.net I do not have any ides ?

    Wednesday, March 11, 2009 3:59 PM

Answers

  • User-891060016 posted
    Could you please give me a bit more information?  I'm having a difficult time understanding exactly what your problem is.
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 12, 2009 2:17 AM
  • User-2058570687 posted

      Start>Run> type inetmgr and press enter

    Under Internet information services select "Default Web Site"

    Select Properties > Under Documents check the Enable Default Document selected
    Click on add button and add your page name there
    Click on OK button

    I hope this is your issue. If not please explain your problem.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 12, 2009 1:48 PM
  • User-102514116 posted

     the aspx page is in the list what it is after I upload any .aspx page in the wwwroot folder I get file not found but if I upload any html page it works .

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 13, 2009 6:40 PM
  • User-2058570687 posted

     Which version you are working with?. Check with this method use 127.0.0.1 instead of localhost to run your aspx page.

    ie http:\\127.0.0.1\yourpage.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 3:23 AM
  • User-102514116 posted

     I useing 3.5 . I have tryed both and also when I try to goto my domain I get I do have iis config to use  asp.net I have asp.net 2.0 installed

    The page cannot be found

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 12:42 PM
  • User-2058570687 posted

     Dear Friend,

    Your problem can occur due to any of the following situation, i have listed it and steps to tackle it efficiently. So try and let me know the result

    Problems

     1. Default environment not set

    2.  Your windows defender update causing localhost to be declared explicitly

    So try following steps to solve the issue

     <meta http-equiv="CONTENT-TYPE" content="text/html; charset=utf-8"><title></title><meta name="GENERATOR" content="OpenOffice.org 3.0 (Win32)"><style type="text/css"> <!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } --> </style>

    Default environment

     Start>Run> type inetmgr and press enter

    Under Internet information services select "Default Web Site"

    Select Properties >Under Asp.net Tab select 2.0........

    and click on apply button to apply the changes


    Cannot connect localhost

    remove the next line in the windows host file C:\Windows\System32\drivers\etc\hosts

    ::1 localhost

    This is an IpV6 entry. Put a # in front of it. "

    Instead of commenting this IpV6 entry adding the following IpV4 entry above this line also helps:

    127.0.0.1 localhost


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 1:40 PM
  • User-102514116 posted

     I got it to work it was turned off it Web Service Extensions

     

    Thank you for all your help 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 5:28 PM

All replies

  • User-891060016 posted
    Could you please give me a bit more information?  I'm having a difficult time understanding exactly what your problem is.
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 12, 2009 2:17 AM
  • User-2058570687 posted

      Start>Run> type inetmgr and press enter

    Under Internet information services select "Default Web Site"

    Select Properties > Under Documents check the Enable Default Document selected
    Click on add button and add your page name there
    Click on OK button

    I hope this is your issue. If not please explain your problem.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 12, 2009 1:48 PM
  • User-102514116 posted

     the aspx page is in the list what it is after I upload any .aspx page in the wwwroot folder I get file not found but if I upload any html page it works .

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 13, 2009 6:40 PM
  • User-2058570687 posted

     Which version you are working with?. Check with this method use 127.0.0.1 instead of localhost to run your aspx page.

    ie http:\\127.0.0.1\yourpage.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 3:23 AM
  • User-102514116 posted

     I useing 3.5 . I have tryed both and also when I try to goto my domain I get I do have iis config to use  asp.net I have asp.net 2.0 installed

    The page cannot be found

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 12:42 PM
  • User-2058570687 posted

     Dear Friend,

    Your problem can occur due to any of the following situation, i have listed it and steps to tackle it efficiently. So try and let me know the result

    Problems

     1. Default environment not set

    2.  Your windows defender update causing localhost to be declared explicitly

    So try following steps to solve the issue

     <meta http-equiv="CONTENT-TYPE" content="text/html; charset=utf-8"><title></title><meta name="GENERATOR" content="OpenOffice.org 3.0 (Win32)"><style type="text/css"> <!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } --> </style>

    Default environment

     Start>Run> type inetmgr and press enter

    Under Internet information services select "Default Web Site"

    Select Properties >Under Asp.net Tab select 2.0........

    and click on apply button to apply the changes


    Cannot connect localhost

    remove the next line in the windows host file C:\Windows\System32\drivers\etc\hosts

    ::1 localhost

    This is an IpV6 entry. Put a # in front of it. "

    Instead of commenting this IpV6 entry adding the following IpV4 entry above this line also helps:

    127.0.0.1 localhost


    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 1:40 PM
  • User-102514116 posted

     I got it to work it was turned off it Web Service Extensions

     

    Thank you for all your help 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 5:28 PM