locked
Error while processing breakpoint RRS feed

  • Question

  •  I recently upgraded to VS 2013.  I am programming in C++.  I have a production code that has been running fine in release mode.  I had a bug crop up and re-compiled in debug x64.  It runs fine unless I set a break point.   If I do, I get the error:  "The following breakpoint cannot be set:.... Error while processing breakpoint." After closing a window for each breakpoint, I then get the error "Execution has stopped at the beginning of the program because one or more breakpoints could not be set".

    I have read through some forums and have tried a number of remedies for similar problems.  For example,  I have done a clean and rebuild.  I have deleted my %tmp% directory.  I have cleaned out my Microsoft.Net\vx.x\Temporary directories.   I've close out VS and restarted, and then did a clean rebuild again.  So far nothing has been successful.  I am open to any suggestions anyone has. Thanks.

    Wednesday, November 26, 2014 11:59 PM

Answers

  • Hi Ged40,

    Do you install the same update package for your VS2013 as other members? The latest VS2013 update package is update 4.

    >> As far as exporting settings, I should have effectively done this for this project b/c this is a multi-developer code kept in a repository, and we all migrated to VS2013 at the same time, and I imported the project files directly.  However, I'm the only developer with this issue.   I also purchased a new Windows 7 computer and installed VS2013 directly, rather than migrating up to VS2013 from 2010 on the same system.

    Actually one important issue is that which VS version your team members use for the old project, since it seems that you mean that other members update it from VS2010 to VS2013, it seems that the previous project was developed by an older version like VS2008 or others, am I right? Other members update it to VS2010, and then update with VS2013, but you just update the old project with VS2013 directly, am I right?

    If so, I doubt that the real issue is related to the Visual Studio 2013 Compatibility.

    Reference:

    http://msdn.microsoft.com/en-us/library/hh266747.aspx

    Based on the above document, we know that generally we could merge project to VS2013 if we use the VS2012 and VS2010 (install SP1). So if this project was developed by VS2008 or others, please merge the project with the closed VS version like VS2010, and then update it with VS2013, so we could make sure that whether it is the update issue.

    >>I then did a fresh checkout of the code, and recompiled in debug mode. 

    But if you mean that it is the VS2010 project, do you mean that you use certain version control tool like TFS? Not very sure that whether it is related to the TFS or VS IDE, one idea is that you could copy other members’ project which work well to your machine, and then run it again.

    In addition, please make sure that other member could run/debug it will with the default VS settings.

    http://msdn.microsoft.com/en-us/library/ms247075(v=vs.100).aspx

    If so, please re-open the new project copied from other machine in your VS IDE, and then reset your VS settings, , clean and rebuild the whole solution, test it again. 

    If still no help, at least we could make sure that it is not the VS settings issue since other members use the same default settings.

    If I have misunderstood this issue, please make free to let me know.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, December 4, 2014 2:58 AM

All replies

  • Hi Ged40,

    >>I recently upgraded to VS 2013.  I am programming in C++. 

    If so, which VS version did you use before? Since release mode is different from the debug mode,  so if possible, please disable all breakpoints in your project, and then clean and rebuild your whole solution in debug mode, do you get any warning or error message in Error list or Output window?

    I doubt that you have some referenced library files in your project properties' settings, for example, it doesn't load them correctly or others. Please also check symbols loaded in your modules window if you debug it.

    http://stackoverflow.com/questions/2787999/one-or-more-breakpoints-cannot-be-set-and-have-been-disabled-execution-will-st

    To make sure that it is not your VS IDE issue, maybe you could debug it in other VS machine, so we could make sure that whether it is the VS IDE or project issue.

    Since it is hard for us to repro this issue, maybe you could share us a simple sample, I will debug it in my side using the same Environment as yours. You could upload your project sample to the onedrive and share us the download link here. 

    Best Regards,

    Jack 


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, November 28, 2014 9:50 AM
  • Jack,

    Thanks for your response.  I migrated from VS 2010 to VS 2013.  I definitely had already disabled all breakpoints, and did a clean and rebuild.  It runs fine.  I can even do a break all and step around using f10 or f11 keys.  If I set a break point at this point, it crashes VS 2013.

    I opened the debug->windows->modules while running in debug mode, and the symbol status shows me the symbols are loaded for my executable.  The DLL's I am linked to do not have symbols loaded (such as msvcp120d.dll, etc.), but this is expected.

    I tried running on another platform using VS2013, and it runs fine in debug mode with breakpoints.  This tells me it is something on my system.

    What I did do is to change Properties->ConfigurationProperties->Debugging->DebuggerType to "Mixed"  (changed from the default choice "auto").  This actually fixed the problem.   I don't understand why this fixed the problem, since it is working just fine on another system running VS2013 with "Auto" selected here.   Perhaps you have some insight about this.  Thanks!

    Monday, December 1, 2014 9:10 PM
  • Hi Ged40,

    We know that there are two scenarios for doing mix debugging, depending on whether the DLL or the application is written in native code:

    1. The calling application that calls your DLL is written in native code. In this case your DLL is managed, and both managed and native debuggers must be enabled to debug both. You can check this in the <Project> Property Pages dialog box. How you do this depends on whether you start debugging from the DLL project or the calling application project.
    2. The calling application that calls your DLL is written in managed code and your DLL is written in native code.

    So your project type is the first one, am I right?

    >> What I did do is to change Properties->ConfigurationProperties->Debugging->DebuggerType to "Mixed"  (changed from the default choice "auto").  This actually fixed the problem.   I don't understand why this fixed the problem, since it is working just fine on another system running VS2013 with "Auto" selected here.   Perhaps you have some insight about this.  Thanks!

    If you make sure that the same project works well with different debugger settings, I doubt that it would be related to other settings, could you check the options under TOOLS->Options->Debugging like the following screen shot in your two VS Environments?

    1. Do you enable “Use Managed Compatibility Mode” like C?
    2. Do you enable “Edit and Continue” like B?

    If still no help, not a good suggestion, just a workaround is that export another VS settings which worked well with Auto debugging to your current VS, test it again, so we could make sure that whether it is the VS settings’ issue.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, December 2, 2014 2:03 AM
  • Jack,

    Thanks again.  In response to your questions:  Your #1 is correct.  The application is written in native code.  The DLL's are called by the application and are managed code (such as Intel MKL DLL libraries, etc.).   Note that any breakpoints that I was trying to set were in the native application code.


    Response to your next question:  No, I am not enabling use managed compatibility mode.  To my understanding, this turns on the legacy debugging engine, and thus I have not selected this.


    Yes, I have Enable edit and continue" checked.  I do not have .  Though, I do not have "Enable native Edit and Continue" checked.

    As far as exporting settings, I should have effectively done this for this project b/c this is a multi-developer code kept in a repository, and we all migrated to VS2013 at the same time, and I imported the project files directly.  However, I'm the only developer with this issue.   I also purchased a new Windows 7 computer and installed VS2013 directly, rather than migrating up to VS2013 from 2010 on the same system.

    New update:   After running several debugging sessions this afternoon, I started getting the breakpoint error again even with mixed debugging.  I tried recompiling, closing the project, and coming back in.  All of these attempts failed.  I then did a fresh checkout of the code, and recompiled in debug mode.  I received the breakpoint errors for auto debug mode (default).  Choosing mixed, it allows me to run with breakpoints again.


    • Edited by Ged40 Tuesday, December 2, 2014 8:51 PM
    Tuesday, December 2, 2014 5:12 PM
  • Hi Ged40,

    Do you install the same update package for your VS2013 as other members? The latest VS2013 update package is update 4.

    >> As far as exporting settings, I should have effectively done this for this project b/c this is a multi-developer code kept in a repository, and we all migrated to VS2013 at the same time, and I imported the project files directly.  However, I'm the only developer with this issue.   I also purchased a new Windows 7 computer and installed VS2013 directly, rather than migrating up to VS2013 from 2010 on the same system.

    Actually one important issue is that which VS version your team members use for the old project, since it seems that you mean that other members update it from VS2010 to VS2013, it seems that the previous project was developed by an older version like VS2008 or others, am I right? Other members update it to VS2010, and then update with VS2013, but you just update the old project with VS2013 directly, am I right?

    If so, I doubt that the real issue is related to the Visual Studio 2013 Compatibility.

    Reference:

    http://msdn.microsoft.com/en-us/library/hh266747.aspx

    Based on the above document, we know that generally we could merge project to VS2013 if we use the VS2012 and VS2010 (install SP1). So if this project was developed by VS2008 or others, please merge the project with the closed VS version like VS2010, and then update it with VS2013, so we could make sure that whether it is the update issue.

    >>I then did a fresh checkout of the code, and recompiled in debug mode. 

    But if you mean that it is the VS2010 project, do you mean that you use certain version control tool like TFS? Not very sure that whether it is related to the TFS or VS IDE, one idea is that you could copy other members’ project which work well to your machine, and then run it again.

    In addition, please make sure that other member could run/debug it will with the default VS settings.

    http://msdn.microsoft.com/en-us/library/ms247075(v=vs.100).aspx

    If so, please re-open the new project copied from other machine in your VS IDE, and then reset your VS settings, , clean and rebuild the whole solution, test it again. 

    If still no help, at least we could make sure that it is not the VS settings issue since other members use the same default settings.

    If I have misunderstood this issue, please make free to let me know.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Thursday, December 4, 2014 2:58 AM