locked
error '8002801d' on Windows 10 Pro, RRS feed

  • Question

  • User-1351844424 posted

    Hello,

    I have many classic ASP pages sitting on my Windows 10 Pro machines (OS build 17134.112) with IIS Version 10.0.17134.1

    Many of these ASP pages use MS Access database (2007 version) as the data source, I wasn't having any problem working with these ASP files, they launched without any errors on localhost testing for years.

    But today suddenly when I test these ASP files on my Windows 10 Pro machine, they show the error message:
    error '8002801d'

    These ASP files were working fine for years, they were working fine 5 days ago but now they are showing the error message "error '8002801d'" Only ASP files with MS Access database connection shows me this error. All database folder permissions are set correctly.

    I have another exactly same Windows 10 Pro machine and when I launch the ASP files on that machine same thing happens, exactly same error message error '8002801d' shows up. So I don't think the error has been caused by me, I didn't touch anything on Windows 10 system registry. It could have been caused by Windows 10 Pro 'Windows Update' but I am not sure.

    I tried to do System restore to restore the Windows 10 Pro machine to the previous restore point, (3 weeks before) but even System restore is not working - showing me the error message, error encountered while doing system restore...

    I have already tried re-registering vbscript dll files and many others (jscript.dll etc.) but didn't fix the problem.

    How can I fix this error?

    Monday, June 25, 2018 1:10 AM

All replies

  • User121216299 posted

    Hi ZKM128,

    You had mentioned that,"I have already tried re-registering vbscript dll files and many others (jscript.dll etc.)".

    This error get occurs when DLL file not get registered properly, in your case it is possible that something got corrupted cause this issue.

    You can try to re-register the ASP.DLL file and check whether it helps to solve the issue or not.

    If the error message shows any specific DLL file name then try to re register that DLL file.

    Reference:

    Getting Error ‘8002801d’ Library not registered on ASP files

    Regards

    Deepak

    Tuesday, June 26, 2018 5:15 AM