locked
How do I configure access for users from another domain? RRS feed

  • Question

  • I'm beginning to think I'm missing something basic. My users in the other domain can access the TFS but can't see Documents or Reports (without setting DNS suffixes on their machines) because those URLs include an unqualified server name.

    Can anyone help me fix this?

    Thanks in advance.

    Thursday, February 9, 2006 3:43 PM

Answers

  • With the RC bits you can force a Fully Qualified Domain Name (FQDN) to be used for SharePoint and SQL Reporting Services after the initial install and without editing database table entries.  Here is how it is done:

    1) Open a command shell and cd to "%programfiles%\Microsoft Visual Studio 2005 Team Foundation Server\Tools" on the TFS AT machine.

    2) Run "tfsadminutil activateat <FQDN>"

    There is one additional step that needs to be performed to get reports on the SharePoint site working correctly.  Update the Key value of the following registry location with the FQDN: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\8.0\TeamFoundation\ReportServer.

    Friday, February 10, 2006 12:40 AM
  • The above responses were for fully qualified names, not for permission.  For permissions, you will need to have the user added to the WSS Sharepoint Administrators group (to create projects) or to the corrisponding Site administration (to just access wss).

    Do you remember when setting the "Sharepoin Administrators Group" on the Sharepoint Admin Site.  You will need to make sure that the other domain users are members of this group.

    Friday, February 10, 2006 7:17 PM

All replies

  • While this isn't tested, you could certainly open the database and add them.

    Go to the DT and open the following table:

    TFSIntegration.dbo.tbl_service_interface

     

    Where you see the links for the WSS, Reporting and Sharepoint Admin, placed fully qualified names in the URL.

     

    Let us know if that works.

     

    Thursday, February 9, 2006 6:16 PM
  • There is a way you can do before installation of the server that would help you resolve this. 

    1. You can copy msiproperty.ini from the folder of the server product you are installing onto a local directory (ie. c:\msiproperty.ini),
    2. Edit the ini file and change [ComputerName] to the actuall fully qualified name of the machine. 
    3. Then , start the installation as follows: <MediaPath>\setup.exe /INIFILE=c:\msiproperty.ini

    This should solve your problem.

    Thanks,
    Elyasse
    Thursday, February 9, 2006 7:57 PM
  • With the RC bits you can force a Fully Qualified Domain Name (FQDN) to be used for SharePoint and SQL Reporting Services after the initial install and without editing database table entries.  Here is how it is done:

    1) Open a command shell and cd to "%programfiles%\Microsoft Visual Studio 2005 Team Foundation Server\Tools" on the TFS AT machine.

    2) Run "tfsadminutil activateat <FQDN>"

    There is one additional step that needs to be performed to get reports on the SharePoint site working correctly.  Update the Key value of the following registry location with the FQDN: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\8.0\TeamFoundation\ReportServer.

    Friday, February 10, 2006 12:40 AM
  • I've done those things, but I still can't get the reports or documents to work.  I even just used the ip address and it doesn't seem to work.  Now, I have taken the actual web service url, for instance http://<ip address>:17012/_vti_adm/admin.asmx?wsdl and was prompted for a login.  I entered the credentials of the domain account, but I still couldn't access the web service.  So far, the only thing that has resloved this has been to give administrator rights to the user on the TFS Server box.  I don't think this has to do with connectivity, but permissions themselves, but I still can't seem to get this to work. 

    Help!

    Friday, February 10, 2006 1:51 PM
  • The above responses were for fully qualified names, not for permission.  For permissions, you will need to have the user added to the WSS Sharepoint Administrators group (to create projects) or to the corrisponding Site administration (to just access wss).

    Do you remember when setting the "Sharepoin Administrators Group" on the Sharepoint Admin Site.  You will need to make sure that the other domain users are members of this group.

    Friday, February 10, 2006 7:17 PM
  • I can access the Sharepoint portal page and the webservices outside of the team system explorer with the same authentication that I'm using in the team system.  The same login that if I'm within the domain works fine.
    Friday, February 10, 2006 8:09 PM
  • Access to the sharepoint portal pages is different from having permission to create projects.  Depending on your final goal, you will need to set the permissions correctly.
    Friday, February 10, 2006 10:29 PM
  • Actually, this is just about access, not creating a team project. The team project has already been created, but the team explorer shows red X's over the Reports and Documents folder.  The Workitem, Build and Source Control Explorer work fine.  I can access the sharepoint portal site for the project from Internet Explorer with the same credentials used to connect in Team Explorer.
    Saturday, February 11, 2006 4:17 AM
  • Bill Essary, your solution appears to have solved my problem - thanks very much.

    I wonder if this scenario could be addressed at install/setup time?

    Monday, February 13, 2006 1:18 PM
  • This scenario could have been better addressed at setup time by chosing to use the FQDN instead of the NetBIOS name for the server.  We had a discussion about making that change late in the cycle, but it was postponed out of this release because we had a number of higher priority issues working their way through setup.

    Monday, February 13, 2006 9:07 PM
  • This sounds very similar to the trouble I am having with TFS 2007. 
    Can your suggestion be applied to TFS 2007 as well?

    Thanks.
    Thursday, May 21, 2009 7:17 AM