none
Workflow Manager - Workflow Status - NotStarted RRS feed

  • Question

  • Hi,

    I have been struggling to get a very basic workflow to run in our own instance of workflow manager. I understand that the issue is likely to be with our workflow manager setup however I am struggling to diagnose the issue.

    So far I have confirmed that I can publish the workflow and start an instance using client.Workflows.Start("TestWorkflow"); but the workflow remains in the 'NotStarted' state. No code exceptions are thrown and if I use client.WaitForWorkflowCompletion("TestWorkflow", instanceId1); the application will wait forever.

    To help find the issue I have tried the following:

    • Restart the server
    • Uninstall/reinstall
    • I have proven the workflow executes in a simple workflow manager setup using an Azure VM, however I cannot get our own hosted instance to work.
    • I have checked the Microsoft-Worflow even logs (Admin, Operational, Analytic & Debug) and see nothing obvious.
    • I have enabled tracing of the System.Activities and Micrsoft.Activities however see nothing as the workflows are never started.
    • I have verified that both the front end website and back end service are running.

    Can anyone offer advice on what else I could check as I have no exceptions or logs and I am at a loss? Its as if everything has worked to queue the workflow instance to be run but nothing is choosing to run it.

    Thanks,

    Craig

    Monday, June 9, 2014 1:52 PM

All replies