none
WCFCustomAdapter for SAP RRS feed

  • Question

  •  

    Hi All,

     

    I am using WCFCustom Adapter for receiving files from SAP. When an Idoc is posted from SAP, I don't know where the problem is.. but my application is receiving the file after a long time may be an hour or so and processing in few seconds.

     

    Here the only problem is my biztalk application is taking the input file from SAP after a long time since the Idoc is posted from SAP.

     

    Please help me regarding this.

     

    Regards,

    SriRam.K

    Tuesday, September 30, 2008 7:21 AM

All replies

  •  

    SriRam, can you please provide more details:

     

    - BizTalk/SQL setup hardware and application infrastructure

    - Is BizTalk running physical/virtual?

    - Is SQL Server physical/virtual?

    - Are you using the SAP binding?

    - SAP server system?

    - Windows eventlog entries on BizTalk/SQL machine?

    - WCF tracing enabled?

    - Performance counters (BizTalk/SQL) taken?

    - Netmon trace?

     

    Did you try to have BizTalk send the idocs to a file destination and have a receive location polling that idocs?

     

    Please explain the message flow and how you notice that receiving is slow.

     

    Perhaps you want to open a support request with PSS and have them take a BizTalk trace.

     

    Thanks,

    Stefan

    Tuesday, September 30, 2008 11:45 AM
  • Hi Stefan,

     

    Thanks for a quick response,

     

    Infact, I would like to change my question...Instead of putting it as "my biztalk application is taking the input file from SAP after a long time since the Idoc is posted from SAP"

     

    I would like to say my application is processing the file after every restart of the host instances. I mean my application is requiring a restart of the host instances to process the input file.

     

    I am using WCF Custom adapter.

     

    - Is BizTalk running physical/virtual? physical

    - Is SQL Server physical/virtual? virtual

    - Are you using the SAP binding? Yes

    - SAP server system?

    - Windows eventlog entries on BizTalk/SQL machine?

    - WCF tracing enabled? no

    - Performance counters (BizTalk/SQL) taken? no

    - Netmon trace? no

     

    I am new to BizTalk, so I might not be so clear to you.. 

     

    Regards,

    SriRam.K

     

    Tuesday, September 30, 2008 12:48 PM
  • Can you change the receiveTimeout binding property on sapBinding to a large value (e.g., 23:59:59) and see if that solves the issue?

     

    Tuesday, September 30, 2008 1:04 PM