locked
Can't install NuGet-Packages RRS feed

  • Question

  • User201220 posted

    I have a problem with NuGet installing the "Xamarin.JOSE.JWT" package. I get the following error:

    Could not install package 'Xamarin.JOSE.JWT 1.0.3'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v6.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

    Is this a known problem or is there a workaround for this? I already had a similar problem (http://forums.xamarin.com/discussion/comment/186116#Comment_186116) but unfortunatley this solution doesn't work here.

    Monday, March 21, 2016 10:38 AM

Answers

  • User18049 posted

    Xamarin.JOSE.JWT does not have any assemblies for MonoAndroid. So you can either try to find another NuGet package, or see if the code compiles against Xamarin.Android, or try directly referencing the assembly and testing to see if it works (it may not if it uses part of the .NET Framework that is not supported by Xamarin.Android).

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, March 21, 2016 5:55 PM