locked
Samsung tablet windows 8 issue with .net buttons

    Question

  • Hi

    When I visit sites I have designed using .Net 4 that are working well,  if I am on the the samsung tablet and using IE on windows 8, some of the buttons on these webforms do not respond to click events.  Any ideas on why that is?

    Jose

    Monday, September 26, 2011 8:53 PM

All replies

  • JoseMontalvo,

    Are any of the sites that you are referring to published so that we can test them?

    Are you using the desktop version of Internet Explorer or the Touch Optimized version?

    Have you verified the .NET 3.5 in “Turn Windows Features on or off” has been activated?

    To do this go to the desktop version of the control panel àProgramsàUnder the header “Programs and Features” select “Turn Windows features on or off” àVerify that the .Net Framework 3.5.1 is activated, if not the activate.

    After this has been done, if you are still experiencing issues then make sure that all updates have been downloaded and applied.

    Please post back with your results.

    Thanks,


    Chris
    Tuesday, September 27, 2011 8:24 PM
  • Hi Chris

    1-Which one is the touch optimized version of IE?

    2-Net 3.5 is activated.

    3- the buttons that dont fire are buttons that I placed in Gridview objects  as ButtonFields.  Aparently they lose thier formatting also.  Unforetunately this is on a private corporate site and I cannot give you access to it.

    4-I am using the Samsung tablet with the installed software, I dont believe there are updates yet.

    thanks,

     

    Jose


    Add to that an application written with MVC3, again the buttons dont triger events.
    • Edited by JoseMontalvo Thursday, September 29, 2011 1:30 AM
    Wednesday, September 28, 2011 7:50 PM
  • JoseMontalvo,

    Are you having issues with all SilverLight websites or just ones that you have written\on you private corporate site?

    Thanks,


    Chris
    Thursday, September 29, 2011 1:56 PM
  • Have not tried with any Silverlight sites yet, I am not talking about silverlight.  But here is what I see:

    1-When I try to click a button that is embedded in a gridview as a buttonfield, the event is not fired.

    Jose

    Thursday, September 29, 2011 2:07 PM
  • JoseMontalvo,

    I apologize, I meant to ask if you have tried it with any .NET4 sites that are not your own. 

    Thanks,


    Chris
    Thursday, September 29, 2011 2:31 PM
  • No, I have not.  Not sure how helpful that is, have you heard about buttonfield issues from other developers?
    Thursday, September 29, 2011 6:15 PM
  • JoseMontalvo,

    I have not heard of this issue; however this forum is for General OS questions.  If you have questions about development then it would be best to post your question in the developer’s forum.

    Thanks,


    Chris
    Thursday, September 29, 2011 7:43 PM