locked
Excel Web Access "An error has occurred. Please contact your system administrator if this problem persists." RRS feed

  • Question

  • Ladies/Gents,

         Thank you for taking the time to view my problem.  I am attempting to use the Excel Web Access web part in SP2007 to view an *.xlsx file and receive the error in the title above.  I have tried multiple files to ensure I'm not trying to use a file with unsupported features.  I have also published the file(s).  I have them stored in the Shared Documents library and have added this location as a trusted file location in Shared Services.

    I'm at the point where I don't know what else to check.  Any help?  Thanks in advance for your time and effort!

    Tuesday, July 5, 2011 2:29 PM

Answers

  • I'm not sure what fixed this problem, but it appears to be fixed now.  What I ended up doing is recycling the app pools and restarting the web site.  I also set the app pools recycle based on another developer's recommendation.  Since these changes were made, the web part has worked perfectly.
    • Marked as answer by AFBurd Thursday, July 28, 2011 3:02 PM
    Thursday, July 28, 2011 3:02 PM

All replies

  • Hi AFBurd,

    You can locate to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\LOGS, reproduce the error and open the newest log file, then find out and post the error log here, we can see more error information.

    And there is another post with the same error message, you can check it.
    http://social.msdn.microsoft.com/Forums/en/sharepointexcel/thread/0a2aee88-52fa-4d1b-91e2-edff8d318a65

    Thanks,
    Daniel

    Regards, Daniel
    Thursday, July 7, 2011 9:55 AM
    Moderator
  • Hi Daniel, thanks for your reply.  As the log file is on a classified system that does not touch the internet, I have no way of knowing how to go about showing you the log file.  As for the other thread, I did an IISreset and the web part did display the excel spreadsheet ONCE, and then it went right back to the original error message.
    Tuesday, July 12, 2011 4:28 PM
  • Hi AFBurd,

    You can check the "Excel Calculation Services" and make sure it is started via the path Central Administration->Operations->Services on Server.

    For the error information in the log file under 12/LOGS, you can sort by Data Modified and open the latest log file, then jump to the end and analysis the relevent error entries, for more information you can refer to the following article.

    http://paulgalvinsoldblog.wordpress.com/2007/09/11/how-to-troubleshoot-mysterious-sharepoint-errors/

    Thanks,

    Daniel


    Regards, Daniel
    Wednesday, July 13, 2011 2:10 AM
    Moderator
  • Hi Daniel, Thanks again for your reply.  Excel Calculation Services is running.  I stopped and restarted it to see if that helped, but it didn't.

    I followed the steps in the link you gave me for capturing the error and came up with the following info:

    07/14/2011 15:50:09:04 w3wp.exe (0x1D9C) 0x111c Excel Services  Excel Services Cache  91zq  Medium  BaseWorkbookManager.BeginGetBaseWorkbookAndMarkUsed: Got an error when trying to fetch file from file loader.  Error was System.IO.DirectoryNotFoundException:  Could not find a part of the path 'C:\WINDOWS\TEMP\Excel Server\FileCache\MySharedServices1593209779\8773d44f-c937-425b-aef3-746b9fa16450.xlsx.xlserver'.

    I tried navigating to that location and the TEMP folder appears empty.

    Does this help at all?  Thanks again for your assistance.

    Thursday, July 14, 2011 8:42 PM
  • I'm not sure what fixed this problem, but it appears to be fixed now.  What I ended up doing is recycling the app pools and restarting the web site.  I also set the app pools recycle based on another developer's recommendation.  Since these changes were made, the web part has worked perfectly.
    • Marked as answer by AFBurd Thursday, July 28, 2011 3:02 PM
    Thursday, July 28, 2011 3:02 PM