none
svcutil/framework version RRS feed

  • Question

  • Hi.  I am running Windows XP, Framework 2.0 and working with Visual Studio 2005.  I've been told that I need the svcutil.exe for a project.   A while back I tried to upgrade my framework so I could get the svcutil, and I started having problems with Visual Studio.  So I removed the upgrade and went back to 2.0, and then things were fine.  I assumed that meant the 3.0 and 3.5 frameworks were for Vista users and/or Visual Studio 2008.  My questions are:

    1)  With my current software, should I upgrade my framework to 3.0 or 3.5?
    2)  If I don't upgrade, is there no other way to get the SVCUtil?

    Thanks!!
    Thursday, December 11, 2008 3:13 PM

Answers

  • Hi!
    .NET Fw 3.0 and 3.5 should work fine on your configuration, they are not only for Vista.

    Install both .NET Fw 2.0 and 3.0, as they can function well on the same machine.
    You can use Svcutil only if you have .net fw 3.0 or above installed.

    Regards,
    Lucian Baciu, MCTS, http://studentclub.ro/lucians_weblog
    • Marked as answer by SKK_ Thursday, December 11, 2008 5:40 PM
    Thursday, December 11, 2008 4:24 PM

All replies

  • Hi!
    .NET Fw 3.0 and 3.5 should work fine on your configuration, they are not only for Vista.

    Install both .NET Fw 2.0 and 3.0, as they can function well on the same machine.
    You can use Svcutil only if you have .net fw 3.0 or above installed.

    Regards,
    Lucian Baciu, MCTS, http://studentclub.ro/lucians_weblog
    • Marked as answer by SKK_ Thursday, December 11, 2008 5:40 PM
    Thursday, December 11, 2008 4:24 PM
  • Great.  Thanks so much!!
    Thursday, December 11, 2008 5:40 PM